Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

I cannot get my wireless to associate. As per one of the ‘sticky’s’ I’ve collected the following info. I have two laptops one listed here, the other an Intel Centrino Ultimage 6300. Neither one will associate and both have similar errors logged. Both have tumbleweed installed. The laptops both connect when running Windows. Any help appreciated.

lspci
02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

lspci -n
02:00.0 0280: 168c:002b (rev 01)

dmesg
6.207555] ieee80211 phy0: Selected rate control algorithm ‘minstrel_ht’
6.207956] ieee80211 phy0: Atheros AR9285 Rev:2 mem=0xffffa868c1030000, irq=17
6.210091] ath9k 0000:02:00.0 wlp2s0: renamed from wlan0
[36299.228984] wlp2s0: authenticate with 00:14:6c:51:ee:f0
[36299.250016] wlp2s0: send auth to 00:14:6c:51:ee:f0 (try 1/3)
[36299.253209] wlp2s0: authenticated
[36299.253444] ath9k 0000:02:00.0 wlp2s0: disabling HT/VHT due to WEP/TKIP use
[36299.253447] ath9k 0000:02:00.0 wlp2s0: disabling HT as WMM/QoS is not supported by the AP
[36299.253448] ath9k 0000:02:00.0 wlp2s0: disabling VHT as WMM/QoS is not supported by the AP
[36299.256239] wlp2s0: associate with 00:14:6c:51:ee:f0 (try 1/3)
[36299.360126] wlp2s0: associate with 00:14:6c:51:ee:f0 (try 2/3)
[36299.464088] wlp2s0: associate with 00:14:6c:51:ee:f0 (try 3/3)
[36299.572121] wlp2s0: association with 00:14:6c:51:ee:f0 timed out
[36300.638330] wlp2s0: authenticate with 00:14:6c:51:ee:f0
[36300.656121] wlp2s0: send auth to 00:14:6c:51:ee:f0 (try 1/3)
[36300.657764] wlp2s0: authenticated
…iwlist scan
lo Interface doesn’t support scanning.

enp1s0 Interface doesn’t support scanning.

wlp2s0 Scan completed :
Cell 01 - Address: 00:14:6C:51:EE:F0
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=70/70 Signal level=-39 dBm
Encryption key
ESSID:“HomeBase”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s
Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=00000015a1a7f346
Extra: Last beacon: 12ms ago
IE: Unknown: 0005427261756E
IE: Unknown: 010882848B960C183048
IE: Unknown: 030101
IE: Unknown: 2A0100
IE: Unknown: 32041224606C
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD0900037F0101000EFF7F
IE: Unknown: DD1A00037F030100000000146C51EEF002146C51EEF064002C010E08

from the system log
Feb 25 21:10:13 linux-b1w6 kernel: wlp2s0: send auth to 00:14:6c:51:ee:f0 (try 1/3)
Feb 25 21:10:13 linux-b1w6 kernel: wlp2s0: authenticated
Feb 25 21:10:13 linux-b1w6 kernel: ath9k 0000:02:00.0 wlp2s0: disabling HT/VHT due to WEP/TKIP use
Feb 25 21:10:13 linux-b1w6 kernel: ath9k 0000:02:00.0 wlp2s0: disabling HT as WMM/QoS is not supported by the AP
Feb 25 21:10:13 linux-b1w6 kernel: ath9k 0000:02:00.0 wlp2s0: disabling VHT as WMM/QoS is not supported by the AP
Feb 25 21:10:13 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 1/3)
Feb 25 21:10:13 linux-b1w6 NetworkManager[1016]: <info> [1488075013.0389] device (wlp2s0): supplicant interface state: authenticating -> associating
Feb 25 21:10:13 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 2/3)
Feb 25 21:10:13 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 3/3)
Feb 25 21:10:13 linux-b1w6 kernel: wlp2s0: association with 00:14:6c:51:ee:f0 timed out
Feb 25 21:10:13 linux-b1w6 NetworkManager[1016]: <info> [1488075013.3797] device (wlp2s0): supplicant interface state: associating -> disconnected
Feb 25 21:10:23 linux-b1w6 NetworkManager[1016]: <info> [1488075023.3924] device (wlp2s0): supplicant interface state: disconnected -> scanning
Feb 25 21:10:25 linux-b1w6 NetworkManager[1016]: <warn> [1488075025.8967] device (wlp2s0): Activation: (wifi) association took too long
Feb 25 21:10:25 linux-b1w6 NetworkManager[1016]: <info> [1488075025.8967] device (wlp2s0): state change: config -> need-auth (reason ‘none’) [50 60 0]
Feb 25 21:10:25 linux-b1w6 NetworkManager[1016]: <warn> [1488075025.9021] device (wlp2s0): Activation: (wifi) asking for new secrets

Hi
Are you really using WEP/TKIP on the Router/AP? Did you configure the correct wifi security in either NetworkManager or if using wicked, YaST Network Settings.

If you are using WEP, then suggest WPA, I have no issues with Atheros devices and ath9k driver.

Also check the password entered, maybe caps/num lock is/was on…?

Erm


IE: **WPA** Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP

So “only” WPA1 but certainly WPA and not WEP.

+1

AK

(sigh). i did a bit of homework before posting my question. i believe that the issue is with the wpa_supplicant because the logs suggest that it authenticates but does not associate. i have tried downloading the drivers from for both laptops and installing them in /lib/firmware. The problem persists. it works on the same hardware with a different OS which makes me believe that my problem is in the OpenSUSE software stack. i have also done a lengthly www search and i see that there are other people complaining about this endless cycle of authentication followed by association timeouts but have not found a solution. The posted logs are from a Sony Viao and the other laptop is a Samsung Series 9. Both are getting up in years but other than this issue are perfectly servicable. laptops. I am attempting to configure the network with Network Manager but have also tried with Wicked. The result is the same.

Any advice would be appreciated.

Hi
Maybe it doesn’t like WPA1 (Thank’s AK :slight_smile: ), can you switch to WPA2?

I have a HP and Dell systems here with Atheros devices, all work fine, but I use WPA2…

Am Sun, 26 Feb 2017 16:26:02 GMT
schrieb malcolmlewis <malcolmlewis@no-mx.forums.microfocus.com>:

> Maybe it doesn’t like WPA1 (Thank’s AK :slight_smile: ),

  1. you’re welcome

  2. just tested this with my own AR9285 card, no problems either with WPA1, WPA2
    or the sometimes problematic mixed mode.

> can you switch to WPA2?
>

A good idea in general, but I would add another suggestion for testing purposes.

Switch to WPA2 and use a simple passphrase without any special characters,
1234567890 will do for a simple test.

The usual suspect for such problems is misconfigured pass phrase, sometimes
not even by user mistake.

As you might know, wpa_supplicant can work with two different encodings for
pass phrases, the “real passphrase” and the respective base64 version obtained
from “wpa_passphrase ESSID real_passphrase”.

Now if $FRONTEND expects the one and trying to get the passphrase from the
router’s web interface or from another OS yields the other, then …

AK


Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)

With a new simple password and WPA2-PSK[AES] on the router I see basically the same thing.

Feb 26 12:34:40 linux-b1w6 NetworkManager[21035]: <info>  [1488130480.5538] device (wlp2s0): supplicant interface state: scanning -> authenticating
**Feb 26 12:34:40 linux-b1w6 kernel: wlp2s0: authenticated**
Feb 26 12:34:40 linux-b1w6 kernel: ath9k 0000:02:00.0 wlp2s0: disabling HT as WMM/QoS is not supported by the AP
Feb 26 12:34:40 linux-b1w6 kernel: ath9k 0000:02:00.0 wlp2s0: disabling VHT as WMM/QoS is not supported by the AP
Feb 26 12:34:40 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 1/3)
Feb 26 12:34:40 linux-b1w6 NetworkManager[21035]: <info>  [1488130480.5613] device (wlp2s0): supplicant interface state: authenticating -> associating
**Feb 26 12:34:40 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 2/3)
Feb 26 12:34:40 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 3/3)
Feb 26 12:34:40 linux-b1w6 kernel: wlp2s0: association with 00:14:6c:51:ee:f0 timed out**
Feb 26 12:34:40 linux-b1w6 NetworkManager[21035]: <info>  [1488130480.8987] device (wlp2s0): supplicant interface state: associating -> disconnected
Feb 26 12:34:50 linux-b1w6 NetworkManager[21035]: <info>  [1488130490.9125] device (wlp2s0): supplicant interface state: disconnected -> scanning
Feb 26 12:34:53 linux-b1w6 NetworkManager[21035]: <warn>  [1488130493.9879] device (wlp2s0): Activation: (wifi) association took too long
Feb 26 12:34:53 linux-b1w6 NetworkManager[21035]: <info>  [1488130493.9880] device (wlp2s0): state change: config -> need-auth (reason 'none') [50 60 0]
Feb 26 12:34:53 linux-b1w6 NetworkManager[21035]: <warn>  [1488130493.9934] device (wlp2s0): Activation: (wifi) asking for new secrets

With security set to none on the router I see this:

Feb 26 12:40:30 linux-b1w6 NetworkManager[21035]: <info>  [1488130830.3999] device (wlp2s0): supplicant interface state: inactive -> disabled
Feb 26 12:40:30 linux-b1w6 NetworkManager[21035]: <info>  [1488130830.4010] device (wlp2s0): state change: prepare -> config (reason 'none') [40 50 0]
Feb 26 12:40:30 linux-b1w6 NetworkManager[21035]: <info>  [1488130830.4020] device (wlp2s0): Activation: (wifi) connection 'HomeBase' requires no security.  No secrets needed.
Feb 26 12:40:30 linux-b1w6 NetworkManager[21035]: <info>  [1488130830.4024] Config: added 'ssid' value 'HomeBase'
Feb 26 12:40:30 linux-b1w6 NetworkManager[21035]: <info>  [1488130830.4029] Config: added 'scan_ssid' value '1'
Feb 26 12:40:30 linux-b1w6 NetworkManager[21035]: <info>  [1488130830.4033] Config: added 'key_mgmt' value 'NONE'
Feb 26 12:40:30 linux-b1w6 NetworkManager[21035]: <info>  [1488130830.4057] device (wlp2s0): supplicant interface state: disabled -> inactive
Feb 26 12:40:30 linux-b1w6 NetworkManager[21035]: <info>  [1488130830.4059] sup-iface[0xa3c0e0,wlp2s0]: config: set interface ap_scan to 1
Feb 26 12:40:30 linux-b1w6 NetworkManager[21035]: <info>  [1488130830.4214] device (wlp2s0): supplicant interface state: inactive -> scanning
Feb 26 12:40:31 linux-b1w6 kernel: wlp2s0: authenticate with 00:14:6c:51:ee:f0
Feb 26 12:40:31 linux-b1w6 NetworkManager[21035]: <info>  [1488130831.3690] device (wlp2s0): supplicant interface state: scanning -> authenticating
Feb 26 12:40:31 linux-b1w6 kernel: wlp2s0: send auth to 00:14:6c:51:ee:f0 (try 1/3)
**Feb 26 12:40:31 linux-b1w6 kernel: wlp2s0: authenticated**
Feb 26 12:40:31 linux-b1w6 kernel: ath9k 0000:02:00.0 wlp2s0: disabling HT as WMM/QoS is not supported by the AP
Feb 26 12:40:31 linux-b1w6 kernel: ath9k 0000:02:00.0 wlp2s0: disabling VHT as WMM/QoS is not supported by the AP
**Feb 26 12:40:31 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 1/3)
Feb 26 12:40:31 linux-b1w6 NetworkManager[21035]: <info>  [1488130831.3771] device (wlp2s0): supplicant interface state: authenticating -> associating
Feb 26 12:40:31 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 2/3)
Feb 26 12:40:31 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 3/3)
Feb 26 12:40:31 linux-b1w6 kernel: wlp2s0: association with 00:14:6c:51:ee:f0 timed out**
Feb 26 12:40:31 linux-b1w6 NetworkManager[21035]: <info>  [1488130831.7149] device (wlp2s0): supplicant interface state: associating -> disconnected
Feb 26 12:40:31 linux-b1w6 NetworkManager[21035]: <info>  [1488130831.8171] device (wlp2s0): supplicant interface state: disconnected -> scanning
Feb 26 12:40:32 linux-b1w6 kernel: wlp2s0: authenticate with 00:14:6c:51:ee:f0
Feb 26 12:40:32 linux-b1w6 NetworkManager[21035]: <info>  [1488130832.7673] device (wlp2s0): supplicant interface state: scanning -> authenticating
Feb 26 12:40:32 linux-b1w6 kernel: wlp2s0: send auth to 00:14:6c:51:ee:f0 (try 1/3)
Feb 26 12:40:32 linux-b1w6 kernel: wlp2s0: authenticated
Feb 26 12:40:32 linux-b1w6 kernel: ath9k 0000:02:00.0 wlp2s0: disabling HT as WMM/QoS is not supported by the AP
Feb 26 12:40:32 linux-b1w6 kernel: ath9k 0000:02:00.0 wlp2s0: disabling VHT as WMM/QoS is not supported by the AP
Feb 26 12:40:32 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 1/3)
Feb 26 12:40:32 linux-b1w6 NetworkManager[21035]: <info>  [1488130832.7744] device (wlp2s0): supplicant interface state: authenticating -> associating
Feb 26 12:40:32 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 2/3)
Feb 26 12:40:32 linux-b1w6 kernel: wlp2s0: associate with 00:14:6c:51:ee:f0 (try 3/3)
Feb 26 12:40:33 linux-b1w6 kernel: wlp2s0: association with 00:14:6c:51:ee:f0 timed out



Something has changed since OpenSuse 13.x. Prior to that both of these worked out of the box. Both laptops have a fresh install including all patches as of this weekend.

From the wpa_supplicant log:

SME: Trying to authenticate with 00:14:6c:51:ee:f0 (SSID='HomeBase' freq=2437 MHz)
wlp2s0: Trying to associate with 00:14:6c:51:ee:f0 (SSID='HomeBase' freq=2437 MHz)
wlp2s0: SME: Trying to authenticate with 00:14:6c:51:ee:f0 (SSID='HomeBase' freq=2437 MHz)
wlp2s0: Trying to associate with 00:14:6c:51:ee:f0 (SSID='HomeBase' freq=2437 MHz)
wlp2s0: SME: Trying to authenticate with 00:14:6c:51:ee:f0 (SSID='HomeBase' freq=2437 MHz)
wlp2s0: Trying to associate with 00:14:6c:51:ee:f0 (SSID='HomeBase' freq=2437 MHz)
wlp2s0: SME: Trying to authenticate with 00:14:6c:51:ee:f0 (SSID='HomeBase' freq=2437 MHz)
wlp2s0: Trying to associate with 00:14:6c:51:ee:f0 (SSID='HomeBase' freq=2437 MHz)
wlp2s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="HomeBase" auth_failures=1 duration=10 reason=CONN_FAILED
wlp2s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="HomeBase"
wlp2s0: SME: Trying to authenticate with 00:14:6c:51:ee:f0 (SSID='HomeBase' freq=2437 MHz)
wlp2s0: Trying to associate with 00:14:6c:51:ee:f0 (SSID='HomeBase' freq=2437 MHz)
wlp2s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="HomeBase" auth_failures=2 duration=20 reason=CONN_FAILED
wlp2s0: Reject scan trigger since one is already pending
.

Is wpa_supplicant user configurable?

Am Sun, 26 Feb 2017 17:56:01 GMT
schrieb dlbraun <dlbraun@no-mx.forums.microfocus.com>:

>

As we are talking about Tumbleweed (Question: Why?)

  • a buggy wpa_supplicant/NetworkManager

or

  • the latest “feature” of rnadomizing MAC addresses for scanning

come to mind as potential problems.

Search the forums for the latter (and think about installing leap or reporting
a bug for the first), I am sure this has been discussed several times here.

AK


Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)