QTCurve theme doesn't work for GTK apps all of a sudden

I want to use my QTCurve theme for GTK apps. This has worked great for several months on opensuse 11.2, and suddenly it broke. I do not know what made it broke, purhaps some kind of system update…

The gtk-Qtcurve engines are installed (both 32 and 64 bit). I tried linking the gtkrc file from /usr/share/themes/QtCurve/gtk-2.0 towards /etc/gtk-2.0 but that didn’t help either.

Can somebody help me out? I can change the GTK themes to whatever theme, except to QTCurve…

Please post output of

rpm -qa | grep qtcurve

Output from my laptop, where this works:

glosscomputer@LapTop:~> rpm -qa | grep qtcurve


I don’t see any problem in this. I suspect I have to link the correct gtkrc file in the correct directory. But don’t know which ones. Remember, it has worked before and I didn’t uninstall anything of qtcurve…

Aha, found something!

It seems that the GTK apps are using the default QTCurve settings, which look A LOT different from my agua QTcurve settings.

So I have to make the GTK apps use the same custom aqua style as the QT apps… Does somebody know how?

You are running different versions of qtcurve. Look at the version numbers. The qtcurve gtk2 packages show 0.68 while the qtcurve kde4 packages show 1.2.0.

I would suggest to you that you install an up to date version of qtcurve. That way you should get the most out of it. Me, I am using this repo at the moment for anything qtcurve:
Index of /repositories/home:/pantsgolem:/qtcurve/openSUSE_11.2_KDE4_UNSTABLE_Desktop

There isn’t anything besides the 1.3.x versions of the various qtcurve packages in this repo, so it should not be the cause for any problems.

Indeed, the version is different. But the repo you suggest is unstable so I prefer not to install those packages. And I don’t think that is the root of the problem because it was working before with these versions.

The problem I think is this:
/usr/share/themes/QtCurve/gtk-2.0/gtkrc is setup to use the default QTCurve settings

style “qtcurve-pathbutton” = "qtcurve-default"
GtkButton::child_displacement_x = 0
GtkButton::child_displacement_y = 0

style “qtcurve-toolbar” = "qtcurve-default"
GtkButton::default_border = { 0, 0, 0, 0 }
GtkButton::default_outside_border = { 0, 0, 0, 0 }
GtkWidget::interior_focus = 1
GtkButton::child_displacement_x = 1
GtkButton::child_displacement_y = 1
GtkOptionMenu::focus-padding = 0
GtkWidget::focus-padding = 1

So this gtkrc file does not reflect the QTCurve settings that KDE is using (currently agua style). Instead it always uses the default style. So I need a gtkrc file which reflects my custom QtCurve-Agua style, but don’t know where to find it. I remember I had to copy some gtkrc or stylerc of qtcurverc file to some directory to get it work for the first time. But I can’t remember which file and where to place it;).

Any ideas?

Alternatively, you could try this repo:
Index of /repositories/home:/cornelisbb/openSUSE_11.2
I had been using this one in fact myself for 1.2.x, however I wanted 1.3.x so badly, I switched to the repo I linked to above. Now I realize this repo also holds qtcurve 1.3.x, so maybe you want to give this one a try? (The downside is that it is not so neat and tidy, and holds othe things besides qtcurve.)

No, I don’t think it is that. I looked at that file on my system and it says exactly the same except that there are three additional lines. The two lines
style “qtcurve-pathbutton” = “qtcurve-default”

style “qtcurve-toolbar” = “qtcurve-default”
are there in any case.

No, except maybe to point out that I never had to move any files to get qtcurve to work at all.

I installed version 1.2 and it got fixed! Thanks for the help!!