Qt Virtual Keyboard

Hi all!

Has the Qt Virtual Keyboard (available since Qt 5.7) been packaged for OpenSUSE? Can’t find the package anywhere (or I can’t guess its name)…

I wanted to test this in Wayland with a touchscreen! :wink:


I’m trying a little “up” before the subject disappears in the limbo of the forums.

Here’s (I think) the package for Arch:

I can’t find anything related to that name on OpenSuse…

if it’s part of Qt 5.7 it might be available on TW as TW uses Qt 5.7 while leap is still on 5.5.1
I can’t seam to find any source of that package I wonder how the arch maintainers build it, maybe it’s an example application from Qt?
opensuse uses a different packaging scene then arch, there are already a few virtual keyboards for plasma 5 there is a plasmoid keyboard that comes with plasma 5 or you can install kvbd (it’s Qt 4 but it works good)


Thanks for your reply.

I guess I should have provided more context. This is what I mean:

And it was used by Martin Gräßlin in Kwin/Wayland 5.7 to provide an virtual keyboard input for tablet/hybrid PCs (the feature I have been meaning to test):

Currently I’m using kvbd (and I’ll continue to do so for the forseeable future, since Kwin/Wayland is not really production ready), but it is not very handy to use on a hybrid tablet: it does not remember its shape, size and location, and can be quite buggy to use with a touchscreen (resizing is nearly impossible, for some random reason…). Hence my wanting to test the new feature and get excited about the future (or not! ^^).

But I guess, if the package does not exist, I’ll have to wait, since my packaging skills (limited to change sources and versions of existing packages…) are outmatched by this task. Is there anywere where we can “request” a package?

As I thought it;s a demo application from Qt, as it needs Qt 5.7 it can only run on TW, nobody seams to have build it on OBS,
there are several other virtual keyboards, the default on opensuse is kvkbd
a few users have build onboard on OBS
maybe a TW user will build it or make a project on OBS as currently it can not be found on OBS, I think the maintainers are busy with leap 42.2 which should be out in a few weeks and don’t have time for 3rd projects, that project will build on TW and if you have TW you can try to build it (I’m on LEAP)
the Link you posted as well as this thread might create some inters

OK thanks!

As far as I know, the Qt virtual kwayboard should be part of the standard Qt packages.
The question is whether that feature is already enabled by default (or even included) in Plasma 5.8…

I’m not completely sure though.

I just re-read this sentence in Martin’s post:

The virtual keyboard is integrated into KWin/Wayland making it part of our platform.

So, I guess the code is in Kwin directly rather than requiring a Qt package?

Nevertheless, with Plasma 5.7 and Qt 5.7, I can’t manage to make this virtual keyboard happen. A system notification icons should appear in Plasma/Wayland, but it doesn’t…
Possibly Martin teased us with a feature that he implemented but is not yet reachable for users, he tends to do that sometimes! :wink:

I’ll give 5.8 a go when it’ll land in TW I guess…

Some part is in kwin, AIUI.

But it seems it also needs the qtvirtualkeyboard QML bindings…

I built libqt5-qtvirtualkeyboard for you, so maybe try to install it:

I’m only using 13.2 here, so cannot test it, as I can’t run a Wayland session.

It’s currently built without spell checking though, I have to add hunspell to the build requirements… :wink:

Nevertheless, with Plasma 5.7 and Qt 5.7, I can’t manage to make this virtual keyboard happen. A system notification icons should appear in Plasma/Wayland, but it doesn’t…

I’m not sure it was in Plasma 5.7 already.

I’ll give 5.8 a go when it’ll land in TW I guess…

Should be any day, you could install it from KDE:Frameworks5 now though if you don’t want to wait.

Thanks Wolfi323, I installed the package and tested again in Wayland, but still nothing unfortunately. The feature is supposed to be implemented in Plasma 5.7, according to Martin’s post, but as I said, “implemented” and “discoverable by user” can be far away.

I’ll wait for 5.8 to land in TW, shouldn’t be too long now, and try again. There’s no hurry.

Right, I got confused by this comment (also by Martin Graesslin):

X11 is something I would also like to support, but I fear 5.7 is an unrealistic target

But that’s about X11 support obviously, I just remembered it wrongly.

Unfortunately I didn’t find more information so far about this feature (e.g. how to enable it, what build requirements it has, and so on).
I had a look at kwin’s build log at least, but nothing in there indicates that it is disabled.
Maybe I’ll have to take a closer look at kwin’s code… :wink:

I’ll wait for 5.8 to land in TW, shouldn’t be too long now, and try again. There’s no hurry.

Plasma 5.8 has been accepted to Factory last Tuesday already, so it should be in the next snapshot.

A possibility that just occurred to me is that Kwin needs the package to be available at compile-time (not at run-time) to activate the feature, could it be? But testing that would require recompiling Kwin, which is a pain… I guess I can wait for a further state of TW where both packages are compiled against one another and try again (as I said, there’s no hurry, this was just to test the feature).

Not as far as I can see.

It needs libinput and threads, and the virtual keyboard will be compiled.
And if you look at the package list, it seems to be included:

rpm -ql kwin5 | grep virt/usr/share/kwin/virtualkeyboard

OK, well, I tested again, and still no trace of the virtual keyboard. Maybe the System Notification Icon is not working yet, and since I do have a keyboard, it doesn’t show the virtual keyboard (which makes sense).

A customer is very satisfied about

Yes, onboard is nice (admittedly much better than kvkbd), but it doesn’t integrate nicely with Plasma unfortunately. For example, clicking on the system notification icon does not trigger the keyboard, it requires a right-click (which is not easy with a touchscreen!)… Sometimes I think about switching entirely to Gnome when I want to use my laptop in a “tablet mode”, but this would be a very tiresome workaround and I’m too KDE-addicted to switch entirely to Gnome! :wink:

I’ll be patient, it’s coming, slowly but surely!

FYI, I got kwin’s integrated virtual keyboard to work on a Krypton LiveCD (which is current Tumbleweed plus the unstable KDE packages).
I just had to install plasma5-session-wayland (for some reasons it’s not on the LiveCD any more currently) and libqt5-qtvirtualkeyboard, and the icon to enable/disable it appeared in the system tray.

And indeed, when I disconnected my keyboard (this is a desktop system), the virtual keyboard got enabled automatically (an OSD popped up telling you about the fact), when I reconnected it it got disabled again automatically. And you can also manually enable/disable it (regardless whether a keyboard is connected or not) by left-clicking on the tray icon.

As Krypton/KDE:Unstable:Frameworks currently basically contains what will get released as Plasma 5.8.1 tomorrow (there haven’t been much work on 5.9 yet, if any), it should work in stable 5.8 too I suppose. (no idea about 5.7.4)

BUT: the icon was hidden by default. You need to click on the small up-arrow in the system tray to see it.

Thanks! Yes, I did look in the hidden system notifications icons. Just re-tried and still nothing. I’ll have a look when 5.8 will land, at least, we know it should work then.

Hm, so, I tested with the new Tumbleweed snapshot including 5.8 and still no success. I’m starting to wonder: maybe the keyboard should have been disconnected ONCE for the icon to show up? That would be a decent default, just not for my use case as I have a touchscreen laptop and cannot remove the keyboard.

Or, possibly more likely, something is messed up with my system…

IIRC the icon appeared also if I didn’t disconnect the keyboard at all.

Unfortunately I cannot try it in my Tumbleweed VM, because I cannot login to a Wayland session (the system just freezes, apparently a problem with the virtualbox video driver…).

I suppose I’ll try with a Krypton_stable LiveCD later.

Just one thing: please redownload libqt5-qtvirtualkeyboard and install it again (or force a re-installation).
I built it against KDE:Qt5 by mistake instead of plain Factory/Tumbleweed, which may have caused an incompatibility.
I don’t really think that’s the problem, but who knows.
Unfortunately the 64bit version still hasn’t been rebuilt in the last 4 days…