[Qt][QMPlay2] Application not launched to the default monitor

How can I tell QMPlay to launch on “monitor-2” which is set as default monitor on a dual display ?
I got a QMPlay2.ini but it seems it isn’t read at application launch.

Likely we need to know which DE you use, and possibly which GPU(s). inxi -GSaz input/output pasted here using PRE tags (</> icon) will provide this info.

Plasma:
Open qmplay2, klick on the Title Bar and choose moore Actions----special adjustment of this programm (I am here on a German PC)

Same can be done in the systemsettings5-----Window Managment-----Window Rules

sirius:/datas1/netbeans # inxi -GSaz
System:    Kernel: 5.14.21-150400.24.60-default x86_64 bits: 64 compiler: gcc v: 7.5.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.14.21-150400.24.60-default root=UUID=0f381669-91e2-48ac-a969-1c5d9b35550e
           quiet elevator=cfq mitigations=auto
           Desktop: KDE Plasma 5.24.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 7 dm: SDDM Distro: openSUSE Leap 15.4
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Baffin [Radeon RX 550 640SP / RX 560/560X] vendor: XFX Pine
           driver: amdgpu v: kernel bus-ID: 08:00.0 chip-ID: 1002:67ff class-ID: 0300
           Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa
           display-ID: :0 screens: 1
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") s-diag: 1055mm (41.5")
           Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 81 size: 600x340mm (23.6x13.4") diag: 690mm (27.2")
           Monitor-2: DVI-D-0 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27")
           OpenGL: renderer: Radeon RX 550 Series (POLARIS11 DRM 3.42.0 5.14.21-150400.24.60-default LLVM 11.0.1)
           v: 4.6 Mesa 21.2.4 direct render: Yes

Tried… it works but I’m a little disappointed, the application is launched at the correct screen, but to work I had to set “Force” at “screen 0” (for me the screen is “monitor/screen 2” not screen 0, as seen in inxi used before I posted… anyway).
The consequence is when moving to the other screen, it jumps back to “screen 0” ^^

I hve a Computer with 2 Monitors (both 1920x1080)so my screen is 3840x1080, my mumble is opening on virtual desktop 1, Monitor 2.

So i have set:

1920 on my first Monitor
984 on my second Monitor

2904 in the settings.

This is working for years.
mumble, konsole,konversation and more are opening on the same place on the monitor I want for a long time.