QT applications print with wrong paper type

Canon MF4370dn printer

This problem has been unresolved for years. It was a problem in Leap and is a problem still in Tumbleweed. I’ve tried reporting it here and to QT bug forums.

I live in Canada. Being the confused country that it is, we formally use metric measurements, but use Letter and Legal sized paper. This seems to blow the minds of QT developers.

I have “Canada - Canadian English (en_CA)” selected as my KDE Region Settings >> Formats choice.

When I attempt to print anything from a QT application, it trys to use A4 paper, which always results in a printer fail. (I can see the error on my printer LCD display asking for A4 paper to be loaded.)

When I print from a GTK application, it works fine.

I can work around the problem by manually changing the print margins in the print dialogue window just before sending the job to the printer. Adjusting them by just a few mm seems to do it. But I have to make the adjustment every time. I have tried setting the adjusted margins permanently but this will fail. Only manually adjusting the margins before every job avoids the problem.

Have you switched the paper size in cups:


This worked for me on an HP printer.

Yes. Triple-checking, I can see:

Defaults:job-sheets=none, none media=na_letter_8.5x11in sides=two-sided-long-edge

What does

locale LC_PAPER


If you explicitly set the paper size (to letter) in the application you’re printing from does that still attempt to print as A4?

$ locale LC_PAPER


If you explicitly set the paper size (to letter) in the application you’re printing from does that still attempt to print as A4?

Yes. “Letter” is always the paper type displayed as default in the print dialogue. I have tried changing it to A4 and back to Letter, hoping this would update a bad configuration someplace, but it does not work.

Odd one! As you’ve already concluded, it looks very much like a qt bug.

cups default is letter, LC_PAPER is letter, and you’re explicitly setting setting size in the application print dialogue…

Sorry, I really can’t suggest anything other than reporting the bug to qt … again.



Yes, you’ll need to register first if you’ve not already done so in the past.

Before doing that there is one other thing you could try, although I don’t know it will help in this instance.

In the system directory “/etc” create a text file named “papersize” (no file extension) containing the single word “letter”.

If it helps anyone in the future, I (think I have) have been able to hack a solution by editing the printer .PPD file and deleting mention of all paper types except Letter and Legal.