QStandardPaths: XDG_RUNTIME_DIR points to non-existing path Error in plasma apps

Hi.

After upgrading to 15.1 Sometimes (but not always) I get errors like this and other messing about d-bus not working.


fperal@tutatis:~> dolphin
QStandardPaths: XDG_RUNTIME_DIR points to non-existing path '/run/user/500', please create it with 0700 permissions.
QStandardPaths: XDG_RUNTIME_DIR points to non-existing path '/run/user/500', please create it with 0700 permissions.
"Session bus not found
To circumvent this problem try the following command (with Linux and bash)
export $(dbus-launch)"
fperal@tutatis:~> ls /run/user
476
fperal@tutatis:~> 


I’m working in plasma fine, but suddenly it stops working well, I can launch apps like dolphin, konsole, etc.
If I launch dolphin from konsole (if konsole was already open, but if it wasn’t I can not open it) I get the error above.
I’m working in remote with vnc, then I have to kill the vnc session and start it again and everything is normal again.

In the error avove you can see the system is complaining of /run/user/500 not existing. 500 is my user number. If I try to mkdir /run/user/500 I can’t because I have no permission.
If I create the directory as root then I get again the last error


fperal@tutatis:~> su
password: 
root@tutatis:/home/fperal> mkdir /run/user/500
root@tutatis:/home/fperal> chown fperal.users /run/user/500
root@tutatis:/home/fperal> exit
fperal@tutatis:~> dolphin
"Session bus not found
To circumvent this problem try the following command (with Linux and bash)
export $(dbus-launch)"
fperal@tutatis:~> 



I hace been searching and some of thes dbus errors seem to be caused by anaconda, but I don’t have anaconda installed.

Any clues?

thanks

Q.: why is your UID 500? On openSUSE in /etc/login.defs the minimum UID is set to 1000.

Because my user is here since the good old times when the id for normal users began at 100 if I don’t remember wrong

regards

I was doing that, for a while. But I eventually decided to change to uid=1000 and up. Of course, I had to do some corresponding “chown” commands. But, long term, that makes things easier.

Same here. I had non system users from 500 for many years. Only changed when going to 15.1.

Is there any problem with users below 1000?
I thought it was only that new users are created above 1000 as defined in login.defs but that it didn’t affect existing users at all.

Something is wrong with your login as the directory is always created:

erlangen:~ # journalctl -b --grep 1001|grep systemd
Sep 17 20:19:00 erlangen systemd[1]: Created slice User Slice of UID 1001.
Sep 17 20:19:00 erlangen systemd[1]: Starting User Runtime Directory /run/user/1001...
Sep 17 20:19:00 erlangen systemd[1]: Started User Runtime Directory /run/user/1001.
Sep 17 20:19:00 erlangen systemd[1]: Starting User Manager for UID 1001...
Sep 17 20:19:00 erlangen systemd[1]: Started User Manager for UID 1001.
...
erlangen:~

You may check your journal for errors and report.


root@tutatis:~> journalctl -b --grep 500|grep systemd
journalctl: unrecognized option '--grep'
root@tutatis:~> journalctl -b | grep 500 | grep systemd |less
sep 19 09:52:01 tutatis.dyndns.org systemd[1]: Started User Manager for UID 500.
sep 19 09:52:04 tutatis.dyndns.org systemd[1]: Stopping User Manager for UID 500...
sep 19 09:52:04 tutatis.dyndns.org systemd[1]: Stopped User Manager for UID 500.
sep 19 09:53:01 tutatis.dyndns.org systemd[1]: Starting User Manager for UID 500...
sep 19 09:53:01 tutatis.dyndns.org systemd[1]: Started User Manager for UID 500.
sep 19 09:53:03 tutatis.dyndns.org systemd[1]: Stopping User Manager for UID 500...
sep 19 09:53:03 tutatis.dyndns.org systemd[1]: Stopped User Manager for UID 500.
sep 19 09:54:01 tutatis.dyndns.org systemd[1]: Starting User Manager for UID 500...
sep 19 09:54:01 tutatis.dyndns.org systemd[1]: Started User Manager for UID 500.
sep 19 09:54:04 tutatis.dyndns.org systemd[1]: Stopping User Manager for UID 500...
sep 19 09:54:04 tutatis.dyndns.org systemd[1]: Stopped User Manager for UID 500.
sep 19 09:55:01 tutatis.dyndns.org systemd[1]: Starting User Manager for UID 500...
sep 19 09:55:01 tutatis.dyndns.org systemd[1]: Started User Manager for UID 500.
sep 19 09:55:03 tutatis.dyndns.org systemd[1]: Stopping User Manager for UID 500...
sep 19 09:55:03 tutatis.dyndns.org systemd[1]: Stopped User Manager for UID 500.
sep 19 09:56:01 tutatis.dyndns.org systemd[1]: Starting User Manager for UID 500...
sep 19 09:56:02 tutatis.dyndns.org systemd[1]: Started User Manager for UID 500.
sep 19 09:56:04 tutatis.dyndns.org systemd[1]: Stopping User Manager for UID 500...
sep 19 09:56:04 tutatis.dyndns.org systemd[1]: Stopped User Manager for UID 500.
sep 19 09:57:01 tutatis.dyndns.org systemd[1]: Starting User Manager for UID 500...
sep 19 09:57:01 tutatis.dyndns.org systemd[1]: Started User Manager for UID 500.
sep 19 09:57:03 tutatis.dyndns.org systemd[1]: Stopping User Manager for UID 500...
sep 19 09:57:03 tutatis.dyndns.org systemd[1]: Stopped User Manager for UID 500.
sep 19 09:58:01 tutatis.dyndns.org systemd[1]: Starting User Manager for UID 500...
sep 19 09:58:01 tutatis.dyndns.org systemd[1]: Started User Manager for UID 500.
sep 19 10:03:03 tutatis.dyndns.org systemd[1]: Stopping User Manager for UID 500...
sep 19 10:03:03 tutatis.dyndns.org systemd[1]: Stopped User Manager for UID 500.
sep 19 10:04:01 tutatis.dyndns.org systemd[1]: Starting User Manager for UID 500...
sep 19 10:04:01 tutatis.dyndns.org systemd[1]: Started User Manager for UID 500.







It is not above 1000, but above 999.

There is not realy a problem except that some software “may” use the below 1000 as a sign that this is a “system user”. I only know of some display managers, that are able to show lists of users on the login screen (something I hate) and then only show above 999. But that is configurable.

For some reason pam_systemd fails to create the directory: pam_systemd You may check systemd:

erlangen:~ # rpm -qf /lib64/security/pam_systemd.so
systemd-242-3.1.x86_64
erlangen:~ # rpm -V systemd
.M.......  c /etc/X11/xorg.conf.d/00-keyboard.conf
.M.......  c /etc/locale.conf
.M.......  c /etc/machine-id
.M.......  c /etc/vconsole.conf
.M.......  g /var/lib/systemd/random-seed
erlangen:~ # 

A reinstall might help: zypper in -f systemd.


tutatis:~ # rpm -qf /lib64/security/pam_systemd.so
systemd-234-lp151.25.7.x86_64
tutatis:~ # rpm -V systemd

.M.......  c /etc/X11/xorg.conf.d/00-keyboard.conf
.M.......  c /etc/locale.conf
.M.......  c /etc/machine-id
S.5....T.  c /etc/systemd/system.conf
.M.......  c /etc/vconsole.conf
.M.......  g /var/lib/systemd/random-seed
tutatis:~ # 


Reinstall didn’t change anything

I haven’t found the cause of the problem although I have found a quick fix


fperal@tutatis:~> mkdir XDG_RUNTIME_DIR
fperal@tutatis:~> export XDG_RUNTIME_DIR=/home/fperal/XDG_RUNTIME_DIR
fperal@tutatis:~> export $(dbus-launch)

And it seems to work fine

Hey fperal !!!
thank you so much… had black screen on my VNC-Session and solve it with your post. The last workaround was the one that made it!

Cheers,
Daniel

I’m glad it was useful to you.

best regards