QGIS 3.20.1 fails to start

It looks like I got QGIS 3.20.1 (from 3.20.0) earlier today and now it won’t start. On the console, the following is output:

src/core/symbology/qgsstyle.cpp:1621 : (runEmptyQuery) [0ms] UNIQUE constraint failed: symbol.name 
src/core/symbology/qgsstyle.cpp:227 : (saveSymbol) [0ms] Couldn't insert symbol into the database!

repeated a bunch of times followed by

src/core/symbology/qgsstyle.cpp:1621 : (runEmptyQuery) [0ms] UNIQUE constraint failed: colorramp.name 
src/core/symbology/qgsstyle.cpp:427 : (saveColorRamp) [0ms] Couldn't insert colorramp into the database!

repeated a bunch of times. Top shows the qgis process using 100% of processor. I’ve waited up to about a minute to see if anything more happens; it doesn’t. I haven’t run QGIS for a while, maybe 1-2 weeks ago was the last time it worked but I’m assuming the update today is what did it. Anyone else having troubles? Anything to troubleshoot or should I just file a bug?

Your message re: qgis got me intrigued as to what it was about. I downloaded and installed qgis from repos. On leap 15.3 it started and ran. I ran through a tutorial and all appears to be functioning.

The downloaded version from repos is: 3.18. App says there is an update but I haven’t looked into installing that. I don’t know where the 3.2 version that was mentioned came from.

Looks like very comprehensive mapping program. Not really my thing but interesting.

Just for info, I am including startup messages for qgis in a terminal. Several errors are indicated but it stil started successfully. Perhaps this will provide some info to diagnose the problem, e.g., missing files.

tom@localhost:~> qgis
src/app/main.cpp:511 : (main) [0ms] Starting qgis main
src/core/qgsmessagelog.cpp:29 : (logMessage) [214ms] 2021-08-06T07:46:08 [1] Successfully loaded globalsettingsfile path: /
src/core/qgsproviderregistry.cpp:267 : (init) [696ms] Loaded 25 providers (DB2;OAPIF;WFS;arcgisfeatureserver;arcgismapserve
src/providers/grass/qgsgrass.cpp:518 : (lock) [4ms] lock
src/providers/grass/qgsgrass.cpp:317 : (init) [0ms] do init
src/providers/grass/qgsgrass.cpp:799 : (error_routine) [0ms] error_routine (fatal = 1): Module built against version 2021-0
5-18T09:48:58+00:00 but trying to use version 2021-07-26T14:08:57+00:00. You need to rebuild GRASS GIS or untangle multiple
src/providers/grass/qgsgrass.cpp:805 : (error_routine) [0ms] fatal -> longjmp
src/providers/grass/qgsgrass.cpp:349 : (init) [0ms] Problem in GRASS initialization, GRASS provider and plugin will not wor
k : Module built against version 2021-05-18T09:48:58+00:00 but trying to use version 2021-07-26T14:08:57+00:00. You need to
 rebuild GRASS GIS or untangle multiple installations.
src/providers/grass/qgsgrass.cpp:524 : (unlock) [0ms] unlock
src/providers/grass/qgsgrassprovidermodule.cpp:1313 : (initProvider) [0ms] init failed
src/core/qgsmessagelog.cpp:29 : (logMessage) [1463ms] 2021-08-06T07:46:10 Plugins[0] Loaded DB Manager (package: db_manager
src/core/qgsmessagelog.cpp:29 : (logMessage) [590ms] 2021-08-06T07:46:11 Plugins[0] Loaded MetaSearch Catalog Client (packa
ge: MetaSearch)
src/core/qgsmessagelog.cpp:29 : (logMessage) [1282ms] 2021-08-06T07:46:12 Processing[2] Problem with SAGA installation: SAG
A was not found or is not correctly installed
src/core/qgsmessagelog.cpp:29 : (logMessage) [250ms] 2021-08-06T07:46:12 Plugins[0] Loaded Processing (package: processing)
src/core/qgsmessagelog.cpp:29 : (logMessage) [151ms] 2021-08-06T07:46:13 [0] Application state:
Prefix:         /usr
Plugin Path:            /usr/lib64/qgis
Package Data Path:      /usr/share/qgis
Active Theme Name:      default
Active Theme Path:      /usr/share/qgis/resources/themes/default/icons/
Default Theme Path:     :/images/themes/default/
SVG Search Paths:       /usr/share/qgis/svg/
User DB Path:   /usr/share/qgis/resources/qgis.db
Auth DB Path:   /home/tom/.local/share/QGIS/QGIS3/profiles/default/qgis-auth.db


zypper se -si qgis
Loading repository data... 
Reading installed packages... 

S  | Name             | Type    | Version    | Arch   | Repository 
i+ | qgis             | package | 3.20.1-1.1 | x86_64 | openSUSE-Tumbleweed-Oss 
i  | qgis-sample-data | package | 3.20.1-1.1 | noarch | openSUSE-Tumbleweed-Oss

It is! And very useful. Thank you for your efforts, I didn’t see anything in your console output that looked helpful necessarily, but I appreciate it. FYI I rolled back btrfs to get to the previous version and it works. Another change is that libqwt6 was replaced by libqwt6_2 with the newest version. For now I’ve locked the old version of qgis.

Just in case anyone else was having issues, this was a bug found across multiple platforms see https://github.com/qgis/QGIS/issues/44293. I’ve submitted https://build.opensuse.org/request/show/910618 with the fix.

I am the same problem and solved deleting the file ~/.local/share/QGIS/QGIS3/profiles/default/symbology-style.db
(Do not use a custom profile)