qemu:// no connection driver

this is openSUSE-13.2, qemu-2.4.0-305.d_l_ocaml.1.x86_64
after an update, qemu wouldn’t start anymore, it has been running fine since initial installation-
All I get is following error:

Libvirt URI is: qemu:///system

Traceback (most recent call last):
File “/usr/share/virt-manager/virtManager/connection.py”, line 864, in _do_open
self._backend.open(self._do_creds_password)
File “/usr/share/virt-manager/virtinst/connection.py”, line 161, in open
open_flags)
File “/usr/lib64/python2.7/site-packages/libvirt.py”, line 105, in openAuth

So it seems, that virtManager doesn’t receive login credentials anymore.
Any work around or help?

-Dieter

First,
If you <really> believe that something in an update broke something, keep in mind that if you are running BTRFS you can always use snapper (command line utility) to rollback to a point before the update. If you do so, you can re-run however you updated and carefully read <what> was updated to see if something relevant to libvirt is listed.

You can force-re-install your libvirt packages… To do so, first determine what libvirt packages you have installed using the following command

zypper se libvirt | grep "i |"

Now, force re-install each package that is listed

zypper in -f* package1 package2 package3* 

HTH,
TSU