qemu/kvm vm of gentoo linux will not find root partition to boot

Current status is that gentoo (using minimal iso with openrc as stage 3) vm won’t boot. It enters grub menu but afterwards says Block device UUID=xxxxxxxx is not valid root device. Could not find the root block device. Offers to drop into shell. I have tried inserting many different device descriptors, e.g., /dev/vda1 etc with no success.

In looking at grub commandline in the vm using (e), the grub command there has a different UUID string in the --set=root setting than what was listed later.

I have many other qemu vms working fine including TW so I am confident my basic setup works. I have configured/compiled gentoo vm probably 30 times using gentoo handbook and multiple successful installs in youtube videos. Followed steps very carefully. Tried both mbr and gpt disk partitions.

I am looking for a means to get information to point current vm to the root or perhaps there is some vm manager setting specially needed for gentoo vm that I am missing. Else maybe some means to modify files within the vm to correct things.

thanks for any ideas/help, tom kosvic

Sounds like this? https://forums.gentoo.org/viewtopic-t-1061394-start-0.html