QEMU/KVM Problem with mouse and keyboard


I have a problem with my mouse and keyboard. When I run virtual machine and switch to Guest System mouse and keyboard not work. I looked for help in forum and Internet but I didn’t find. I need your help.

I installed KVM and QEMU by YaST.

My configuration:
Dell D630
openSUSE Leap 15
KDE Plasma 5

  1. Do you have multiple monitors or a single monitor?
  2. If you click on the graphical console of your Guest, do you still see your mouse cursor? Does it change or look the same?
  3. Try installing an openSUSE Guest and see if you are experiencing the same problem. When openSUSE is installed as a Guest, the install should automatically detect it’s being installed in a virtual environment and so should install the appropriate Guest enhancements (in KVM, Guest Tools). I’m assuming your current Guest is a MSWindows.



  1. I have single monitor
  2. When I click on the console of Guest, cursor is invisible. I don’t see it.
  3. Yes, I tried install Windows 7. When I have tried install of openSUSE, keyboard works during boot sequence. After choose “Install” option, installation process was running but it was stopped. The following link https://1drv.ms/u/s!AtYuO965r0VhgsNXjAvVIGIc1uPuZg consist screen shot

Is it possible install Guest enhancements manually?

Ordinarily, Guest enhancements are not required for basic functionality like display and mouse movement. Enhancements might be required only to provide more display options and performance…

You should try to install an openSUSE Guest first just to have something working you can compare other installs.
The screenshot you posted describes a point in the boot sequence when fixes to address the Spectre vulnerabilities are applied. But, that shouldn’t pause your install for more than a little bit, your boot should not come to a complete stop.

Was your screenshot from early when your Install is setting up or much later when your Install has completed and your Guest is booting up?

Do a hash check on your install medium to verify it’s good, and if is, try again.
Or, many torrent apps today do a checksum on every chunk as it’s downloaded and again when the file is completed automatically. I assume you’re installing using an openSUSE DVD ISO file as your install source, right? You should avoid using a real DVD if an ISO file is available .



I was silent because I was trying do that you describe. Unfortunately it didn’t work.

Then I installed Ubuntu on my computer and KVM/Qemu are working correct. Problem gone.
I installed KVM\Qemu using following instruction

sudo apt install qemu-kvm libvirt-clients libvirt-daemon-system bridge-utils virt-manager

Do you have any idea, what is missing in openSUSE?

No idea at the moment.
But I am looking into a possibly distantly related issue on a Vmware machine.
The virtualization is different, and the problem is not an invisible mouse, but is a problem rendering a special font set.
In my case, an error is thrown by the application

Gtk-CRITICAL **: IA__gtk_widget_realize: assertion 'GTK_WIDGET_INVISIBLE (

Note that I’m quoting my error above not because I expect you to see the same,
It’s only to give you an example of a rendering error you might find, and while my error is in my Guest, I’d more likely expect your error to be in your HostOS system log.

And, as always try installing a Windows guest again…
It’s one thing I did in my case to prove the error is replicate-able which you need to do as well.

As for your openSUSE try, I don’t see that you tried again or that you might have followed through to try to get past the error in your screenshot.

It is useful to know though that you had a successful Ubuntu install.