Qbittorrent needs libboost_system.so.1.66.0

after doing the dup for the new plasma for Tumblweed and then 2 the0180618 update/ upgrade with dup I went to install Qbittornet and I can either break the pkg by ignoring the dependency or cancel. For now I canceled to ask here if it’s a matter of waiting for more updates.

Qbittorent needs this dependency libboost_system.so.1.66.0 but it can not be found anywhere.

is this a matter of waiting for the Qbittorrent pkg to be updated or?

:EDIT

output of zypper install Qbittorrent

Problem: nothing provides libboost_system.so.1.66.0()(64bit) needed by qbittorrent-4.1.1-1.2.x86_64
Solution 1: do not install qbittorrent-4.1.1-1.2.x86_64
Solution 2: break qbittorrent-4.1.1-1.2.x86_64 by ignoring some of its dependencies

Hi
Yes, it needs fixing to build against .67 boost libraries…

It has been fixed in the devel project already (the “problem” was actually in libtorrent-rasterbar), the update isn’t in Factory yet though.

thank you very much

FTR, here’s the SR to Factory:
https://build.opensuse.org/request/show/618708

As soon as this is accepted (and a new TW snapshot published), qbittorrent’s dependencies should be fixed I hope.