Qbittorrent install, nothing provides libboost_system.so.1.65.1()(64bit)

So I tried to install Qbittorrent but presented with error “Problem: nothing provides libboost_system.so.1.65.1()(64bit) needed by qbittorrent-4.0.2-1.1.x86_64”. (using official tumbleweed oss and obs’s network repo)
When I tried to use libboost_system 1.65 from random repo in obs the software installs, but I got undefined error symbol when launching it. So I assume I just have to wait for the qbittorent repo itself get fixed.

How long usually it takes to get this fixed?

A fix is already submitted (see below), takes time for review, rebuild, openQA esp with holiday break

See: https://build.opensuse.org/request/show/560762

Ref: https://forums.opensuse.org/showthread.php/528840-Qbittorrent-libboost_system-so-1-65-1-error

That’s just a fix for libtorrent-rasterbar, that qbittorrent uses.
Unfortunately, qbittorrent itself still fails to build.

The reason apparently is that cmake doesn’t support boost 1.66 yet.

You can install qbittorrent from here for now though, if you need it:

Thanks man. That really help. I can finally use a torrent client that didn’t suck.

Was waiting and trying to install it every few hours every day :P.

FYI, qbittorrent builds fine again now in Factory.
So after the next snapshot is published, the standard version should be usable again.