Q1: Compiz/ATI1600 Q2: Browser/1-click problem

Hey there, I’m new to openSUSE, thought I’d try it out.

First problem:

After looking it up and my problem has a common name “white cube of death”. Thats right, I’m trying to get compiz fusion going on my ATI Radeon 1600. I havn’t found any actual solved threads, they seem to take me all over the place and I have no idea where the answer is and I’m getting tired of reading posts.

Second problem:

This one-click-install thing looks like a great idea but when I try it I get a tiny window that shows up in the middle of my screen and It doesn’t seem to lead to any wizard or do anything. Infact, I have to make the window bigger so i can close it since it isn’t doing any real operation. I tried getting the ATI drivers from the ATI site and I can’t even get those because I’m getting that little asshole of a window pop-up again. Is my Firefox missing something?

Alright, awesome, not one person has even seen this post.
Anyhoo, I’ve got the browser fixed, now to get compizfusion working.