python-setuptools broken in 11.1 x86-64?

After installing setuptools and attempting to use easy_install to install a library, I get this error:

/usr/lib64/python2.6/site-packages/setuptools/package_index.py:7: DeprecationWarning: the md5 module is deprecated; use hashlib instead
from md5 import md5
error: can’t create or remove files in install directory

The following error occurred while trying to add or remove files in the
installation directory:

[Errno 2] No such file or directory: '/usr/local/lib64/python2.6/site-packages/test-easy-install-25679.pth'

The installation directory you specified (via --install-dir, --prefix, or
the distutils default setting) was:

/usr/local/lib64/python2.6/site-packages/

This directory does not currently exist. Please create it and try again, or
choose a different installation directory (using the -d or --install-dir
option).
]

I can create symbolic links in /usr/local to just /usr, (which shouldnt’ be necessary, but if I do that, I get an equally catastrophic, even more difficult to explain error as easy_install does its path processing.

I’m using python 2.6 (which seemed to be what came on my install)

Should I switch versions? What gives?

THanks!

-R

same here, i need it to work, … and can’t get it right…
i’ve also tried the symlink but i only made a recursion error.
also tried installing with ez_setup.py but i got a similar error.
anyone has a clue?
btw, i’m using 11.1 x86

The distutils default setting points to /usr/local in 11.1:

$ cat /usr/lib64/python/distutils/distutils.cfg 
[build_py]
optimize=0

[install]
prefix=/usr/local
optimize=0

This can be fixed by simply creating the directory as root:

sudo mkdir -p /usr/local/lib64/python2.6/site-packages

which worked for me.

Thank you so much, this works!