Python matplolib

Hi,
I’ve tried to make a plot using matplotlib, but the same error keeps popping up. Further I’ve tried some of the source-codes given at matplotlib.sourgeforge.net and still getting the same error message:

$ python test.py
/usr/lib/python2.6/site-packages/pytz/tzinfo.py:5: DeprecationWarning: the sets module is deprecated
from sets import Set
Traceback (most recent call last):
File “test.py”, line 1, in <module>
import matplotlib.pyplot as plt
File “/usr/lib/python2.6/site-packages/matplotlib/pyplot.py”, line 75, in <module>
new_figure_manager, draw_if_interactive, show = pylab_setup()
File “/usr/lib/python2.6/site-packages/matplotlib/backends/init.py”, line 25, in pylab_setup
globals(),locals(),[backend_name])
ImportError: No module named backend_tkagg

It seems like I dont have the module backend_tkagg.

So, I’ve installed the matplotlib-tk package, and now it is working just fine.

So, this post is for helping others, but could somebody please tell me if they have the same problem and:
shouldn’t this package be installed together with the matplotlib package?

I’m running opensuse 11.1, using the science repository and the languages/python repository.

I didn’t have this problem in openSUSE 11.2, but with openSUSE 11.3 I had this problem, which is weird.

I also had some trouble with building matplotlib on openSUSE 11.3. I found that the package ‘freetype2-devel’ needs to be installed.

Hi,

I am currently trying to use matplotlib to draw graphs using NetworkX library (see Overview — NetworkX v1.3 documentation). The NetworkX library runs without any problems, but when I try to import the matplot library as indicated below (see Creating a graph — NetworkX v1.3 documentation) I get a “Sementation fault”.

>>> import matplotlib.pyplot as plt
Segmentation fault

Anyone had the same problem ?

My system is OpenSuse 11.3 (32 bits). The Matplotlib I currently have installed is the one of the OpenSuse Education Repository, version

python-matplotlib-wx-1.0.0-9.1.i586
python-matplotlib-1.0.0-9.1.i586
python-matplotlib-tk-1.0.0-9.1.i586

Thanks for your help,

Luis

Hi,

I’ve solved the above problem. It seems that you need to install the corresponding numpy package. That is, the problem was that the matplotlib library is from the OpenSuse Education Repository, whereas numpy was from the OpenSuse Standard library. If you ugprade the numpy package using the one available in the OpenSuse Education repository, the problem disappears.

Best,

Luis

Hi,

I faced the same problem on 11.4 x64. I could resolve it by installing the following additional packages -
a. python-matplotlib-wx
b. python-matplotlib-tk

Old thread, but still useful. Have found it through Google.

I have got the same “ImportError: No module named backend_tkagg” on openSUSE 12.1

As said above, solved by installing python-matplotlib-tk
from: Index of /repositories/science

Thanks guys!