Python Development Pattern in openSUSE 11.4

In openSUSE 11.3 when I selected the Python Development pattern for install, it included everything needed for Python development. I installed openSUSE 11.4 yesterday from the full DVD ISO and selected the Python Development pattern, but all it installed is the patterns-openSUSE-devel_python meta package, which apparently doesn’t include any other software. It didn’t even install the python interpreter.

Of course I can easily install what I need manually, but the pattern is a handy one for quick installs that need Python. Is this pattern broken under 11.4 or am I missing something? I couldn’t find anything about this behavior in the release notes, known 11.4 bug list on the forums, Google, etc.


It appears there may be some other issue here. I just tried to manually install Python and am getting the following error:
python-2.7-8.2.i586 requires python(abi) = 2.7, but this requirement cannot be provided

Possible solutions are deinstallation of patterns-openSUSE-minimal_base-11.4-6.9.1.i586 or do not install python-2.7-8.2.i586. Neither of those are particularly helpful.

Any idea what the issue is? I assume other people have installed Python successfully on 11.4.


I am giving up on this one. I am going back to openSUSE 11.3 until someone else runs into this. I just discovered that the man program is not even installed. I had to manually install vim as well. Either this installation is completely screwed up or there have been undocumented changes as to what the various installation options do in 11.4.

Here’s how I built my 11.4 system if anyone runs into this:
Installation via the 32-bit DVD ISO on a USB memory stick
Choose New Installation and uncheck Use Automatic Configuration.
Choose Minimal Server Selection (Text Mode).
Choose the following package groups:
Base Development
Linux Kernel Development
Python Development

That’s it - and no python, and apparently no man program or vim. Very strange - best of luck to anyone else that runs into this. By the way, those exact installation steps work as expected with openSUSE 11.3.


Are you sure you set up your repos correctly? Since I have python-2.7-8.2, and seems like I have no python(abi) installed.

Good suggestion, but even as part of the stock 11.4 32-bit DVD installation where you can select what software you want it won’t let me select python without complaining about the python(abi) dependency. I assume the DVD ISO comes configured with the right local repositories for installation as part of the installation process? If not, how did the 11.4 system get installed?

When I have more time to waste on this I will try some other things and report back. My frustration is that I didn’t have this trouble with openSUSE 11.3 and it is such a basic setup (stock install, text mode only, need python.)


On 03/17/2011 05:36 PM, mgibbsvt wrote:
> My frustration is that I didn’t have this trouble with
> openSUSE 11.3 and it is such a basic setup

how did it test out in RC1?

[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

About python I have written in Hellas(Greek Forum). You must translate it Εισαγωγή στη Python](

I never tried RC1. I typically stick with releases for their relative stability.

I looked into this issue a bit more this morning and it appears the root problem is a conflict between python-base-2.7-8.4.i586 and minimal_base-11.4-6.9.1.i586. The patterns-openSUSE-minimal_base package specifically lists python-base as a conflict.

Based on that info I was able to find this larger bug, reflecting some of the other issues I ran into with the minimal server selection installation like man and vim not being installed: