python(abi) = 2.6 is needed

I was trying to install wammu-0.33-1.9.noarch.rpm from suse repository
but a dependency error occurred

python(abi) = 2.6 is needed

I cannot find anywhere this python(abi) could you tell me in which
software is it? or where can I find it?

many thnks


As you do not tell which openSUSE, I tried with openSUSE 11.2

There is a package* wammu 0.30.1-3.2* in the OSS repository. and as you do not tell which repository you use I am stuck.

IMHO I tried to be helpfull. IMHO I think you were not very helpfull in trying to give all the relevant information one needs to help you.

you are right 11.2 kde 4.4.3 :slight_smile:

you are right again :slight_smile:

Index of /repositories/home:/Nijel/openSUSE_Factory

I already have wammu 0.30 installed but the 0.33 has more features I would like to try on my phone

and again you are right again more, I wasn’t helpful but you helped me anyway remembering me that when I’m absent-minded I became neglectful :), and I apologize for this.
Thank you again and I hope infos I gave you results enough

Thanks for the clarifications.

Now this repository is maintained by a certain Nijel as you can see. So (s)he is responsible for packageing correctly and (s)he is the one you should ask. Now I never use these Factory repos (for the very reason you show to advantage), thus I can not tell you how you can contact Nijel. Maybe try a Google on this name?

It could be there is a standard way to find these individuals that make software available on Factory. In that case I hope someone else here can tell.

Thank you, following your suggestion I discovered that already I contacted him (Michal Čihař, I don’t know czech names but Michal seems “Him” :slight_smile: ) in the wammu mail list, he said me this:

“It just means that it was built for Python 2.6, which you probably
don’t have installed. Most likely it means that you’ve chosen packages
for different distribution than you are using.”

It seems that the repo should be for wrong distro, but it was for 11.2 … factory … let me look better… infact I looked better and there is another repo with 0.33 Index of /repositories/home:/Nijel/openSUSE_11.2 (wammu-0.33-1.1.noarch.rpm) not the last (wammu-0.33-1.10.noarch.rpm) but 0.33 should be enough :slight_smile:
thank you again I’m learning day after day always more but never enough

Factory is where the NEXT version of things are tried out. In general factory is considered unstable and you should only get packages from a factory repo if you know what you are doing.

As gogalthorp allready gave you a good warning, the only thing I can do is congratulate you with the solution.