Resently I tried to install Pysol which is a collection of solitaire games. I installed it through YaST and it seemed to download and install correctly but when I click on the PySol icon nothing happens. So if anyone could help me with this issue it would be greatly appreciated. -Clinton


first step, check the command in the .desktop file and run it manually from a console. That should show some errors.


i would like to kindly recommend uninstallation of pysol & then installation of pysolFC. (fan club edition). it is newer & has many more games.

installing PysoFC is not an option.
it only allows playing the startup “Klondike”. if you choose any other game it crashes. does this in all distros i have tried.
i have tried many of the solutions found on the net but none have yet to work.
after all this time there should be a fix.

PySol worked great for me in ver 10.3 But will not run in ver. 11.1. When I attempt to start it all I get is the bouncing cursor. And that just goes away after a bit. I tried it from the command line and got the following feedback -

gary@linux-unxh:~> pysol
Traceback (most recent call last):
File “/usr/share/games/pysol/src/”, line 47, in <module>
from main import main
File “/usr/share/games/pysol/src/”, line 48, in <module>
from app import Application
File “/usr/share/games/pysol/src/”, line 54, in <module>
from images import Images, SubsampledImages
File “/usr/share/games/pysol/src/”, line 47, in <module>
from pysoltk import tkversion, loadImage, copyImage, createImage
File “/usr/share/games/pysol/src/”, line 81, in <module>
exec “from " + m + " import *”
File “<string>”, line 1, in <module>
File “/usr/share/games/pysol/src/tk/”, line 39, in <module>
import Tkinter
File “/usr/lib/python2.6/lib-tk/”, line 39, in <module>
import _tkinter # If this fails your Python may not be configured for Tk
ImportError: cannot open shared object file: No such file or directory

I would appreciate any suggestions on how to solve this problem. I am a newbie to Linux - trying to climb the learning curve.

Thanks - Gary

Are tk and python-tk installed?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 2 days 11:38, 2 users, load average: 0.10, 0.15, 0.33
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Thanks for the advice - I’ll check on the TK stuff.