PySide causes Ninja-IDE crash (openSUSE 13.2)

My I use Ninja-IDE which is in openSUSE 13.2 available from Oss repo. In openSUSE 13.1 It worked fine especially with one of my projects that involved matplotlib. Unfortunately in openSUSE 13.2 Ninja-IDE was unable to show matplotlib plots when

command was issued and didn’t raise any error. I tried the same code in Spyder-IDE and Spyder complained about missing qt4 back end for matplotlib. I have installed python-matplotlib-qt4 and its dependencies. Now Spyder was able to show plots with ‘’, but I was unable to start Ninja-IDE:

:~> ninja-ide
libpng warning: iCCP: known incorrect sRGB profile
python: siplib.c:8484: sip_api_can_convert_to_type: Assertion `(((td)->td_flags & 0x0007) == 0x0000) || (((td)->td_flags & 0x0007) == 0x0002)’ failed.

After some tests I found out that the PySide is the reason for crash and uninstalled it (python-pyside), breaking python-matplotlib-qt4 dependencies. After that Spyder-IDE was still able to show plots and Ninja-IDE was able to launch. Unfortunately in Ninja-IDE still produces no plots and raises no errors.

I guess if the issue with PySide could be fixed somehow, Ninja-IDE would be able to show plots (???). Or is there another way to make Ninja-IDE show plots?