PXE/Network/LAN Boot: "Could not find the openSUSE Repository. Activating manual setup program"

I am trying to install openSUSE 13.1 DVD, via PXE or network boot, I am using serva as tftf server. It boots and everything works fine but then i get a message “Could not find the openSUSE Repository. Activating manual setup program”. However I successfully installed Windows 7 via PXE boot without any problems so I guess my configuration is correct but may there is something extra that I am missing in order to install a Linux operating system via PXE. Please let me know if anyone can guide me.

Thank you!

Ok well I figured it out, I thought I should share this in case anyone else is having the same problem.
So this is what I did, I configured serva on my server machine to offer HTTP services using NWA_PXE as root folder. Then after that I made changes to ServaAssist.inf and add the following line to the append
install=http://$IP_BSRV$/NWA_PXE/$HEAD_DIR$/
Which is now pointing towards the openSUSE DVD installation directory and offering HTTP services.

If there is something else you need then please refer to serva documentation on their website , they have a very good documentation page and covers almost everything which you need to know.

Ok now I am going back to continue my installation.

Sorry I meant ServaAsset.inf not ServaAssist.inf… Typing mistake :stuck_out_tongue:

you can find here:
http://vercot.com/~serva/an/NonWindowsPXE3.html

the required ServaAsset.inf for PXE installing
openSUSE-13.1-DVD-x86_64.iso
openSUSE-13.1-DVD-i586.iso

you also have the ServaAsset.inf for booting live distros

openSUSE-13.1-GNOME-Live-x86_64.iso
openSUSE-13.1-KDE-Live-x86_64.iso
openSUSE-13.1-Rescue-CD-x86_64.iso

OK, this is quite old but i had that error today and i figured out how to solve it.

I tried this and had no success. >:(
The boot-screen was loading and loading and loading…
… and then the client was rebooting and hanging after the reboot. :’(

Later i found this line in the Serva-Log:
[01/28 12:12:23.725] HTTP Inf: 200 OK. Resource [/OpenSuse64[b]//content] Client [192.168.1.200]

I assumed that the two slashes were incorrect and responsible for the failure. So i removed the slash at the end of the line.
->

install=http://$IP_BSRV$/NWA_PXE/$HEAD_DIR$

I restarted serva and tried the bootprocess again and now i had a complete success. :slight_smile:
The Serva-Log shows a correct Path:
[01/28 12:31:32.725] HTTP Inf: 200 OK. Resource [/OpenSuse64[b]/content] Client [192.168.1.200]

The whole installation flowed smoothly.