Purge completed todos does not work in Korganizer/Kontact with KDE 4.11

Since upgrading to KDE 4.11 Korganizer does not purge completed todos. I tick off completed todos in the list, they go to the bottom of the list, then right clicking and selecting ‘purge completed’ does nothing: the completed todos remain in the list. Terminal output gives nothing.

Has any one else encountered this?

Tested, works fine here.
Question: how did you perform the upgrade to KDE 4.11?

I just tried and it doesn’t work here either (4.11).
I guess this should be reported at http://bugs.kde.org/ then…

I added the KDE 4.11 repos (4.11 and Extra), disabled the 4.10 repos, and did a ‘switch system packages’ through Yast. Strange that it works on some systems and not others.

Well, maybe Knurpht is still using 4.10, at least his signature would imply that and he didn’t say otherwise.

@Knurpht: Did you test this on 4.10 or 4.11?
And just to be sure: this is about “Purge Completed”. Normal deleting works fine.
Steps to reproduce:

  • open KOrganizer and switch to the “To-do List” (“View” menu)
  • add a new to-do item
  • click on the tick-box to mark it as completed
  • right-click on that entry and select “Purge Completed”
    The entry stays in the list here.

Strange enough, I tried “Purge completed To-dos” in the “File” menu as well now (didn’t see that before), and that successfully removed the entry…
So apparently it’s just the context menu entry that doesn’t work.

OK, get it now. And indeed, that doesn’t work.
BTW, I’m on KDE 4.11 on my laptop, since TW serves that. Not using the Kontact suite on the other machine (yet).

I never noticed the purge completed option in the ‘file’ menu, so thanks for that. For me it only half-worked. It purged only half of my completed to-dos, but it purges newly created tasks; so it’s not just the context menu, or there is something about these particular tasks.