PulseAudio - Only Dummy Output

Hi,

Sometime in the last few days I seem to have lost all my input/output devices in Pulseaudio, the only thing I have there is “Dummy Output”.
YaST can still see them and I can even play the test sound through them…

Could a recent update have caused this? Any ideas on how to get this fixed?

Thanks.

Same thing here. No audio and no system sounds.

Hi
Still part of the audio group? Is alsasound service running?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
up 4 days 18:35, 3 users, load average: 0.13, 0.08, 0.11
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

I did some more updates this morning and now I have a black screen when the desktop comes up. At boot, everything looks normal until the splash screen fades to black. I reinstalled the nvidia drivers but that didn’t help.

Probably missing an alsa-pulseaudio plugin package, which should have been put in dependencies for the better …

Thank you, good sir, adding myself to the audio group fixed it for me.

Hi
To me that would be a bug…?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
up 4 days 20:13, 3 users, load average: 0.34, 0.21, 0.16
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

Definitely. I also discovered the other day that ‘enable printing’ was turned off in YaST printer configuration after an update. I solved my audio problems the same way but KDE is still booting to a black screen. I’m using xfce for the time being.

Using KDE/Qt? Problem with the Qt packages, not related to the sound problem:
[opensuse-kde] KDF 4.7.1 packages ̣- black screen](http://lists.opensuse.org/archive/opensuse-kde/2011-09/msg00138.html)

I did some more updates today and KDE is back up again. I think it was related to libqt4 packages.

I’m part of the audio and of the pulse group and I still get the dummy device!

I found out that alsa-programs like the flash-player stil work when pulseaudio only finds the dummy-device.
And there’s a workaround: You have to restart the alsa-service using

sudo -s rcalsasound restart

But why? :open_mouth:

Seems to be solved since the last dup… lol!

I’ve encountered this problem today :frowning:
zypper dup won’t help
any ideas?

I zypper dup almost daily, so it must have been quite recent update…

This is related with udev and filesystem packages.
Filesystem was removed from tumbleweed, causing new version of udev to malfunction.

Please either update filesystem or downgrade udev.

Hi!
I have the same problem - it works very strange:

  1. Youtube video sounds sometime works only in headphones, sometimes don’t
  2. VLC player sound sometimes works, sometimes don’t
  3. The volume control bar disappeared from the panel
  4. Sound control shows that works only Dummy Output
  5. Qmmp player sound doesn’t work anyway
  6. Sound control (Pulse audio) sometimes appear, sometimes after click show this: “Waiting for sound system to respond”
  7. alsa installed

Please help!

  1. This is the Tumbleweed Subforum, you wrote: opensuse 13.2

  2. This Thread is 3 years old.

  3. And your Problem is a bug with the pulseaudio-Update, so switch back to the older Version of pulseaudio.
    http://bugzilla.opensuse.org/show_bug.cgi?id=928035

Switched to the older version. It helped!

Thanks a lot!

I had the dummyoutput problem after i updated my GNOME 3.14 today . I downgraded packages with name “pulse” in them and it solved the problem.

Update for openSUSE 13.2 is in the normal Update-Repo.

Add the group “pulse” to your username in Yast–>Security and Users–>User and Group Management.
Shut down and restart your system.

The dummy output disappears and is replaced with the correct one.