Pulseaudio not working

When I install and try to start up Pulseaudio, I receive this error message:


Why is that?


OpenSUSE Leap 42.1
Logitech G35 USB headset
AMD FX-8350
MSI R9 280x
ASUS M5A97 R 2.0

How did you install (isn’t it installed by default)?

How did you try to start it?

Installed it by opening Yast 2 and searching for “pulseaudio” in the local repositories.

And also opened it by selecting it from the “start menu”.

Edit: I installed the package “pavucontrol”. Is there anything more that’s needed to get it to work?

PA is installed by default in most cases at least. You need to explain why your system is different?

Does audio work in Yast -sound?

Be sure the PA usage is selected there

Well, to be honest I don’t know. I only remember that I used YaST to install it, without even considering the possibility of it already being there.

I installed OpenSUSE with LXDE only if that has anything to do with it.

And also, when I go to “sound” in Yast, click “other” and then “PulseAudio configuration” i recieve the following error:

“PulseAudio is not installed or cannot be configured.”

Anyone :’(

The error you reported in your opening post refers to a mis-configured client.conf, so you should investigate that first. It’s located in the /etc/pulse/ directory. Post the configuration here if needed.

Review this troubleshooting guide for PA

Any errors reported here?

journalctl -b |grep pulse

I’m assuming the daemon won’t be running, but you can check anyway…

ps aux|grep pulse

If it isn’t running, try launching in a terminal as regular user

pulseaudio -vvv

If it is running, then you need to kill it first, but openSUSE has client.conf configured to respawn it automatically so that needs to be turned disabled first. The following option in client.conf will take care of that

autospawn = no

then kill PA with

pulseaudio -k

Capture what is reported by the daemon when relaunched as that might yield more information about what is wrong.


# This file is part of PulseAudio.
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# General Public License for more details.
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; default-sink =
; default-source =
; default-server =
; default-dbus-server =

; autospawn = yes
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; auto-connect-localhost = no
; auto-connect-display = no
autospawn = yes

You didn’t need to upload the commands output. That is only necessary for verbose output. Anyway, the fact that the command was not found indicates that pulse audio is not installed. What I find surprising is that it is missing to begin with, since it would normally be installed by default. Did you remove it?

Install it and other dependent packages with

sudo zypper in pulseaudio

I cannot believe this -_-

I thought that you only needed the *pavucontrol *package to get the Pulseaudio sound control “thing”. What a howler

Thank you very much for helping. It’s now working properly :slight_smile:

LOL… glad to have been of help.