Pulseaudio Monitor/Hardware

I’ve been regularly using PA to manage my hardware devices without an issue for many months.
Suddenly I seem to have a problem where the PA meters in the volume control indicate that the mic
is working, but my application (arecord) does not get any input. If I switch to the “Recording” tab in PA
it shows me that I have 3 options for my hardware interface: monitor source, monitor or the hardware itself.

Sometimes on switching devices PA seems to select the ‘Monitor source’, so I have no sound
until I manually select the last option (the hardware) at which point the mic starts working.

So the issue is that PA does not always select the right option. I’ve tried to think what I might have changed
(it does not seem to be kernel related even though I recently went to 3.2 which seems fine). I’ve also tried to find
a set of selectable options to force it into the right startup option but so far have failed to locate it.

Any suggestions?

Colin Beckingham

You could write a bug report on this erratic behaviour. There is guidance for bug reports here: openSUSE:Submitting bug reports - openSUSE You can use your openSUSE forum username and password when logging on to bugzilla. Please ensure you mention (1) your desktop and (2) your openSUSE version in your bug report (as that information is missing from this thread).

I recently blogged on pulse audio volume control (pavucontrol) which I assume you refer to when you abbreviate PA (?) … Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums However my blog has no answers for your observations.