pulseaudio-equalizer doesn't work

Hi,
I’ve got openSUSE Tumbleweed and I’ve installed pulseaudio-equalizer from packman repo. Now, if I click on pulseaudio-equalizer in gnome menu, nothing happens. It worked for me on debian. Here is terminal log

tommaso@R530:~> pulseaudio-equalizer-gtk
Getting settings...
/usr/bin/pulseaudio-equalizer: line 221: /home/tommaso/.pulse/equalizerrc: File o directory non esistente
mkdir: impossibile creare la directory "/home/tommaso/.pulse/presets": File o directory non esistente
/usr/bin/pulseaudio-equalizer: line 229: /home/tommaso/.pulse/equalizerrc.availablepresets.unsorted: File o directory non esistente
sed: couldn't flush stdout: Pipe interrotta
/usr/bin/pulseaudio-equalizer: line 232: /home/tommaso/.pulse/equalizerrc.availablepresets.unsorted: File o directory non esistente
ls: impossibile accedere a /home/tommaso/.pulse/presets/*.preset: File o directory non esistente
/usr/bin/pulseaudio-equalizer: line 235: /home/tommaso/.pulse/equalizerrc.availablepresets: File o directory non esistente
rm: impossibile rimuovere "/home/tommaso/.pulse/equalizerrc.availablepresets.unsorted": File o directory non esistente
Traceback (most recent call last):
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 535, in <module>
    Equalizer()
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 357, in __init__
    GetSettings()
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 46, in GetSettings
    f = open(eqconfig, "r")
IOError: [Errno 2] File o directory non esistente: '/home/tommaso/.pulse/equalizerrc'
tommaso@R530:~> 

I’m italian so my system is in italian. “File o directory non esistente” means “No such file or directory”.
Thanks

Hmmm … I dont’ speak Italian, so thanks for the translation.

OK, so the file is not found. Out of curiousity, what happens if as a regular user you create the file ‘/home/tommaso/.pulse/equalizerrc’ (create it to be an empty text file).

Then as a regular user restart pulse audio with something like (or just reboot):


pulseaudio -k
pulseaudio --start

and then try running pulseaudio-equalizer ?

It still doesn’t work:

tommaso@R530:~> pulseaudio-equalizer-gtk
Getting settings...
/usr/bin/pulseaudio-equalizer: line 68: : 0: unary operator expected
/usr/bin/pulseaudio-equalizer: line 78: 10+: syntax error: operand expected (error token is "+")
(standard_in) 1: syntax error
ls: impossibile accedere a /home/tommaso/.pulse/presets/*.preset: File o directory non esistente
Traceback (most recent call last):
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 535, in <module>
    Equalizer()
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 357, in __init__
    GetSettings()
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 64, in GetSettings
    num_ladspa_controls = int(rawdata[9])
ValueError: invalid literal for int() with base 10: ''


Where “File o directory non esistente” still means “No such file or directory” (It seems that italian didn’t change in the last 5 minutes lol!)
If you need more translations ask me.

So now its looking for another directory/file.

Does the directory /home/tommaso/.pulse/presets/ exist ? If not, as a regular user, create it.

Then restart pulse as noted above. I note that on my PC with pulseaudio-equalizer, I have that directory, but I have no files inside of it.

I’ve got it, but no files in it.

ok, … I think that advice of mine was not relevant. When I successfully launch pulseaudio-equalizer from a terminal, this is what I get:


oldcpu@corei7-920:~> pulseaudio-equalizer-gtk
Getting settings...
ls: cannot access /home/oldcpu/.pulse/presets/*.preset: No such file or directory
Match!
Fontconfig warning: "/etc/fonts/conf.d/56-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.

… but pulse successfully runs even with the above.

Where did you get your pavucontrol from ? Could it be the install was corrupted ?

On my PC I note:


oldcpu@corei7-920:~> rpm -q pavucontrol
pavucontrol-1.0-7.1.3.x86_64

I assume also that you have pulse audio running ?

I had the same Problems with Tumbleweed and openSUSE 12.3 in a Virtualbox, after creating the ~/.pulse it works.

Please post also:

zypper lr -d

#  | Alias                     | Nome                               | Abilitato | Aggiornamento | Priorità | Tipo   | URI                                                                      | Servizio
---+---------------------------+------------------------------------+-----------+---------------+----------+--------+--------------------------------------------------------------------------+---------
 1 | Current-Non-Oss-Updates   | Current-Non-Oss-Updates            | Si        | Sì            |   99     | rpm-md | http://download.opensuse.org/update/openSUSE-non-oss-current             |         
 2 | openSUSE-12.3-1.7         | Current-Oss                        | Sì        | Sì            |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/     |         
 3 | packman                   | packman                            | Sì        | Sì            |   98     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed                         |         
 4 | repo-debug                | openSUSE-12.3-Debug                | No        | Sì            |   99     | NONE   | http://download.opensuse.org/debug/distribution/12.3/repo/oss/           |         
 5 | repo-debug-update         | openSUSE-12.3-Update-Debug         | No        | Sì            |   99     | NONE   | http://download.opensuse.org/debug/update/12.3/                          |         
 6 | repo-debug-update-non-oss | openSUSE-12.3-Update-Debug-Non-Oss | No        | Sì            |   99     | NONE   | http://download.opensuse.org/debug/update/12.3-non-oss/                  |         
 7 | repo-non-oss              | Current-Non-Oss                    | Sì        | Sì            |   99     | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/ |         
 8 | repo-source               | openSUSE-12.3-Source               | No        | Sì            |   99     | NONE   | http://download.opensuse.org/source/distribution/12.3/repo/oss/          |         
 9 | repo-update               | Current-Update                     | Sì        | Sì            |   99     | rpm-md | http://download.opensuse.org/update/openSUSE-current/                    |         
10 | standard                  | standard                           | Sì        | Sì            |   98     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/ |         

“Si” means “Yes”, “No” means “No”

I’ve installed pavucontrol but got this

Getting settings...
/usr/bin/pulseaudio-equalizer: line 68: : 0: unary operator expected
/usr/bin/pulseaudio-equalizer: line 78: 10+: syntax error: operand expected (error token is "+")
(standard_in) 1: syntax error
ls: impossibile accedere a /home/tommaso/.pulse/presets/*.preset: File o directory non esistente
Traceback (most recent call last):
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 535, in <module>
    Equalizer()
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 357, in __init__
    GetSettings()
  File "/usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py", line 64, in GetSettings
    num_ladspa_controls = int(rawdata[9])
ValueError: invalid literal for int() with base 10: ''

My Repos with Priority:

zypper lr -d
# | Alias               | Name                             | Aktiviert | Aktualisieren | Priorität | Typ    | URI                                                                      | Dienst
--+---------------------+----------------------------------+-----------+---------------+-----------+--------+--------------------------------------------------------------------------+-------
1 | Packman-Tumbleweed  | Packman-Tumbleweed               | Ja        | Ja            |   20      | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed                         |       
2 | openSUSE_Tumbleweed | openSUSE Tumbleweed              | Ja        | Ja            |   80      | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/ |       
3 | repo-non-oss        | openSUSE Current non-OSS         | Ja        | Ja            |   99      | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/non-oss/ |       
4 | repo-oss            | openSUSE Current OSS             | Ja        | Ja            |   99      | yast2  | http://download.opensuse.org/distribution/openSUSE-current/repo/oss/     |       
5 | repo-update         | openSUSE Current OSS updates     | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/update/openSUSE-current/                    |       
6 | repo-update-non-oss | openSUSE Current non-OSS updates | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/update/openSUSE-non-oss-current/

And I have made a

zypper dup

This seems to indicate that the file $HOME/.pulse/equalizerrc is corrupted.
Try to run this as user in a terminal window:

pulseaudio-equalizer interface.resetsettings

This should recreate the file with default values.

Or you could try to remove $HOME/.pulse/equalizerrc…

Finally… it… works!
I’ve tried a lot of distros, so I’ve registered to a lot of forums. This forum is the best!
Thank you!

I had this problem on 12.3 as well. Installed via YAST from the packman repo. I added the ~/.pulse and ~/.pulse/presets directories and used wolfie’s reset command and it now works.

Couple of other factors that may have solutions.

I played with the 50Hz setting and couldn’t get it back to zero. Looking in the equalizerrc file there may be something in that to increase the resolution of the controls? Currently the slider can be set to either + or - 0.2dB - not much I know but…

When I enable the equaliser there is a slight increase in volume.

My speakers response is more or less flat from 50Hz to 20Khz. In real terms I could do with altering the response below 50Hz.

Looking at the equalizerrc file it may be possible to change some of this. Any one have any experience?

Content is currently


mbeq_1197
mbeq
Multiband EQ
1.0

0
0
-30
30
15
-0.2
0
0
0
0
0
0
0
0
0
0
0
0
0
0
50
100
156
220
311
440
622
880
1250
1750
2500
3500
5000
10000
20000

It looks like the -30 30 are the range which is over the top really. 15 relates to the number of frequencies so it may be possible to change it???

Looking about on the web for info I came across another equaliser.

https://sites.google.com/site/nevion/projects/qpaeq

I did find mbeq_1197.xml and a win32 version where the frequencies seem to be fixed so the above may be the only one that can offer an extended range of frequencies.

John