Pulseaudio doesn't start :(

Hi everyone. I’m trying to get work my headphones for skype. While sound output works ok, the microphone doesn’t. So I tried to record a test recording using

arecord -d 10 testrecording.wav

but the result was

ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused

arecord: main:590: audio open error: Connection refused

Next try was to run alsa-info script which outputed info to http://www.alsa-project.org/db/?f=d2f2424564f8090d668bc0cd5a4d4eb0e132ac2dFrom the info I saw that pulseaudio isn’t running at all. I tried to run it manually and it says

W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied
W: ltdl-bind-now.c: Failed to find original dlopen loader.
W: pid.c: Stale PID file, overwriting.
E: module-alsa-source.c: Assertion 'u->hw_dB_supported' failed at modules/module-alsa-source.c:742, function source_get_volume_cb(). Aborting.

I did also some queries:

linux-e685:~ # rpm -qa |grep alsa

linux-e685:~ # rpm -qa |grep pulse                                                                        

. I gues there is some conflict between alsa and pulse, but I have no clue how to solve it. Any help is higly appreciated.

W:main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied

Is this perhaps (partly) a permission problem? In that case just check if the useraccount you use, is a member of the audio-group.

If you don’t know how to achieve this:
start Yast - security and users - Usermanagement - select your account - after your account opens, select tab details - place a checkmark next to “audio”, if necesarry. Then restart X (or restart your computer) and check wether this helped somewhat.

Best of luck.

Thanks akaper, I checked but the user is member of audio group, what else could cause the security problem. Should the regular user also be member of pulse,pulse-access and pulse-rt group? Thanks again for your help.

Well, I hope somebody else could shine some light here, to be honest. Perhaps you could provide a bit more information, about the problem and what more you have done so far.
I understand that you have no sound output problem: that means that you can play webvideo’s, without bunks or glitches? You have sound-output in for instance skype?

The pulse-groups were unchecked on my system. I checked them without ane noticable effect.

Tried this code without problems (do you hear a female voice chanting left-right)?

speaker-test -c2 -l5 -twav

Perhaps a bit of a stupid thing to ask: did you check your mixer settings for microphone?:shame:

Then there is this helpful website: http://en.opensuse.org/SDB:AudioTroubleshooting#Symptom
I suggest you try the steps here, if not tried yet.

If that doesn’t work: I got my sound working after the upgrade to opensuse 11.1 by checking the tips on this site:
Check your multimedia problem in ten steps - openSUSE Forums

I saw too that something about esound is reported by the alsa-script you used. Esound and pulseaudio are not quite compatible, perhaps you should check your installs in YAST and reinstall pulseaudio again.

And at the end: your computer type (desktop or laptop, age, brand, motherboard) your opensuse version and what GUI you use.

I’m not that an expert at all, but perhaps someone else will respond. And I will do my best in the meantime.

Did you try with root permissions?

I note your alsa configuration is very mixed up:

!!ALSA Version

Driver version:     1.0.17
Library version:    1.0.16
Utilities version:  1.0.18 

What did you do to have a different driver, different library and different alsa utility installed? How did you get a 1.0.16 version of the library? It looks to me that you installed an alsa version that was not intended for openSUSE-11.1 (possibly intended for 11.0, which you should not do … do you have 11.0 repositories selected in your software package manager ??? If so, you should not !! ).

I also note your PC has an ALC883 and that you have not attempted to apply a custom model setting in your /etc/modprobe.d/sound file. For 1.0.18 of alsa, the list of different settings (which can only be applied one at a time in the /etc/modprobe.d/sound file) are:

	  3stack-dig	3-jack with SPDIF I/O
	  6stack-dig	6-jack digital with SPDIF I/O
	  3stack-6ch    3-jack 6-channel
	  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
	  6stack-dig-demo  6-jack digital for Intel demo board
	  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
	  acer-aspire	Acer Aspire 9810
	  medion	Medion Laptops
	  medion-md2	Medion MD2
	  targa-dig	Targa/MSI
	  targa-2ch-dig	Targs/MSI with 2-channel
	  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
	  lenovo-101e	Lenovo 101E
	  lenovo-nb0763	Lenovo NB0763
	  lenovo-ms7195-dig Lenovo MS7195
	  lenovo-sky	Lenovo Sky
	  haier-w66	Haier W66
	  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
	  6stack-dell	Dell machines with 6stack (Inspiron 530)
	  mitac		Mitac 8252D
	  clevo-m720	Clevo M720 laptop series
	  fujitsu-pi2515 Fujitsu AMILO Pi2515
	  3stack-6ch-intel Intel DG33* boards
	  auto		auto-config reading BIOS (default)

I do not know the contents of your /etc/modprobe.d/sound file, so I can not provide a recommendation for that yet. What is the output of cat /etc/modprobe.d/sound
I also think you should also fix the bad versioning of your alsa driver. One way to do that is to insert your installation CD/DVD and roll back to the alsa version that comes with openSUSE-11.1.

Since a search of ALC883 (which is on your PC) on the alsa web sites indicates updates to alsa since 1.0.16 (which is the library you have):
Search results - AlsaProject
You could then try to update you alsa to the latest cutting edge versions.

You can do that by opening a gnome-terminal or a kde-konsole and type “su” (no quotes - enter root password when prompted) and then copy and paste the following six zypper commands, in sequence, one at a time, to update your alsa version to a consistent version:

 zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.1/ multimedia 
zypper install alsa alsa-utils alsa-plugins-pulse alsa-plugins alsa-plugins-jack alsa-oss alsa-tools alsa-firmware libasound2
 zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1/ multimedia
 zypper install alsa-driver-kmp-pae
 zypper rr multimedia

then restart your pc and test your sound and your microphone.

If that does not work, post the content of your /etc/modprobe.d/sound file (as requested above) and I can propose a logic to iteratively update that file and test your mic.

Thanks oldcpu, I did update the alsa stuff to the latest versions as you recomended and now after several days of tough tries of adjusting and trying to phisicaly change the sound card,finally my sound works as it should. And also pulseaudio runs now ok. Thanks again for your exhaustive help.

How you managed pulse audio to run? I have a working soundcard, but some ways i get the pulse audio can’t connect message.

Don’t know :slight_smile: it just started working after latest alsa stuff installed.