PulseAudio and Selecting the Proper Sound Card Configuration

Today, a lot of computers have more than one sound generating device. However, as far as hearing sound is concerned, its is very likely you have only one set of speakers or sound cable connected up to a single output on your PC. PulseAudio (freedesktop.org - Software/PulseAudio/About) has been our default sound server in openSUSE for some time now. So one issue I run into on every openSUSE install is the need to disable all sound devices, recognized by PulseAudio, that are not connected to my speakers. Besides the obvious problem of having no sound, it can even interact with the likes of KMIX in KDE and prevent the volume setting from being saved between each new openSUSE session. PulseAudio is considered a sound driver to KMIX in KDE.

So, here are the steps to use only one audio device in your PC. My examples are taken from a KDE session:

  1. Start up YaST / Hardware / Sound and make sure all devices have been configured, select any that are not and edit them with defaults. Make sure that the main sound device you use is listed as Index 0 (If your sound device is not** Index 0** then highlight your primary sound card under Card Model, then Select the Other button on the bottom right corner and pick Set as the Primary Card):

Under the same Other button, there is an option called “PulseAudio** Configuration…**” which should be checked. If you want to go on without using PulseAudio and switching to Alsa, uncheck it here and PulseAudio will be disabled. I suggest that you NEVER uninstall PulseAudio, but just disable it to try other things. If they do not work out for you, come back here and enable this option again so that it always looks like this:

  1. Next you want to install pavucontrol from YaST. pavucontrol (PulseAudio Volume Control) is intended to work with Gnome, but works great in KDE as well. Go to YaST / Software / Software Management, search on pavucontrol, check it and install it. Other support files may also be installed and that is OK.

  1. Now lets start it up. You can do Alt-F2 and enter “pavucontrol” to find and run or in KDE its menu / Multimedia / Volume Control / PulseAudio Volume Control. Now run it:

Go to the Configuration Tab and set the Profile for all devices you do not use to Off. There is no save function required, Your setting selections made here are immediate.

If your sound card supports more than PCM audio, you should have check blocks for AC3, DTS, EAC3 and MPEG on the Output Device Tab of the pavucontrol application. These are the formats supported by your sound card, you check only the ones supported by your speakers or receiver controller connection. Anything other than PCM requires you to use an Optical, Coaxial or HDMI connection to your speakers or receiver. In addition, added settings may be required in your video player when using VLC, MPLAYER or Totem. A simple stereo cable will only provide stereo, though a few methods include three stereo cables. Don’t check anything here you don’t want to normally use, even if supported, for any reason.

If for any reason you want to keep more than one sound device enabled, then you need to make sure the main sound device is listed first in PulseAudio as well. To do this in KDE go to menu / Configure Desktop / Hardware / Multimedia / Phonon (on left) / Device Preference Tab / Select your Preferred device and keep pressing Prefer until it is at the top. Devices set to off will be grayed out here.


If you want to use a Line-in or Aux input, but you find that it shows audio is working, but you have no audio output you can hear, you can enable monitor functions so that these inputs provide audio operation directly. You may not want to use this option if you use a Microphone also on the same system as you can get feedback when the Mic is enabled.

To enable monitoring as a temporary function, open terminal and run this command:

pactl load-module module-loopback latency_msec=1 channels=2

To Make this a permanent fix, you need to add it to the default.pa file as root. Open terminal and type the following command:

sudo sh -c ' echo "load-module module-loopback latency_msec=1 channels=2" >>  /etc/pulse/default.pa '

KMIX Settings:

In KMIX Settings, check your settings against mine if your volume is still not being preserved on restart.

One last suggestion, if you use KDE and KMIX, you might like to set your percentage adjust from five percent to just 1 percent. To make this change, do an Alt-F2 and enter:

kwrite $HOME/.kde4/share/config/kmixrc

Under the Global section, modify (or add if missing) the setting named as “VolumePercentageStep=1” which sets the adjustments to using just one percent instead of 5 percent, the default.


PulseAudio can output audio levels above 100%, thus over driving some devices. You can stop this in KDE with this command:


Once you are complete, I suggest you restart your PC to get the full effect of all of the changes listed above.

For even more info on using pavucontrol, have a look at this blog by oldcpu: Pulseaudio Basics for openSUSE with pavucontrol

I have a bash script for testing sound you can find here: S.T.A.R.T. - SuSE Terminal Audio Reporting Tool - Version 2.00 - Blogs - openSUSE Forums
Now to test your sound even further, check out these YouTube [size=3]Video Links:[/size]**

This video is silly perhaps, but the sound is not, so turn it up: 009 Sound System “Wings (Hardrox Remix) Official HD” - YouTube

Another nice video that could give you a heart attack is here: Demi Lovato - Heart Attack (Official Video) - YouTube

A nice song with no video, but a keeper: Daft Punk - Within [Random Access Memories] - YouTube

Another Good one from the same gang: Daft Punk The Game of Love (CD version) - YouTube

Here is one that is a little suggestive, but very nice: Alex Gaudino - Destination Calabria [HD] 1080p - YouTube

Do you feel Luck? Get Lucky Today: Daft Punk - Get Lucky (Music Video) - YouTube

And under the category its my blog and I can post any song I want: Hubble Slide Show [Laura Veirs - Galaxies] - YouTube

The Video May be old, but the audio is good. Turn it Up: Stars - Roxette. - YouTube

Another Good one from Roxette: Roxette - Wish I Could Fly - YouTube

Here is a new one my Daughter pointed out to me from One Republic: OneRepublic - Counting Stars - YouTube

If you like the sound (and video) from these links, download them using** Clipgrab **which you can find in the Packman repository and have lots of fun.

The Application is just called clipgrab and you can locate it with a Alt-F2 in KDE and just type in clipgrab to find and load it:

If you have issues in playing video in openSUSE, then for Multimedia Setup in openSUSE 12.3, please have a look here: openSUSE 12.3 Multi-media and Restricted Format Installation Guide

If you have any comments on this blog subject, please let me hear what they are.

Thank You,

Thanks for this I had been wondering how to organise the sound device list correctly. I have 3.

I fitted a new sound card moved it up KDE’s list and found some of kde’s sound outputs worked and others didn’t. This was corrected using the “apply list to” button. Fine but alsa still used the earlier arrangement. I can correct that now and suspect may have to use the apply list button again.


[QUOTE=John_82;bt926]Thanks for this I had been wondering how to organise the sound device list correctly. I have 3.

I fitted a new sound card moved it up KDE’s list and found some of kde’s sound outputs worked and others didn’t. This was corrected using the “apply list to” button. Fine but alsa still used the earlier arrangement. I can correct that now and suspect may have to use the apply list button again.


Happy to help and always leave any helpful info you have found out. Only through our combined efforts can we deal with PulseAudio and multiple sound devices.

Thank You,

In order to manually upgrade to clipgrab 3.3 here is what I had to do:

  1. Download Clipgrab version http://download.clipgrab.de/clipgrab-
  2. Using ARK, I extracted the executable file clipgrab- and renamed it to just clipgrab and set it as executable using Dolphin File Properties
  3. I opened up YaST / Software Managment
  4. I searched for and installed the applications; libQtWebKit-devel, libQtWebKit-32bit and mono-qt4-devel (This will install MANY files)
  5. You must have installed the older version of clipgrab. Copy the executable clipgrab from step 2 to the folder /usr/bin/clipgrab as root.
  6. Restart your PC.

This worked for me if you can’t wait for an update in Packman.

Thank You,

Sound configuration is always (often) tricky in Linux. Your article is very simple, clear and thorough. I easily solved a microphone problem in 5 minutes by following your steps. Thanks for the article and taking the time to write it!

I am very happy to help and thanks for your very kind words.

Thank You,

Thank you very much for this great blog article. Since the installation of openSUSE starting last year, the audio devices on my Thinkpad only work following your detailed advice given here. Thanks! :wink: