Pulse audio outputting s32le when set to s24le


My speakers/sound-monitors are active and they feed 24bit/192 audio. When I configured my Pulseaudio conf file to s24le and either 192000 or 96000 it magically switches itself to s32le. I have avoid re-sampling on(but tested with off also) and after running "pactl list short sinks" it shows that it switches to s16/44100 when playing spotify, but then changes to S32/48000 when opening say youtube or vlc for example. It starts to sound like a compressor is running because it's sampling up and down. While things like youtube audio are not exactly premium listening experiences, I would like to avoid having it ever going into 32bit since the speaker amplifier can't handle that and downsample making everything sound overprocessed. 

Thank you for the help.

Try to set PulseAudio

resample-method = copy


resample-method = soxr-vhq

Additionally you may change ALSA settings.

AFAIK problem is not with s32le.