pulse-audio impacting alsa sound-test

I ran into a strange quirk of pulse audio last night, helping a user on IRC #suse.

After updating to the latest alsa, with a custom /etc/modprobe.d/sound file, when running “speaker-test -c2 -l2 -Ddefault -twav” they get

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 128 to 1048576
Period size range from 64 to 262144
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
***** PULSEAUDIO: Unable to create stream**
and no sound.

but seconds later (no config changes in between) when running the speaker test “speaker-test -Dplug:front -c2 -l5 -twav” they get the proper audio (female voice saying “left” / “right” …etc … ).

What quirk of pulse audio causes the speaker test to fail in one case and not in the other?

Their system is a sony vaiovgc-rb52 with a CXD9872RD/K (which I treated like a STAC9872).

(1) … before alsa update, their diagnostic script output: tsalsa.txt - nopaste.com (beta) with all the details on their PC, codec, etc …
(2) … their /etc/modprobe.d/sound file was finally updated to:

options snd slots=snd-hda-intel
# u1Nb.sYhCI1EfSbC:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=vaio-ar 

with last line added. Still no sound. Nor with model-vaio (attempted previous).
(3) … alsa updated to latest alsa on Index of /repositories/multimedia:/audio/openSUSE_11.0 multimedia and Index of /repositories/multimedia:/audio:/KMP/openSUSE_11.0 where the alsa apps that were the latest as of 14/07/08 were installed.
Note their pulse audio was NOT updated with the many pulse audio apps on the first URL.
(4) they performed a reboot and sound worked after the reboot, with

“speaker-test -c2 -l2 -Ddefault -twav” not working
“speaker-test -Dplug:front -c2 -l5 -twav” working.

Any sound guru’s who can explain why?

  • Is it because alsa was updated to the latest cutting edge alsa, but pulse NOT updated to the latest cutting edge pulse (on same site).
  • Is this because of the difference in the two speaker-tests and how pulse audio works?
  • Or is this some other pulse quirk?

The good news is sound works now on their PC.