ps3 & open suse help

im not new to suse , but why does suse run slow on a ps3 ?

im using 11.1 suse (im new to that ,since i have been using 10.0) how can i speed it up a bit . i do get a message that that my system is runnuning slower to some update running in the back ground but have no idea what to edit to resolve this

Quit the updater applet and uninstall beagle indexing.


You do realize that the ps3 is restricted by a hypervisor right? You’re only getting 256 mb of memory to start off with.

I’d probably use my openSUSE installation on my ps3 more if my disc drive wouldn’t have died >:( But I had kde 4.0 on mine and it ran decently. KDE 4.2.2 would probably be even crazier.

Anywyas, you’re not going to get any decent performance from the ps3 until Sony allows more of the hardware to be used. You could also try a distribution that uses xfce as the Desktop Manager. But remember it has to be made for PPC. And last I checked openSUSE’s PPC with xfce was non-existant. But I haven’t tried that in a couple of months. That would be your best bet though. Reinstall and choose xfce as your desktop environment.

Hope this helps!


how do i do that

Right click the tray updater icon - Quit
If you don’t want it to start again you can configure that here too.

Yast - Software Management
Search: beagle
Right click and delete. (There are quite few beagle packages allow it to remove them all with the dependency check)

  • Just take note of Ian’s comments. I have no knowledge of ps3’s and it rather sounds like Ian does.

Hi again,

I just fired my ps3 up again. It seems like I had openSUSE 11.1 kde 4.1.3 installed on it! I ran some updates and it’s in the latest release. It doesn’t run too shabby. I mean upon further investigation it only has 217 MB of RAM to work with. I also found that xfce is a no go for openSUSE and ppc architecture. You can’t get any of the factory stuff either.

Also remember, since it’s the ppc architecture, you’ll have a limited option to install things. I blindly tried installing AdobeAIR to get Pandora Desktop and was quickly reminded that binary files don’t work in the ppc setting. So really, linux on the ps3 is more of a tinkering around thing than an actual desktop computer experience.

At least with openSUSE. You should try YellowDog Linux since it’s officially supported by Sony and you don’t have to do the workaround to get wireless working.

Hope this helps!


well i have open suse 11.1 with xfce on it … my only issue is i cant seem run anthing from cd .

i have vmware 6.0(just to try)and when i insert the dvd it says "unable to mount " it also says this with just a regular dvd , so how can i get it to run


I couldn’t seem to find any core packages for xfce. I could only find brandings and other minimal packages. What repositories are you using?

Anyways, perhaps some of the fixes that have been applied for the regular architectures haven’t made it to the ppc? Not sure how that stuff works. Have you tried to add yourself to the cdrom and/or disk groups?