PROXMOX6 SERVER UNABLE TO CONNECT INTERNET

Hello Team,

i am using Proxmox6 server environment for my ViciDial .

Vicidial Based on OpenSUSE Leap 15.1 Kernel 4.12.14-lp151.28.13-default.

i am trying to connect internet but unable to connect .

as per me because of my IP and my Gateway IP belong to different network.

MY IP : 51.x.x.200
My Gateway IP : 37.x.x.254

Help me to fix this issue .

let me know if you need any config file detail.

I do not know what Proxmox6 is, but when you want to communicate that the system can not connect to the internet becaue the systems IP address is in another network then the gateway that is configured on it, I can follow you.

Please always post the computer facts where you base your assumptions on. So e.g the IP address with

ip addr

and your router with

ip route

And what are you using to manage the network: Wicked or NetworkManager?
And where are the network parameters coming from: DHCP or fixed configuration?

IP addr = Image added. IP-ADDR hosted at ImgBB — ImgBB

IP route = no result

i try to configuration IP with Yast Lan and my configuration is static IP

So first this:
There is an important, but not easy to find feature on the forums.

Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

An example is here: Using CODE tags Around your paste.

This is easier to do then making an imgage of a simple piece of terminal text and also sompler to read directly from the post.
Also saying “No result” is not needed because we see it from the only two lines that you post in that case.

Back to your problem.

When you configure with YaST, I assume (but please confirm) that you choose for Wicked.

You saying that you configure the IP address through YaST, then means you have switched off DHCP.
It also means that you have to confifure your router in the same YaST module in the Routing Tab. Did you do that?

Agree with @hcvv,

But more completely…
A full network configuration usually comprises the following

  • IP address, with subnet mask
  • At least one gateway address, one being designated the Default Gateway
  • DNS server(s)

Whether you configure as a DHCP client or a static address manually, typically all of the above are required.
Without a gateway address, your machine cannot connect to a machine outside your immediate network segment.
Without DNS servers, you can connect to other machines by IP address but not by name (unless you have a specially mapped name in your /etc/hosts file)

You can configure at least the one “router” gateway address in the routing tab, and you can configure your DNS servers in the DNS and Hostnames tab.

HTh,
TSU

sharing you my detail network configuration in below IMG , after searching on google i mange to do this kind of configuration please let me know if i am doing any mistake

Imgur

sorry i try use tag but its not working here.

Imgur

I’m not familiar with proxmox6 at all, so can only provide general advice here.

I note that you’re connecting direct to the internet with a /32 address: 51.83.49.200/32 and that this connects to a gateway at 37.187.93.254 (at least that’s how your config info is presented to us)

Your manually added routing table (as per posted image) does not make sense. You have the destination address as your assigned ethernet NIC address. I would have expected a route to a destination network more like these examples

0.0.0.0/0    37.187.93.254    (a default route)
8.8.8.8     37.187.93.254     (a example static route)

The gateway router would have a similar route that looks like

destination network     netmask     gateway
 51.83.49.200    255.255.255.255    37.187.93.254

You may need to consider getting further assistance from
https://forum.proxmox.com/