ProtonVPN-GTK won't start

I switched from Protonvpn-GUI to the more recent implementation PROTONVPN-GTK
and it worked flawlessly up until about a month or so ago. I tried starting it via Konsole and this was the output. I am using KDE Plasma 6 on Wayland and Tumbleweed. I was wondering if anyone has a fix or any info on this issue if anyone else is even having this issue.

protonvpn-app
Traceback (most recent call last):
File “/usr/bin/protonvpn-app”, line 33, in
sys.exit(load_entry_point(‘proton-vpn-gtk-app==4.2.0’, ‘console_scripts’, ‘protonvpn-app’)())
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/bin/protonvpn-app”, line 25, in importlib_load_entry_point
return next(matches).load()
^^^^^^^^^^^^^^^^^^^^
File “/usr/lib64/python3.11/importlib/metadata/init.py”, line 202, in load
module = import_module(match.group(‘module’))
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “/usr/lib64/python3.11/importlib/init.py”, line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File “”, line 1204, in _gcd_import
File “”, line 1176, in _find_and_load
File “”, line 1147, in _find_and_load_unlocked
File “”, line 690, in _load_unlocked
File “”, line 940, in exec_module
File “”, line 241, in _call_with_frames_removed
File “/usr/lib/python3.11/site-packages/proton/vpn/app/gtk/main.py”, line 25, in
from proton.vpn.app.gtk.app import App
File “/usr/lib/python3.11/site-packages/proton/vpn/app/gtk/app.py”, line 28, in
from proton.vpn.app.gtk.controller import Controller
File “/usr/lib/python3.11/site-packages/proton/vpn/app/gtk/controller.py”, line 29, in
from proton.vpn.core.session import ClientTypeMetadata
ImportError: cannot import name ‘ClientTypeMetadata’ from ‘proton.vpn.core.session’ (/usr/lib/python3.11/site-packages/proton/vpn/core/session/init.py)

1 Like

Same issue here, worked fine in the past.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.