Proton VPN Authentication Required

Hi all,

I’m just new to tumbleweed. I installed proton vpn. It works fine, but I get several pop-ups all the time when I start proton vpn:

‘Authentication Required: System Policy prevents modification of network settings for all users.’

Is there a way to solve this through terminal?

Thanks a lot.

To my best knowledge, ProtonVPN creates NetworkManager connections on the fly and by default it needs authentication. You can allow this for your user to avoid such prompts.

Hi, tnx. I’m not tech-savvy al all. Do you know how I can do that?

I think it would have been much more useful to explain how to “allow this for your user to avoid such prompts” instead of just telling him to do it.

tom kosvic


I tried some commands in terminal like ‘sudo ls -la /etc/polkit-1/localauthority/50-local.d’. I get the answer ‘cannot acces’.

Another one I tried is sudo cat /etc/polkit-1/localauthority/50-local.d/50-allow-network-manager.pkla. Here I got the answer ‘No such file or directory’.

I couldn’t find any information about the problem I have specific for
Tumbleweed, so this might be the cause for these commands not working.

Are you using the Proton VPN client? If so, I’m not sure how to get that working correctly as I’ve never used the client but an easy alternative might be to add one or more VPNs via Network Manager.

Exactly how to do that depends on your desktop environment. In Gnome you can do the following:

  • Download one or more OpenVPN configuration files via your Proton VPN account.
  • Open Settings > Network and click the “Add” button in the VPN section.
  • In the Add VPN dialogue, select Import from file…
  • Navigate to the OpenVPN configuration file you downloaded.
  • Enter your VPN username and password under the Authentication settings
  • Click Add

You should now be able to enable / disable the VPN via the VPN option in your system tray.

1 Like

This file was used by old polkit versions. Today polkit switched to using JavaScript for rules. Except on Debian/Ubuntu that stuck using the old polkit version

I always wonder why users start with random Internet search hit instead of using what is available on own system. man polkit provides pretty decent overview, explains JavaScript specifics and gives examples. But if you do not want to learn JS - the most simple way is to edit /etc/sysconfig/security, set POLKIT_DEFAULT_PRIVS="easy" and run sudo set_polkit_default_privs. This will reconfigure polkit to allow most actions for the currently logged in user without explicit authentication.

bor@tw:~> nmcli connection add type ethernet autoconnect no
Error: Failed to add 'ethernet' connection: Insufficient privileges

Now edit

or@tw:~> grep POLKIT_DEF /etc/sysconfig/security
bor@tw:~> sudo set_polkit_default_privs
bor@tw:~> nmcli connection add type ethernet autoconnect no
Connection 'ethernet' (8163ba0a-ec5c-4f17-9629-df4eea800fb1) successfully added.

If you still get authentication request, then you need to investigate what your application does. May be ask on their support channels.


Thanks! I will go and try it.

And? Did you try it? Did it help?

Hi arvidjaar. No, it didn’t work out. I must have done something wrong. The solution of beepmode is a nice temporary solution anyway. I don’t have that much time. But I’m thinking try your solution again in a VM. Have to find out which VM and how it works. Your suggestion to learn JS is tempting, but well… time.