Proprietary NVIDIA display mode problem with Geforce 6200 and Acer X193W

Hi, I have a bit of a problem with the proprietary nvidia driver which I installed as a binary on suse 11.3,
when I run the nvidia-settings gui it does not give any widescreen display modes as options.

My monitor is an Acer x193w which will do 1440x900 but there is no option for that.

The monitor is just listed as a generic CRT, and only 4x3 display modes are given.

My card is a PNY Geforce 6200 AGP 512MB.

Thanks for any help.

To help our experts understand this better, could you provide the output of the command


Also, please open with a text editor the file /var/log/Xorg.0.log and copy and paste the contents to the openSUSE paste site and press ‘create’ on that site, and then post here the output URL/web-address it gives, so that our forum experts can examine the content of that log.

That log file may provide the information needed to understand why you are not seeing as an option the resolution you wish to achieve.

thanks for your help oldcpu.

xrandr gives:

Screen 0: minimum 320 x 240, current 1024 x 768, maximum 1280 x 960
default connected 1024x768+0+0 0mm x 0mm
1024x768 50.0 51.0 52.0 61.0*
832x624 53.0
800x600 54.0 55.0 56.0 57.0 58.0
640x512 59.0 60.0
640x480 61.0 62.0 63.0 64.0
576x432 65.0
512x384 66.0 67.0 68.0
416x312 69.0
400x300 70.0 71.0 72.0 73.0
320x240 74.0 75.0 76.0
1152x864 77.0
1280x960 78.0

my Xorg.0.log is at SUSE Paste

According to that your PC is using 1024x768 resolution, and your PC has the higher 1280x960 resolution available. What is available is different from the 1440x900 that you believe is possible and so we need to determine why that is the case.

From the /var/log/Xorg.0.log file I note:

#**    25.024] (WW) NVIDIA(GPU-0): The EDID read for display device CRT-1 is invalid: the**
#**    25.024] (WW) NVIDIA(GPU-0):     checksum for EDID version 1 is invalid.**
#    25.024] (--) NVIDIA(GPU-0):
#    25.024] (--) NVIDIA(GPU-0): Raw EDID bytes:
#    25.024] (--) NVIDIA(GPU-0):
#    25.024] (--) NVIDIA(GPU-0):   00 ff ff ff ff ff ff 00  04 72 06 00 76 5e 71 74
#    25.024] (--) NVIDIA(GPU-0):   2f 11 01 03 68 28 19 6b  2a 67 60 a2 5a 49 9e 23
#    25.024] (--) NVIDIA(GPU-0):   13 50 54 bf ef 00 81 8f  81 80 95 0f 95 00 01 01
#    25.024] (--) NVIDIA(GPU-0):   01 01 01 01 01 01 9a 29  a0 d0 51 84 22 30 50 98
#    25.024] (--) NVIDIA(GPU-0):   36 00 98 ff 10 00 00 1c  00 00 00 ff 00 4c 41 4d
#    25.024] (--) NVIDIA(GPU-0):   30 38 30 30 33 34 32 31  30 0a 00 00 00 fd 00 37
#    25.024] (--) NVIDIA(GPU-0):   4b 1e 53 0e 00 0a 20 73  20 20 20 20 00 00 00 fc
#    25.024] (--) NVIDIA(GPU-0):   00 41 63 65 72 20 58 31  39 33 57 0a 20 20 00 f6
#    25.024] (--) NVIDIA(GPU-0):
#    25.025] (II) NVIDIA(0): NVIDIA GPU GeForce 6200 (NV44) at PCI:1:0:0 (GPU-0)
#    25.025] (--) NVIDIA(0): Memory: 524288 kBytes
#    25.025] (--) NVIDIA(0): VideoBIOS: 05.44.a2.10.51
#    25.025] (II) NVIDIA(0): Detected AGP rate: 8X
#    25.025] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
#    25.025] (--) NVIDIA(0): Connected display device(s) on GeForce 6200 at PCI:1:0:0
#    25.025] (--) NVIDIA(0):     CRT-1
#    25.025] (--) NVIDIA(0): CRT-1: 400.0 MHz maximum pixel clock
#    25.026] (II) NVIDIA(0): Assigned Display Device: CRT-1
#**    25.026] (WW) NVIDIA(0): No valid modes for "1440x900+0+0"; removing.**
#    25.026] (II) NVIDIA(0): Validated modes:
#    25.026] (II) NVIDIA(0):     "nvidia-auto-select+0+0"
#    25.026] (II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
#**    25.027] (WW) NVIDIA(0): Unable to get display device CRT-1's EDID; cannot compute DPI**
#**    25.028] (WW) NVIDIA(0):     from CRT-1's EDID**.

The above states there is a problem with the EDID file that characterizes your monitor for the graphic card

And there is a strange entry at the end of your openSUSE’s /var/log/Xorg.0.log file:

#    43.578] (II) NVIDIA(0): Setting mode "640x480"
#   106.861] (**EE) NVIDIA(0): Failed to allocate primary buffer: out of memory.**
#   106.861] (EE) NVIDIA(0):  *** Aborting ***
#   106.862] (II) NVIDIA(0): Setting mode "640x480"
#   124.373] (II) NVIDIA(0): Setting mode "CRT-1:1280x960@1280x960+0+0"
#   145.560] (II) NVIDIA(0): Setting mode "CRT-1:1024x768@1024x768+0+0"

I’m puzzled why that entry is there but presumeably it is related to the EDID entry.

We need one of our graphic card experts (who know more than I) now to step in and provide a way to proceed here.

Many problems with that company.

I don’t think that comment is helpful on this thread. One can say the same about:

  • Intel
  • where Intel integrated/embedded core i3 and core i5 graphic processors are causing massive problems with all Linux distributions, and where older hardware (such as i855GM) are unstable or broken ever since an update inside the 2.6.28 and all subsequent kernels, and - ati
  • where ATI graphic card drivers are constantly late and do not work with new kernel releases, they often do NOT include a release note with their Linux updates, and their proprietary driver support for offloading video from the CPU to GPU is simply pathetic. Pathetic. Anyone who wants to use new cutting edge ATI hardware with new kernel release are OUT OF LUCK for extended and totally unacceptable periods of time.

Both Intel and ATI have poor reputations in some cases, even worse than any bad news about nVidia.

So the long and short of it is NO graphic supplier is great with Linux, and statement such as I quoted in a support thread is controversal and definitely NOT helpful. Lets stick with the matter at hand, which is helping the user.

Sorry fo this comment but is true. Nvidia has many problems with linux, but amd has not, all in Hellas subforum have amd products because we have not problems with our operating system and we have better performance than nvidia.

Sorry if my comment is caustic, but it is true.

Always Friendly!!!:slight_smile:

Well I’ve managed to fix it, now I have 1440x900 resolution, but I’m not quite sure how I did it!

First I tried renaming xorg.conf and editing 50-device.conf, 50-monitor.conf,
and 50-screen.conf in /etc/X11/xorg.conf.d, but this made no difference.

Then I tried xrandr with this article I found: How change display resolution settings using xrandr | Ubuntu Geek

  • but xrandr complained that my max resolution was 1024x768 and refused to display 1440x900 (I know, I managed somehow to reduce my max resolution listing under xrandr - don’t ask me how!)

Then I reinstated xorg.conf and made the edit in bold:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       28.0 - 80.0
    VertRefresh     43.0 - 75.0
    **ModeLine       "1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync**
    Option         "DPMS"
  • from the output of “cvt 1440 900”

I also added

SubSection "Display"
	Depth 24
	Modes "1440x900"
  • to the “Screen” section of xorg.conf.

Again, on reboot these changes made no difference.

However, when I ran the nvidia-settings gui again, as if by magic it gave me
the 1440x900 display option!

On reboot the change was lost, but there was now the 1440x900 option
in the gui launched from the monitor icon on the task bar, and using that
made the change stick.

So unless I’ve forgotten anything else I did, I think making the changes to xorg.conf then using the gui’s did the trick.

What might be interesting now is to see your current: /etc/X11/xorg.conf file, and also the contents of your /etc/X11/xorg.conf.d/50-device.conf, 50-monitor.conf, and 50-screen.conf files. Also, the content of the /var/log/Xorg.conf file would be interesting. If you get the opportunity, you could post the content of those on and press create and post here the url/web site address where they are located.

It could be very educational to see the final settings and logs.

Hi, I’ve pasted all the files together in this link: SUSE Paste

I think I actually tried the xrandr configuration just before running the nvidia-settings gui, and without a reboot, so perhaps the gui picked up the new modeline from xrandr?

It also seemed strange the the display changes I made in nvidia-settings were not saved
on reboot.

This was the case when running the gui both as a standard user and as root.

I did use the “Save to xorg.conf” option in the gui, which merges the existing
xorg.conf with the new settings.

Thanks. I guess you know that if there any conflicts in the xorg.conf file vs the content in the /etc/X11/xorg.conf.d files, the xorg.conf file content is supposed to take priority. I also note this entry in your /var/log/Xorg.0.log file that is different from before :

#    25.165] (II) NVIDIA(0): Assigned Display Device: CRT-1
#    25.165] (II) NVIDIA(0): Validated modes:
#    25.165] (II) NVIDIA(0):     "1440x900_60.00+0+0"
#    25.165] (II) NVIDIA(0): Virtual screen size determined to be 1440 x 900

I’m glad to read it is working now.