Propietary AMD driver

Over a year ago I posted about having problems with fglrx. The thread is here:
Last week I tried it again with the same results. I was wondering if it was a problem with my specific card (by Sapphire) but today I confirmed the card is alright: I installed Fedora 20 and tried the driver there, using AMD’s installer. Works like a charm. So there’s something not working well between fglrx and openSUSE. Any ideas? I’m willing to do tests if there’s a way to take a snapshot of the current state of the system since my previous fglrx installs ended in a system reinstall because the fglrx uninstall was leaving leftovers which included missing module prompts in console.

It was too late to edit the first post, but I just noticed looking at yast, that my kernel is kernel-desktop. Is there any chance that it’s the reason of the drivers malfunctioning? Should I try with kernel-standard?

Nope if you bring it in via a repository desktop is what you want. I guess it does not matter too much if you bring it in via direct install from download, but best to keep things simple.

note that you did not mention the specific video chip used 5xxx and before are legacy and the legacy no longer compiles for a modern kernel note also a new change may have moved legacy up to 6XXX but then I’m a NVIDIA user and don’t follow AMD GPU’s that close

The OS driver is pretty good these days unless you plan high level gaming

Legacy is for 4xxx and below, this one is a 6570.I’ve been using radeon (free driver) since then with no problems but I’d like to be able to test stuff like vDrift and the likes. But for the sake of stability I’ll use this until I know of a safe way to install with no leftovers. If you look at the thread I linked there are pictures with artifacts, it couldn’t process multitexturing well for some reason. At least now I know there’s a software issue somewhere.

I guess you could report the problem to AMD not sure it will do much good, but it is their hardware and software that is not working.

Note others don’t seem to be having the problem so maybe some odd hardware configuration on your system ?

I noticed that but was hoping to be able to find some cause and fix it. The fact that it works on Fedora leads me to think there’s something strange happening with either the kernel or some library. I’ll try to get some hard drive snapshot application so I can test the other kernel options.

A few days ago I got a Phenom II 945 CPU and when the computer booted it gave a microcode error. I reinstalled the ucode package and it was gone. Today I tried fglrx and it worked like a charm! I’m not sure if I should thank the new CPU or the new BIOS (being an AM2 motherboard, it required a BIOS upgrade to support the new CPU). So this is solved.

I thought I’ve installed latest driver since Yast shows 14.301.1001 is installed

…however Catalyst control center says it’s 14.10.1006

Does anyone know what might be the problem here? It’s a little bit strange :expressionless:

OS is 13.1 with 3.11.10-21 kernel and KDE 4.11.5

probably need a new thread unless you have the same problem as the OP (origianl Poster)