Proliant Woes

Greetings Folks,

I have a Compaq (HP) Proliant ML350 G3 server and I am trying to install OSuSE 11.1 on it.

The problem I am having is basically a lockup during setup at the time of device probing. Specifically the disk drive controller probing. It either locks or doesn’t detect.

I have tried apci off and noapic as well as fail safe and still the same results. I’m fairly certain it has to do with the raid controller “HP Smart Array 641”.

I’m convinced I simply need the driver, but not sure where I would get it. HP’s site does not have it.

The controller was picked up by earlier distros, such as SuSE Linux Pro 10. Perhaps my server is simply too antiquated, but it’s what I have to work with.

Is there a way I could use an earlier driver? Or is there some other workaround?

Any help would be appreciated.


Some specs would be helpful.

A bit of searching turned up this:

HP Smart Array CCISS driver

which suggests that the cciss driver is the one to use. I see that it’s in the kernel modules for 11.1. That doesn’t guarantee that you don’t have some other problem that might prevent detection. Maybe you have to do something to make sure this driver is loaded first, no idea what.

Upgrade your servers firmware, there were several fixes for the older Generation 3 series released - it’s possible that the new versions of the driver may conflict if there were issues with the adapter.

My Generation 5 series works just fine with 11.1 ( 06:00.0 RAID bus controller: Hewlett-Packard Company Smart Array Controller (rev 01) )

I did notice that the CCISS module is the one to use and it is loading. It hangs for a very long time just after loading CCISS.

The Smart Array 641 is firmware 1.4 I think there might be an upgrade for that and I will look into flashing it.

The server BIOS has been flashed to the latest: D14 (9/2004)

The CCISS module is kinda screwy. HP released one for use with up to SLES 10, but if I try that one while installing OSuSE 11.1 it wont take.

I have been here: HP Smart Array CCISS driver and basically it says for Kernel 2.6.15 and higher CCISS 3.6 should be used.

The drives are 2x36G in a mirror array. I did note yesterday that if they are partitioned before the install then the install hangs during controller probing. If I start the install without partitions then it doesn’t hand, it simplt doesnt detect any disks.

Thanks for the replies!


Just wanted to say thanks guys!

It turns out the old antiquated firmware was the issue. Updated from FW 1.4 to 2.84a and it works!

I had to download maintenance CD’s 8.5, 8.2, and 8.0 before I could find one that would boot.

Thanks again guys, I really really appreciate it!