Progress bar on my desktop from nowhere!

I have installed opensuse 11.2 64-bit, KDE 4. I noticed that a progress bar appears in the middle of my desktop from no where every now and then! ALSO, another strange thing happens: whenever I start openOffice Writer or a any window/application with a text box (such as Firefox or yast) a random number appears. Even now that I’m typing this here in the forums, random single digit numbers 6are entered (such as that ‘6’ in front of ‘are’ :slight_smile: ) I am completely at a l0oss (:)) here! Please any help would be appreciated! (number 5 just popped in my terminal window which I happen to0 have opened a few seconds ago… Heeelp! It spoils all the fun!!!

Never seen this. Your install seems somehow broken. Can you show the result of typing

zypper lr -d

on the command line? And - I forgot - welcome to the forum !

Thank you,

this is what zypper says:

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | Libdvdcss repository | Libdvdcss repository | Yes | Yes | 99 | rpm-md | |
2 | NVIDIA Repository | NVIDIA Repository | Yes | Yes | 99 | rpm-md | |
3 | Packman Repository | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.2 |
4 | X11:XGL | X11:XGL | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/XGL/openSUSE_11.2 |
5 | | Updates for openSUSE 11.2-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
6 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No | 99 | yast2 | cd:/// |
7 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
8 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
9 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |

I didn’t have any major problems with previous versions of opensuse (surely not like this one!) and I’m clueless…

Does #dmesg bring up anything unusual?

I’ve found that in the startup log the following lines are present:

<6> 20.692012] i2c IR (Pinnacle PCTV): unknown key: key=0x42 raw=0x42 down=1
<6> 20.794273] i2c IR (Pinnacle PCTV): unknown key: key=0x42 raw=0x42 down=0

these lines also appear in the system’s log, for example:

Dec 28 21:42:41 linux-qsja kernel: 303.347008] i2c IR (Pinnacle PCTV): unknown key: key=0x42 raw=0x42 down=0
Dec 28 21:42:45 linux-qsja kernel: 307.224011] i2c IR (Pinnacle PCTV): unknown key: key=0x42 raw=0x42 down=1
Dec 28 21:42:45 linux-qsja kernel: 307.326012] i2c IR (Pinnacle PCTV): unknown key: key=0x42 raw=0x42 down=0
Dec 28 21:42:46 linux-qsja kernel: 308.556012] i2c IR (Pinnacle PCTV): unknown key: key=0x42 raw=0x42 down=1

I don’t know if this has anything to do with the issue but I do not recall having lines like this in previous installations…

as a matter of fact dmesg also contains lines like:
596.419008] i2c IR (Pinnacle PCTV): unknown key: key=0x45 raw=0x45 down=0

also I get errors like:
6.248055] ACPI: I/O resource 0000:00:1f.3 [0x400-0x41f] conflicts with ACPI region SMRG [0x400-0x40f]
6.248066] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

6.762543] Error: Driver ‘rt2870’ is already registered, aborting…
6.762552] usbcore: error -17 registering interface driver rt2870

Sounds like Pinnacle PCTV is related to this issue then. Is there a TV tuner card installed? Or a USB Remote control or something?

Yes! There is a pci pinnacle pctv installed on my system which also comes with a remote control… (I didn’t have any problems with it in opensuse 11.1 though…).

Any ideas on how to rectify this?

that’s the tv card, by the way…

SAA7131/SAA7133/SAA7135 Video Broadcast Decoder
Configured as TV card number 0
Driver saa7134

What is that first libdvdcss repo you have active? Is it Videolan? Or something similar? This can mess up your system.

Did you follow oldcpu’s advice when installing?

Multi-media and Restricted Format Installation Guide - openSUSE Forums

@ vodoo:
i’ve followed the community’s 1-click collection, specifically
the Multimedia part:
“Codecs pack for KDE”

1-click-collection - openSUSE-Community

I’ve just noticed that not only i get random numbers when typing but other keys kick in as well, such as backspace or the arrow keys… :\

Sigh. An unknown number of 1-click installs. I would say that’s pretty much impossible to remote-diagnose or even fix. The fastest way is to restart from ZERO. Second time around strictly following the Howto.

that’s what i think too, i think i would re install everything and see how it goes…

Failure! A fresh install fixed nothing! The problem persists. I’ve just logged in for the first time and the same thing happens… no updates, no 1-click install no nothing and still the same situation…

May be that pinnacle card or the remote could be causing the trouble, i don’t know… any ideas?

It could be. I have no knowledge about it, I have not use those gadgets, but can it be disabled for a test to know if it is really causing the problem? Can it be disabled physically (detach) on a temporary basis for diagnostic purposes?

Well does anyone know how to remove pinnacles modules from kernel?

I tried to remove the module ir_kbd_i2c (for the remote I suppose???) and it seems that by doing so, the progress bars and the random numbers have stopped! But after performing a reboot i see ir_kbd_i2c is loaded again!!!

I tried to:
modprobe -r ir_kbd_i2c

all symptoms gone!

The problem with modprobe is that the above mentioned module reappears after a reboot, so I have deleted it! :stuck_out_tongue:

If anyone knows how to remove the module from kernel without having to physically remove it, please let me know…

p.s. the problem had nothing to do with 1-click installs or any repository but it was based on the fact that my remote (from my pinnacle pctv pci card) had issues with the ir_kbd_i2c module - at least that’s what i deduce!