Programs Not Showing Up in KDE Menus

I’m running OS 11.1 w/KDE 4.1 (x86_64-bit), and am having a problem with several programs installed through Yast not showing up in the App Launcher menus like they should.

One example is Ktouch, the typing tutor program. I installed it though Yast with no errors, and I can run it from the command window or a terminal, so its definitely on the system and working but doesn’t show in the menus.

Opening the menu editor shows it in Edutainment/Teaching where it is supposed to be, but it will not show up in the menus themselves. The Edutainment part of my menus remains empty.

Anyone know how to fix this?

just try moving it in the menu editor to another location and see if it shows up.

I’m having the same problem. Same setup, except 32-bit. I tried the move things around solution and all that did was drop out a lot of programs from the menu. Now I only have two. And moving things back won’t change it.

Anybody else have an idea?

Fiddling around I restored to system menu. That seemed to fix it.

Under Mene Editor -
Edit: Restore to System Menu

This gives the warning that you will lose all custom settings. Click Yes.

Tried the moving things around in the Menu Editor, and that fixed the problem for the 2 “missing” programs in my OP. They show up where they should now, but there are a couple of things that show in the Menu Editor that will not show up in the menus at all.

I’m wondering if anyone knows where the menu config files are stored? Maybe a little manual editing is needed. (After backing up the originals, of course. :))