Processing power dissapeared

Dear all,
I am having quite often times that my linux turns quite unresponsive. You have the feeling that 90% of the cpu is used and you have to wait a bit for your application to find a time slot to be processed by the cpu.

During one of those times I have opened ksysguard to see why this might happen (i.e which process for example is so much demanding)

Please find here my ksysguard output

ImageShack® - Online Photo and Video Hosting

things one has to mention
a. At the bottom 63% cpu utilization is mentioned, while the system becomes for few secs unresponsive.
b. The 63% cpu utilization can not be explained. As the sum of the most cpu intensive processes (is sorted by cpu usage) gives only 18% (also all the processes from all users are shown in top right part of the window).

Can someone explain me why a and b are happening and what I can do to find the cause of this problem?

I would like to thank you in advance for your help

B.R

Alex

On 01/18/2012 10:16 AM, alaios wrote:
> Can someone explain me why a and b are happening

i guess the mystery will be solved if you do not use Flash…it is a
horrible program which can grab hold of the CPU and force the system
into “unresponsive” for seconds at a time…

that “operapluginwrapper-na…” is Flash (in Firefox it will show as
“plugin-containe”…

> and what I can do to find the cause of this problem?

shut down all uses of Flash and i’d guess your unresponsiveness will be
history…


DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software
openSUSE®, the “German Engineered Automobiles” of operating systems!

Try running top in a console it may give a better picture of what is happening.

Good tip regarding the flash plugin, there is an improvement. Too bad that the flash plugin is eating so much of the cpu.

Also I run a bit the top and it shows slightly different view

  PID USER      PR  NI  VIRT  RES  SHR S   %CPU %MEM    TIME+  COMMAND                                                      
18454 apb       20   0  315m  67m 3284 R     **99**  0.9  58:42.78 R                                                            
 7151 root      20   0 39440 1340  668 S     **25**  0.0 129:39.76 ssh                                                          
 1865 root      20   0 1266m 288m 6072 R     **17**  3.6 763:51.01 Xorg                                                         
 7153 root      20   0 1611m  82m  356 S      **8**  1.0  48:04.84 sshfs                                                        
 4346 apb       20   0  773m  29m  24m S      **5**  0.4 341:58.26 pulseaudio                                                   
 5923 apb       20   0 1117m 327m  14m S      4  4.1 169:41.56 opera            

I put in bold the cpu utilization. The R was indeed running so this entry is fine. Usually the sshfs has quite large cpu utilization, which probably eats of the remaining resources.
I am using sshfs for mounting a partition in a remote linux system.

MY ssh entry looks like that (removed a bit of essential information)


sshfs#data@ourserver:/storageBox/volume1/Data /home/myuser/Documents/Data        fuse comment=sshfs,rw,exec,uid=1000,allow_other,reconnect,transform_symlinks,BatchMode=yes,nonempty,noauto 0 0

I checked again and it seems that I am having a systemd running with a constant of 25% going sometimes to 50% … .

What this process does and how I can relax it a bit?

B.R
Alex

On 01/23/2012 08:26 AM, alaios wrote:
> What this process does and how I can relax it a bit?

systemd is new linux launching system (see
<http://en.wikipedia.org/wiki/Systemd>) and many folks are having
problems with it…try this, do and orderly shutdown of your system and
then boot and at the first green screen press F5 and select “System V”,
like in this image:
http://dl.dropbox.com/u/10573557/12.1_Misc/12.1_F5_sysV.jpg

maybe your disappeared processing power will return…if so, you will
need to file a bug against systemd here http://tinyurl.com/nzhq7j

and, set up your system to always boot via systemv, do that this way:

open YaST > System (on left) > Boot Loader (on right) and carefully type
into the end of the “Optional Kernel Command Line Parameter” line this:


init=/sbin/sysvinit

and then click the “OK” button, like in these images:

http://dl.dropbox.com/u/10573557/systemV/add_systemV1.jpg
http://dl.dropbox.com/u/10573557/systemV/add_systemV2.jpg

please do not forget to log the bug, this new system has lots of
problems, and if you want your problem fixed . . .


DD http://tinyurl.com/DD-Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

Thanks a lot. I will post back after two I am using sysvinit!
Alex