ProBook and 11.2 noboot help

I have a ProBook 4510s which is supposed to support SLES 11, and I can install and run OpenSuSE 11.1 fine, but the installer won’t boot on the 11.2 DVD (checked the disk and it’s fine). So I tried an end-run: I did an online update from 11.1 with zypper dup. That seemed to go very well, but when rebooting, it freezes (it will start in failsafe mode). Here’s where 11.2 freezes during boot (after online update from 11.1):

** 8.827727] b43-pci-bridge 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17**

…and here’s where the 11.2 DVD installer freezes:

>>> openSUSE installation program v3.4.7 (c) 1996-2009 SUSE Linux Products GmbH <<<
Starting udev…

I’m wondering if any developers recognize either of these? There’s only one driver (for the modem) on the HP website for linux, so I assume HP has SuSE working with these laptops. I also flashed the latest BIOS. This seems to remain a problem in the 11.3 #6 installer that I also tried (I’m hoping to get WiFi support OOB).

OK, it turns out this is a Wifi problem - disabling the wifi in BIOS allows 11.2 to boot. A clumsy way to deal with the issue, maybe I’ll just go back to 11.1.

PS: the taskbar at the bottom is backwards (icons on all opposite sides from previous releases) - is this the way it’s supposed to be?

The HP version of SLED11 is a customized version with a tweaked kernel.
If it comes pre-installed there are some HP specific update channels
that are not present on the standard SLED11 install.

You should look at giving the liveCD of 11.3 M6 a whirl and see how
that goes, if it works OOB, then you will need to wait for that
release, else SLED11 SP1 should be out sometime this year which has a
later kernel.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel
up 1 day 14:42, 2 users, load average: 0.04, 0.10, 0.12
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Thanks for the reply!! I wasn’t sure how SLED differed from OpenSuSE. I didn’t get it with Linux installed - I just figured it was compatible… I had trouble with 11.3 also - similar issue(s) with the installer. Funny, I noticed some folks on here were able to install on probooks with no issues. Isn’t SLED pretty expensive?

I also thought it would be useful for coders to know something they did in 11.1 -> 11.2 resulted in an installation issue associated with wifi chipx.

I’d really like to get this fixed because 11.2 is much better I think than 11.1… and it seems like a pretty minor issue (at least to a Real Programmer…) - and there may even be a quite simple fix…

You could try adding the acpi option in the grub boot options to maybe
kick in the key functions;


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 3:55, 3 users, load average: 1.04, 0.50, 0.47
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15

Thanks, Malcom - I’ll give it a try. Using 11.1 right now and got the new broadcom linux WiFi driver running :slight_smile:

OK, tried that 4x and it worked exactly once - maybe I hit <esc> at exactly the right time to do something? (seems unlikely - I don’t think esc does anything other than show the boot STDIO - I was careful to type exactly what you wrote) 11.1 runs fine - I even loaded the new wifi driver that bcm puts out for linux. Hardware acceleration on my laptop’s intel graphics card automatically set up 3D. Yep, it’s nice - maybe 11.3 will unbork things? I tried the #6 release and the installer also froze…

I’m a bit surprised openSUSE-11.1 runs on this. Does your ProBook have Intel Graphics Media Accelerator 4500MHD? If so, I note this from the Thinkwiki: Intel GMA 4500MHD - ThinkWiki

KMS (Kernel Mode Setting) is a recent development, and requires that you have at least kernel 2.6.31 and Intel Xorg driver version 2.8. But newer is better. With the 2.6.32 kernel and Intel Xorg driver 2.9 you can expect full functionality including external displays and 3D acceleration.
openSUSE-11.2 comes with the 2.6.31 kernel, and the 2.9.0 Intel graphic driver. Hence theoretically, it should work. Did you try a safe settings installation from the DVD ? How about a text install from the DVD ?

openSUSE-11.3 milestone6 should work better, with its 2.6.34 kernel and 2.11.0 Intel graphic driver. If you tried milestone5 that was not a good milestone release to try, as it had known problems. Try 11.3 milestone6. Also try the safesettings and text mode if the nominal boot fails.

Did you try with safesettings?

Thanks for the comments. Yes, it has the intel chip for video, and OpenSuSE reports all is active, including 3D acceleration - I didn’t have to install any driver. I did have to download and install the broadcom wifi driver, but at least they have a native linux driver.

I was able to install 11.2 by doing an online upgrade from 11.1, but it would not then boot. So there is some sort of issue with the boot sequence (I posted where it halts). I went back to 11.1 because of this. I did test “safe mode” in 11.2 and it did boot OK, but I didn’t want to always run in safe mode. Also, there was something different about the task bar - the arrangement was different - video driver problem?

Judging from where 11.2 freezes, isn’t the PCI bus the problem, not the video? I think I tried 11.3 #6 installer and it also froze. This is probably a new bug with the PCI driver?

This does not mean one has to always boot in “safe mode”.

On my sandbox PC, which has a nVidia FX5200 graphics, the only way I could get openSUSE-11.3 M6 to install was in “safe settings”. Once the install was complete, I then investigated to see what I could do to get the PC to boot without safe settings. I ended up, in fact, removing all extra boot codes (I had to look at /boot/grub/menu.lst to see which boot codes were being applied, as not all are visible) and it booted fine. For some reason it would only install with safe settings but after openSUSE-11.3 M6 was installed, a normal boot worked.

After an install (with safe settings), the typical techique is to remove one boot code at a time from Fail Safe, to see if any of them are the reason for a successful boot. And sometimes it is also necessary to remove the boot codes from the normal boot in the /boot/grub/menu.lst, and then apply them one at a time to see which (if any) allow a successful boot.

There are different ways one can approach this.

Did you write a bug report on this?

I took some time searching for a bug report on the GMA 4500 and I could not find any that are open.

The closest I found was this one:

… and it does not read to be the same as what you are reporting.

In order for things to be fixed, it really helps if the problem is officially reported. Unfortunately, just posting on our forum does not accomplish that, as we are only a volunteer support forum. The place to report bugs in order to see things fixed is bugzilla. There is guidance here: Submitting Bug Reports - openSUSE and one can use their forum username and forum password when logging on to bugzilla to raise a bug report.

Thanks for the research. I will submit a bug report as soon as I can remember my password. I was a little worried about trying the install again in 11.2. Since I have everything working now - even my intel graphics - well, the screen brightness control doesn’t work - but I’m tre happy (though I’m a little stressed over 11.1 EOL). I should bug HP and see if I can get a Linux driver for their disk g-shock protection hardware (3D Drive Guard) on this lappie. I love 1600x900 resolution! :wink:

KO Bug report submitted. Pray for rain. (hah!) Weird that the installer would get persistently borked going from 11.1 to 11.2. Thank you very much for the tutorial about how to edit the boot lines. But is that really something I want to do since it’s essentially disabling features?


I have 11.1 on our Fujitsu-Siemens laptop and my testing indicates I am not going to be happy with 11.2, nor (as it stands today) 11.3. It has an 855GM Intel graphics and selected implementations of that graphic hardware does not like the current Linux / kernel combinations. This is not openSUSE specific, but rather Linux wide. Ever since the 2.6.29 ( ? ) kernel, one is forced to boot with acpi=off and even then, the graphics behaviour one gets on 11.2 and 11.3 is worse than that on 11.1.

I’m trying to decide if keeping 11.1 after the support runs out is worse than running a laptop with acpi=off.

OK, spoke too soon. Tried to burn a CD this morning (the first time I’ve tried this) and K3B says I don’t have a burner on my system. I have used the DVD/RW for some time for playing, but haven’t tried K3B before… I made sure I was part of the “cdrom” group (which I’ve never done before) but that didn’t seem to help.

BTW: I did try acpi=off as well as NOAPIC on 11.2 and they didn’t help it boot. I suppose I could Clonezilla my hard drive, then try installing 11.2 again with your suggestions about locating the command lines that work…

I’ve never had this problem myself.

Other’s have reported it, but I can’t reproduce it (it just works for me on all 6 PCs in our place), which means without the associated experience I don’t know how to solve it.

I recommend you ensure you have the latest package k3b, and restart, and if that does not work, then start a new thread on k3b.