Problems with USB Stick and Sony Walkman (NWZ-A15)

The walkman is plugged into my workstation (running 42.2 with KDE desktop) using it’s usb cable and I am trying to copy my music data to an SD card in the device. I have formatted the SD card using the walkman setup as instructed and when the usb lead is plugged in the Device Notifier pops up with 2 actions offered:- Download Photos with DigiKam and Open with File Manager. If I open with file manager (dolphin) I can see all the directories created by the Walkman and can access the target Music directory. So far so good.

My first problem has been the inordinate length of time it took to copy the music files. I know the USB port on my system is not the fastest but it took overnight to copy the files I wanted. I have tried a card usb adaptor but this didn’t solve my next problem:-

My second problem was that unfortunately my files required more space than available on the SD card. (128gb class 10) The result was that most directories were copied over but not always their entire contents of track files. The data comprises classical music works so I then had to investigate each work to ensure it was complete. In order to make space I had to delete some directories (works) so that those that remained were complete. The problem is that even if I delete the directories and files I am willing to omit, no space is freed up according to dolphin. I have tried re-booting walkman device, removing card and putting it into adaptor but nothing worked. Does anybody have any idea what is going on and why the space freed up by deleting files and directories is not being released?

Finally I thought I would try and use console and go directly to the Music directory on the SD card rather than working through dolphin. Unfortunately although the device seems to be auto mounted I cannot find a way to navigate to it from the command line. Here is the result for fdisk -l:-

fdisk -l
Disk /dev/sda: 5.5 TiB, 5993995960320 bytes, 11707023360 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: F2939456-093E-4312-9091-673EDA79A76E

Device          Start         End     Sectors  Size Type
/dev/sda1        2048      321535      319488  156M EFI System
/dev/sda2      321536     4530175     4208640    2G Microsoft basic data
/dev/sda3     4530176    88422399    83892224   40G Microsoft basic data
/dev/sda4    88422400  1162158079  1073735680  512G Microsoft basic data
/dev/sda5  1162158080 11684829469 10522671390  4.9T Microsoft basic data

Disk /dev/sdb: 119.8 GiB, 128579534848 bytes, 251131904 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot Start       End   Sectors   Size Id Type
/dev/sdb1       32768 251131903 251099136 119.8G  7 HPFS/NTFS/exFAT

Clearly the usb device is at /dev/sdb1 but how can I get there on the command line and why is there no mount directory in my system? Where is USB device mounted?
Grateful for some help please.

Use lsblk and/or the mount command, it may be fuse mounted… to see where it’s mounted, but I would gues /run/username/Media or similar.

If you delete it’s probably creating a hidden directory on the device called .Trash so set dolphin to see hidden files temporarily and delete that .Trash folder.

Hi Malcolm,
Duh! Why didn’t I think of that. Too tired I guess.
All now sorted except the speed but I shall try cp from console.
Many thanks once more.