Problems with USB mouse - slow and jumpy

Hi.

Im having problems with my mouse beeing slow and very jumpy when I move it. All the buttons (left/right click, scroolwheel click and back button) works, aswell does the scrollwheel. And those functions works without any delay or lag.

The mouse is a USB Logitech mouse, Im unaware of what model it is. Im using openSUSE 11.2 with KDE as desktop.

Anyone got any idéa on how to fix this?

Regards,
Jesper.

Try running top in a console window and see what it using up processor cycles.

Did that but my CPU is just at 5%, but I don’t think that the CPU is a problem since my trackpad works great, not jumpy and slow.

So it is just with my USB mouse… Also got problem with USB in general since when I unplug something I have to plug them in and restart to get them working again… Shouldn’t be like that right?

Anyone got any idéa?

Anyone got any idéa on how to get it working properly?

Regards,
Jesper.

I saw something like this on a PC with 11.1 when I installed brand new hardware, that the open source graphic driver could not handle well. It was on a nVidia GTX260. Since then, the driver has been updated.

Now its mostly quite likely this is NOT your problem, but to rule out that possibility, you need to tell us exactly what graphic hardware, and what graphic driver you are using.

I have the same problem on similar system/hardware! VERY annoying! >:(

Suddenly it will flicker around. Every now and then relocate to position 0,0 (I guess… the top left corner) of either of my monitors.

It does give me breaks of several minutes every now and then. Only to come back and act insane for 30 sec straight.

Tried changing the type of mouse in YaST with no effect (any USB setting seems to work equally bad).

Put specs in signature; just installed the Catalyst driver - but haven’t been able to activate desktop effects yet (tells me I need some xdamage blah blah will look into it). Mouse is a Logitec USB mouse too.

Was looking for the xorg.cong file but it wasn’t there. So this is what it says in “My computer”:

Vendor: VIA Technologies, Inc.
Model: CN400/PM800/PM880/PN800/PN880 [S3 UniChrome Pro]
Driver: Unknown

So maybe it could be the drivers that are creating this problem?

/Jesper.

Maybe, what driver are you using? Without the xorg.conf file being present, you probably need to look into some different places to figure out the driver in use.

One way that works sometimes, is to type:
/usr/sbin/hwfin --gfxcard
and look for a “Driver” entry, and see if it says “vesa”, or “chrome” or something else. For example, I am using the proprietary “nvidia” driver and I see:

  Driver: "nvidia"
  Driver Modules: "nvidia"

Another way is to examine the content of /var/log/Xorg.0.log and look to see if may tell you. For example, I am using the proprietary “nvidia” driver and I see:

(II) LoadModule: "nvidia"
(II) Loading /usr/lib64/xorg/modules//drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.0
	Module class: X.Org Video Driver

The hwinfo didn’t show anything about drivers, but the Xorg.0.log did show me something interesting:


(II) LoadModule: "chrome9"
(WW) Warning, couldn't open module chrome9
(II) UnloadModule: "chrome9"
(EE) Failed to load module "chrome9" (module does not exist, 0)
(II) LoadModule: "openchrome"
(WW) Warning, couldn't open module openchrome
(II) UnloadModule: "openchrome"
(EE) Failed to load module "openchrome" (module does not exist, 0)
(II) LoadModule: "unichrome"
(WW) Warning, couldn't open module unichrome
(II) UnloadModule: "unichrome"
(EE) Failed to load module "unichrome" (module does not exist, 0)
(II) LoadModule: "fbdev"
(II) Loading /usr/lib/xorg/modules//drivers/fbdev_drv.so
(II) Module fbdev: vendor="X.Org Foundation"
        compiled for 1.6.5, module version = 0.4.1
        ABI class: X.Org Video Driver, version 5.0
(II) LoadModule: "vesa"
(II) Loading /usr/lib/xorg/modules//drivers/vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
        compiled for 1.6.5, module version = 2.2.1
        Module class: X.Org Video Driver (II) LoadModule: "chrome9"
(WW) Warning, couldn't open module chrome9
(II) UnloadModule: "chrome9"
(EE) Failed to load module "chrome9" (module does not exist, 0)
(II) LoadModule: "openchrome"
(WW) Warning, couldn't open module openchrome
(II) UnloadModule: "openchrome"
(EE) Failed to load module "openchrome" (module does not exist, 0)
(II) LoadModule: "unichrome"
(WW) Warning, couldn't open module unichrome
(II) UnloadModule: "unichrome"
(EE) Failed to load module "unichrome" (module does not exist, 0)
(II) LoadModule: "fbdev"
(II) Loading /usr/lib/xorg/modules//drivers/fbdev_drv.so
(II) Module fbdev: vendor="X.Org Foundation"
        compiled for 1.6.5, module version = 0.4.1
        ABI class: X.Org Video Driver, version 5.0
(II) LoadModule: "vesa"
(II) Loading /usr/lib/xorg/modules//drivers/vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
        compiled for 1.6.5, module version = 2.2.1
        Module class: X.Org Video Driver
                                                          
                                                          

Any idéas? :slight_smile:

Regards,
Jesper.

To be fully honest, I avoid the sort of hardware you are trying to use with a long pole. I like hardware that “just works”, not hardware thats a pain. For graphics, nvidia “just works”. Chrome can be a pain and I would never buy it… But thats all ancient history and not helpful now for you have it, you are stuck with it.

I don’t know anything about it other than very cursory information.

You could type:
rpm -qa ‘chrome
to see if you have any chrome drivers.

If you go to webpin (http://packages.opensuse-community.org/index.jsp?searchTerm=chrome&distro=openSUSE_112 ) and do a search for “chrome” you will see some interesting hits for xorg chrome drivers, but its possible you have the applicable driver already installed.

But lets see what you have installed and go from there.

Alright, I checked if there where any chrome drivers and there wasn’t. So I went inside the install manager and found some unichrome drivers there (xorg-x11-driver-video-unichrome latest version).

So I installed them and tried to reboot, but then suddenly I couldn’t access the GUI via ordinary boot, but instead I got to a terminal looking login…

So I tried to boot with failsafe, and it worked perfectly, mouse was good and all usb things got working directly. Right now I have to do lsusb to get them to connect and mount… :S

Anyway, it seemed that the unichrome drivers made it work, but there is still a problem using them outside of failsafe.

Any idéas?:slight_smile:

Regards,
Jesper.

I do not know much about this. Did you check to see if the unichrome drivers are the ones you want?

My guess is you are using VESA drivers now when booting from failsafe, but I am not certain. You need to run the command again (it appears to have been typed wrong last time):
/usr/sbin/hwinfo --gfxcard

and again examine the contents of /var/log/Xorg.0.log for relevant info.

Maybe, but I’m not convinced that you are booting to the chrome driver.

You could also start removing the failsafe boot codes, one by one, until you determine which boot code is the one that allows your PC to boot. I suspect it is one that causes X to load a vesa driver, but I could be wrong.

I assume you still have no xorg.conf file.

Its possible we need to run sax2 to create a custom xorg.conf file.

You could also run dmesg in a terminal after the usb mouse/device malfunctions to see if there’s any message about it.

It could be a connector problem, I have a number of machines with older cases where pendrives and usb devices fail if connected to the front USB connectors, but work nicely if connected to the back (motherboard backpanel).

Right.

> dmesg
    0.000000] Linux version 2.6.31.5-0.1-desktop (geeko@buildhost) (gcc version 4.4.1 [gcc-4_4-branch revision 150839] (SUSE Linux) ) #1 SMP PREEMPT 2009-10-26 15:49:03 +0100                                                                 
    0.000000] Command line: root=/dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV90629792-part1    repair=1 resume=/dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV91153412-part1 splash=silent quiet vga=0x317                              
    0.000000] KERNEL supported cpus:                                           
    0.000000]   Intel GenuineIntel                                             
    0.000000]   AMD AuthenticAMD                                               
    0.000000]   Centaur CentaurHauls          

*blah blah blah*

    0.000000] AMI BIOS detected: BIOS may corrupt low RAM, working around it.  

*blah blah blah*

    0.000000] Scanning NUMA topology in Northbridge 24                         
    0.000000] No NUMA configuration found 


*blah blah blah*

    0.746473] mice: PS/2 mouse device common for all mice                      

*blah blah blah*

    1.050193] usb 4-2: **New USB device found**, idVendor=046d, idProduct=c040     
    1.050195] usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    1.050197] usb 4-2: Product: **USB-PS/2 Optical Mouse                         **
    1.050198] usb 4-2: Manufacturer: Logitech                                  
    1.050243] usb 4-2: configuration #1 chosen from 1 choice                   
    1.058321] input: **Logitech USB-PS/2 Optical Mouse** as /devices/pci0000:00/0000:00:12.1/usb4/4-2/4-2:1.0/input/input1                                         
    1.058368] generic-usb 0003:046D:C040.0001: input,hidraw0: USB HID v1.10 Mouse **Logitech USB-PS/2 Optical Mouse**] on usb-0000:00:12.1-2/input0               
    1.304047] ata1: softreset failed (device not ready)                        
    1.304054] ata1: applying SB600 PMP SRST workaround and retrying  


*blah blah blah*

 1451.580804] SFW2-OUT-ERROR IN= OUT=eth0 SRC=192.168.25.50 DST=76.91.151.130 LEN=40 TOS=0x00 PREC=0x00 TTL=64 ID=0 DF PROTO=TCP SPT=57517 DPT=13938 WINDOW=0 RES=0x00 RST URGP=0
 1759.712058] SFW2-OUT-ERROR IN= OUT=eth0 SRC=192.168.25.50 DST=124.205.213.141 LEN=52 TOS=0x00 PREC=0x00 TTL=64 ID=21723 DF PROTO=TCP SPT=39293 DPT=51413 WINDOW=158 RES=0x00 ACK FIN URGP=0 OPT (0101080A00164600000E402D)
 1857.488058] SFW2-OUT-ERROR IN= OUT=eth0 SRC=192.168.25.50 DST=124.205.213.141 LEN=52 TOS=0x00 PREC=0x00 TTL=64 ID=21724 DF PROTO=TCP SPT=39293 DPT=51413 WINDOW=158 RES=0x00 ACK FIN URGP=0 OPT (0101080A0017C3F0000E402D)


Don’t know how to interpret.

I tried to boot in failsafe without the drivers installed too, and it worked flawless then too. So I guess you were right about the drivers.

Also run dmesg and this is what I got before doing lsusb: Plain Text code - 602 lines - codepad

And after doing the lsusb I got this:
Plain Text code - 647 lines - codepad

About the sax2, I tried to run it, but it made me get to login screen in terminal (like when booting with chrome drivers installed).

Does the pastes make any sence? :slight_smile:

Regards,
Jesper.

First, do you have an /etc/X11/xorg.conf file? If so, try moving it somewhere /home/yourusername, and then reboot with no such file. Does that work? If not, move the file back.

I do not understand what you mean here.

IMHO one should run sax2 from run level 3.

That means when the grub boot menu 1st appears, press ‘3’ (no quotes) and a ‘3’ should appear in the options line of the grub menu selection (ie a regular boot). There should be a space between the ‘3’ and the previous entry. Then continue with the boot. That will take to you a login screen like a terminal. That is what you want at this stage.

Log in as a regular user. Once logged in type “su” (no quotes - enter root password) to switch users to user root (administrator). And then and only then, try the sax2 command.

I do not know what the sax2 command is for chrome. Is it “via” ?

Try:
sax2 -r -m 0=via

Note I am guessing. That is zero equals via.

Then if that appears to succeed in configuring, type: shutdown -r now #to reboot.

Ah, of course. I did that and it created a xorg.conf file, this is the content:

# /.../
# SaX generated X11 config file
# Created on: 2009-11-26T18:32:40+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "dri"
  Load         "dbe"
  Load         "extmod"
  Load         "glx"
EndSection

Section "InputDevice"
  # Driver "kbd" will be disabled unless 'Option "AutoAddDevices" "off"' 
  # is set in "ServerFlags" section. 
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "se"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection


Section "InputDevice"
  # Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"' 
  # is set in "ServerFlags" section. 
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "SynPS/2 Synaptics TouchPad"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  305 230
  HorizSync    31-60
  Identifier   "Monitor[0]"
  ModelName    "1024X768@60HZ"
  Option       "DPMS"
  Option       "PreferredMode" "1024x768"
  VendorName   "--> LCD"
  VertRefresh  30-60
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection


Section "Screen"
  SubSection "Display"
    Depth      15
    Modes      "default" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "default" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "default" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "default" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "Framebuffer Graphics"
  Driver       "fbdev"
  Identifier   "Device[0]"
  VendorName   "VESA"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection


Also tried to remove it and restart, no difference. And the sax2 -r -m 0=via only returned errors.

/Jesper.

That is the very basic, and very low performance frame buffer (fbdev) driver:

Section "Device"
  BoardName    "Framebuffer Graphics"
  Driver       "fbdev"
  Identifier   "Device[0]"
  VendorName   "VESA"
EndSection

can you please post the output of:
rpm -qa ‘chrome

Try loading the VESA driver (I think it is separate from the fbdev). Do that by typing in run level 3 with root permissions:
sax2 -r -m 0=vesa
and then restart with
shutdown -r -m 0=vesa
please also provide output of
sax2 -p

As I noted earlier, I am not familiar with chrome hardware. I do not know the syntactical name of the graphical driver they use, nor do I know if that driver can be configured with sax2.

One can get a bit of a handle as to what graphic drivers are available, on a 64-bit system, by going to: /usr/lib64/xorg/modules/drivers and looking.

or on a 32-bit system to: **/usr/lib/xorg/modules/drivers ** and looking.

… but I do not know which, if any, are specific to chrome.