Problems with the new NVIDIA drivers 1 Click Install

Using den 1. Click Installation for the NVDIA (non legacy) drivers for Opensuse 11.00 does noch work properly.

I think that it installs the wrong drivers (the legacy drivers being installed after the 1 Click installation, with the wrong dependecies).

But I’m not quite shure which packages really are the proper ones. Anyways: the one klick installation leads to problems

My Card: NVidia GeForce 7300 LE:(

I recommend removing the old drivers in Yast.

Go here & get the beta driver (it works best for me with 11.0O: NVIDIA Driver Downloads - Advanced Search
fetch the

Howto @ Nvidia Installer HOWTO for SUSE LINUX users

remove the old drivers in Yast
Open a terminal; login as root; do “init 3” which will put you in runlevel 3
login as root
cd /tothefolderwith
sh -q

When that’s done:
Configure X.Org with

sax2 -r -m 0=nvidia (0 is a digit, not a letter!)

(NOTE: There is no need to try to enable 3D support. It’s already
enabled, when the nvidia driver is running.)

Do the configure for your setup & TEST; always TEST & when it’s like you want; save.

type “reboot”

and you should be good to go:)

Hey Snakedriver,
Don’t mean to hijack, but seems appropiate, considering my small problem.

Here goes…
[openSUSE 10.3 64bit on Dell M1330 Laptop with GeoForce 8400M GS] using the Install NVIDIA via 1-click,
and following all instructions, my system upon next boot could not load X and stayed in text mode till I deleted the partitions and reinstalled 10.3 again.

Question: What do I have to do for a proper NVIDIA install. Just follow what you put above with 10.3 understanding?

Thanks for your help.
I don’t wish to go through this delete partition all over again.


The 7300 shouldn’t be using the legacy drivers.

Should be using the normal drivers.

Have a read here, Nvidia no
need to re-install your system, if it borks and you want a gui login,
then as root user;

init 3
sax2 -r -m 0=nv
init 5 && exit

This will use the default nvidia driver, if that doesn’t work use vesa
instead. Also note the “0” is a zero.

Cheers Malcolm °¿° (Linux Counter #276890)
SLED 10 SP2 i586 Kernel
up 4:40, 2 users, load average: 0.07, 0.16, 0.22
GPU GeForce Go 6600 TE/6200 TE Version: 173.14.09

Thanks Malcolm Lewis,
I tried again and received the error FATAL: Module nvidia not found

I am not sure what is not correct here.
The x11-video-nvidiaG01 is downloaded and installed.
I wonder if there is another dependency missing?

XPS M1330 with GeoForce 8400M GS

Thanks for your help,

On the nvidia page, follow the hard way. That is the one installed from
the repository. I’ve never used them, because they have never seemed to
work well for me on either this machine or my AMD 4400+ which has the
EN8600GTS when i tried out openSUSE 11 on it.

Cheers Malcolm °¿° (Linux Counter #276890)
SLED 10 SP2 i586 Kernel
up 11:05, 1 user, load average: 0.17, 0.07, 0.06
GPU GeForce Go 6600 TE/6200 TE Version: 173.14.12

Thanks Malcolm Lewis,
Prerequisites**: used Yast to download these…
compiler gcc
program make &
package kernel-source

I downloaded the to desktop.

I went into terminal, became root, and typed

 # init 3
 # cd Desktop
 # sh -q

followed instructions during install

then to configure

sax2 -r -m 0=nvidia

on return to X configured Sax with proper resolution and screen size.

All is well,

Good to here all is well. Just a couple of notes though, after you have
finished the config with sax2, use the following;

init 5 && exit

This will restart X and exit the root shell, just in case you forget to
logout :slight_smile:

Now, for updating the driver it is even easier (assuming the network
is running and connected to the internet), alt+ctrl+F2 to get to a
console login and login as root user;

init 3
nvidia-installer --update
init 5 && exit

Cheers Malcolm °¿° (Linux Counter #276890)
SLED 10 SP2 i586 Kernel
up 1:39, 2 users, load average: 0.01, 0.09, 0.44
GPU GeForce Go 6600 TE/6200 TE Version: 173.14.12