Problems with synaptics driver (synclient) and openSuSe 11.3

Hello, I am rather new with OpenSuse 11.3, I completely moved 4 month ago from Windows 7 to linux rotfl!

I have (HP DV7-4190us) this hardware Show Box and I complete the HLC HCL:HP laptops - openSUSE

Everything works just fine, but the clickpad/touchpad, that works but when I type on the keyboard I have to be very carefull not to touch the clickpad/touchpad because I have tapping activated and the pointer clicks somewhere else making it really frustrating. Sadly on Win7 or XP I have no problems and also with tapping function ON.

I followed the instructions Synaptics Touchpad - openSUSE and this are the results:

1) Disabling the Touchpad While Typing
The syndaemon that should help to disable the clickpad works, but if you suspend or hibernate when you come back sometimes the syndaemon is no longer resident in memory.
Anyway sometimes it stops working (I can detect it because the clickpad has a light that turns on when syndaemon disables the clickpad when you type)

So, I run in terminal:

syndaemon -d -t

-d Run as daemon
-t Only disable tapping and scrolling, not mouse movements (this works randomly, sometimes if you move the pointer and type… the movement stops)

And when syndaemon stops working it exits with this error:

X Error of failed request:  XI_BadDevice (invalid Device parameter)
Major opcode of failed request:  147 (XInputExtension)
Minor opcode of failed request:  37 (X_ChangeDeviceProperty)
Device id in failed request: 0x17
Serial number of failed request:  75608
Current serial number in output stream:  75609

  1. The tutorial recommends to configure the touchpad using HAL:

"To do so, use the appropriate file in /etc/hal/fdi/policy/11-x11-synaptics.fdi (there is a sample file located at /usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi)."

But there is no example in /usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi anyway I created one and put it in /etc/hal/fdi/policy/11-x11-synaptics.fdi as the tutorial explains… then the same tutorial says: "The configuration is done in the .fdi file located at /etc/modprobe.d/11-x11-synaptics.fdi. These files use a XML syntax but most option variables and values remain the same as before." so where should I put the 11-x11-synaptics.fdi? maybe I did not understood right the tutorial.

So… I put the 11-x11.synaptics.fdi in both locations:


<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
<match key="info.capabilities" contains="input.touchpad">
<merge key="input.x11_driver" type="string">synaptics</merge>
<merge key="input.x11_options.SHMConfig" type="string">true</merge>
<merge key="input.x11_options.TapButton1" type="string">1</merge>
<merge key="input.x11_options.LBCornerButton" type="string">1</merge>
<merge key="input.x11_options.RBCornerButton" type="string">3</merge>

But anyway it seems that these files are ignored completey, ie. SHMConfig is still OFF (I test it with synclient -m 50 to watch the pointer coordinates but the result is: “Can’t access shared memory area. SHMConfig disabled?”

Hope anyone can give me some help, and maybe we can update the tutorial if this is not just a problem with my laptop or my installation.

Thank you very much,


Here some config files and logs may help to understand…

This is my xorg.conf (that I read its no longer useful as everything goes through HAL)

Section "ServerLayout"
	Identifier     " Configured"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
	ModulePath   "/usr/lib64/xorg/modules/updates"
	ModulePath   "/usr/lib64/xorg/modules"
	FontPath     "/usr/share/fonts/misc:unscaled"
	FontPath     "/usr/share/fonts/TTF/"
	FontPath     "/usr/share/fonts/OTF/"
	FontPath     "/usr/share/fonts/Type1/"
	FontPath     "/usr/share/fonts/100dpi:unscaled"
	FontPath     "/usr/share/fonts/75dpi:unscaled"
	FontPath     "/usr/share/fonts/URW/"
	FontPath     "/usr/share/fonts/cyrillic:unscaled"
	FontPath     "/usr/share/fonts/misc/sgi:unscaled"
	FontPath     "/usr/share/fonts/truetype/"

Section "Module"
	Load  "record"
	Load  "dri2"
	Load  "dbe"
	Load  "dri"
	Load  "glx"
	Load  "vnc"
	Load  "extmod"

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"

Section "InputDevice"
	Identifier "Mouse0"
	Driver "mouse" #NOTE: should I use "synaptics" here? I tried but dont see the difference
	Option "Protocol" "auto"
	Option "Device" "/dev/input/mice"
	Option "ZAxisMapping" "4 5 6 7"
	#Option "SHMConfig" "true" #NOTE: if I enable here SHMConfig starts working, but I tried to follow the tutorial.

Section "Monitor"
	#DisplaySize	  390   220	# mm
	Identifier   "Monitor0"
	VendorName   "CMO"
	ModelName    "1711"

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            	# <bool>]
        #Option     "SWcursor"           	# <bool>]
        #Option     "Dac6Bit"            	# <bool>]
        #Option     "Dac8Bit"            	# <bool>]
        #Option     "BusType"            	# <str>]
        #Option     "CPPIOMode"          	# <bool>]
        #Option     "CPusecTimeout"      	# <i>
        #Option     "AGPMode"            	# <i>
        #Option     "AGPFastWrite"       	# <bool>]
        #Option     "AGPSize"            	# <i>
        #Option     "GARTSize"           	# <i>
        #Option     "RingSize"           	# <i>
        #Option     "BufferSize"         	# <i>
        #Option     "EnableDepthMoves"   	# <bool>]
        #Option     "EnablePageFlip"     	# <bool>]
        #Option     "NoBackBuffer"       	# <bool>]
        #Option     "DMAForXv"           	# <bool>]
        #Option     "FBTexPercent"       	# <i>
        #Option     "DepthBits"          	# <i>
        #Option     "PCIAPERSize"        	# <i>
        #Option     "AccelDFS"           	# <bool>]
        #Option     "IgnoreEDID"         	# <bool>]
        #Option     "CustomEDID"         	# <str>]
        #Option     "DisplayPriority"    	# <str>]
        #Option     "PanelSize"          	# <str>]
        #Option     "ForceMinDotClock"   	# <freq>
        #Option     "ColorTiling"        	# <bool>]
        #Option     "VideoKey"           	# <i>
        #Option     "RageTheatreCrystal" 	# <i>
        #Option     "RageTheatreTunerPort" 	# <i>
        #Option     "RageTheatreCompositePort" 	# <i>
        #Option     "RageTheatreSVideoPort" 	# <i>
        #Option     "TunerType"          	# <i>
        #Option     "RageTheatreMicrocPath" 	# <str>
        #Option     "RageTheatreMicrocType" 	# <str>
        #Option     "ScalerWidth"        	# <i>
        #Option     "RenderAccel"        	# <bool>]
        #Option     "SubPixelOrder"      	# <str>]
        #Option     "ShowCache"          	# <bool>]
        #Option     "ClockGating"        	# <bool>]
        #Option     "VGAAccess"          	# <bool>]
        #Option     "ReverseDDC"         	# <bool>]
        #Option     "LVDSProbePLL"       	# <bool>]
        #Option     "AccelMethod"        	# <str>
        #Option     "DRI"                	# <bool>]
        #Option     "ConnectorTable"     	# <str>
        #Option     "DefaultConnectorTable" 	# <bool>]
        #Option     "DefaultTMDSPLL"     	# <bool>]
        #Option     "TVDACLoadDetect"    	# <bool>]
        #Option     "ForceTVOut"         	# <bool>]
        #Option     "TVStandard"         	# <str>
        #Option     "IgnoreLidStatus"    	# <bool>]
        #Option     "DefaultTVDACAdj"    	# <bool>]
        #Option     "Int10"              	# <bool>]
        #Option     "EXAVSync"           	# <bool>]
        #Option     "ATOMTVOut"          	# <bool>]
        #Option     "R4xxATOM"           	# <bool>]
        #Option     "ForceLowPowerMode"  	# <bool>]
        #Option     "DynamicPM"          	# <bool>]
        #Option     "NewPLL"             	# <bool>]
        #Option     "ZaphodHeads"        	# <str>
	Identifier  "Card0"
	Driver      "radeon"
	VendorName  "ATI Technologies Inc"
	BoardName   "Redwood [Radeon HD 5600 Series]"
	BusID       "PCI:1:0:0"

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	SubSection "Display"
		Viewport   0 0
		Depth     4
	SubSection "Display"
		Viewport   0 0
		Depth     8
	SubSection "Display"
		Viewport   0 0
		Depth     15
	SubSection "Display"
		Viewport   0 0
		Depth     16
	SubSection "Display"
		Viewport   0 0
		Depth     24

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24

Part of system log, seems that when syndaemon disables the touchpad the system logs it as “lost sync”:
#1338895 - Pastie](

And this is the Xorg.0.log
#1338877 - Pastie](

First of all, you do a clean-up.
(1) You don’t need xorg.conf anymore. So, delete it or rename it.
(2) 11.3 does not use HAL policy files from /etc/hal/fdi/policy/ or /etc/modprobe.d/ So, delete them.

X, when it comes up, it will use configuration files from /etc/X11/xorg.conf directory. You should look for a file named 20-synaptics.conf for the touchpad driver. If you remove this file, touchpad will be completely disabled and it will act like a normal mouse (see the other configuration files there). However, you can customize the configuration in that file.

Thanks Syampillai lol! you were right! I deleted both files and the xorg.conf and the /etc/X11/xorg.conf.d/20-synaptics.conf started working almost right!

But (sorry for the “but”) I have one more doubt, its seems that now the settings works but some are overriden by the “default” gnome-mouse-properties or may be gpointing-device-settings… (and I dont know where to delete that settings)

i.e. this is my /etc/X11/xorg.conf.d/20-synaptics.conf file now:

Section "InputClass"
	Identifier "touchpad catchall"
	Driver "synaptics"
	MatchIsTouchpad "on"
	MatchDevicePath "/dev/input/event*"
	Option "SHMConfig" "true"
	Option "Buttons" "2"
	Option "TouchpadOff" "0"
	Option "TapButton1" "0"
	Option "TapButton2" "0"
	Option "TapButton3" "0"
	Option "ClickFinger1" "1"
	Option "ClickFinger2" "0" 
	Option "ClickFinger3" "0"  
	Option "LBCornerButton" "1"
	Option "RBCornerButton" "3"
	Option "Emulate3Buttons" "no"
	#Option "ZAxisMapping" "4 5"
	Option "PalmDetect" "0"
	#Option "PalmMinZ" "100"
	#Option "PalmMinWidth" "150"
	Option "LeftEdge" "2000"
	Option "RightEdge" "4900" 
	Option "TopEdge" "2000" 
	Option "BottomEdge" "3800" 
	#Option "Fingerpress" "70"
	#Option "FingerLow" "integer"
	#Option "FingerHigh" "integer"

OK, so these values are being overriden:
Option “LeftEdge” “2000”
Option “RightEdge” “4900”
Option “TouchpadOff” “2”
Option “ClickFinger1” “1”
Option “ClickFinger2” “0”
(and some more values…)

Here is the output of synclient -l so you can see the differences…

Parameter settings:
    LeftEdge                = 1800
    RightEdge               = 5000
    TopEdge                 = 2000
    BottomEdge              = 3900
    FingerLow               = 24
    FingerHigh              = 29
    FingerPress             = 255
    MaxTapTime              = 180
    MaxTapMove              = 221
    MaxDoubleTapTime        = 180
    SingleTapTimeout        = 180
    ClickTime               = 100
    FastTaps                = 0
    EmulateMidButtonTime    = 75
    EmulateTwoFingerMinZ    = 280
    EmulateTwoFingerMinW    = 7
    VertScrollDelta         = 100
    HorizScrollDelta        = 100
    VertEdgeScroll          = 0
    HorizEdgeScroll         = 0
    CornerCoasting          = 0
    VertTwoFingerScroll     = 0
    HorizTwoFingerScroll    = 0
    MinSpeed                = 0.4
    MaxSpeed                = 0.7
    AccelFactor             = 0.00995223
    TrackstickSpeed         = 40
    EdgeMotionMinZ          = 29
    EdgeMotionMaxZ          = 159
    EdgeMotionMinSpeed      = 1
    EdgeMotionMaxSpeed      = 401
    EdgeMotionUseAlways     = 0
    UpDownScrolling         = 1
    LeftRightScrolling      = 1
    UpDownScrollRepeat      = 1
    LeftRightScrollRepeat   = 1
    ScrollButtonRepeat      = 100
    TouchpadOff             = 1
    GuestMouseOff           = 0
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 0
    RBCornerButton          = 3
    LTCornerButton          = 0
    LBCornerButton          = 1
    TapButton1              = 1
    TapButton2              = 3
    TapButton3              = 2
    ClickFinger1            = 1
    ClickFinger2            = 0
    ClickFinger3            = 0
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    CircularPad             = 0
    PalmDetect              = 0
    PalmMinWidth            = 10
    PalmMinZ                = 199
    CoastingSpeed           = 0
    PressureMotionMinZ      = 29
    PressureMotionMaxZ      = 159
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    GrabEventDevice         = 1
    TapAndDragGesture       = 1
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0
    TouchButtonArea         = 20
    TouchButtonSticky       = 64
    LEDStatus               = 0
    LEDDoubleTap            = 1

Thank you very much,


Not sure about the gnome settings. Some gnome expert should respond now :slight_smile:

Thanks Syampillai, I will have to wait for some extra help, anyway I will try something else this weekend.

Do you know about the syndaemon program? that one that disables the touchpad when you type (so you wont click without wanting) well, I also post in this thread that sometimes this daemon just exists with some errors. Do you noticed the same problem?


Nope, I am not using syndaemon. Also, my synaptics.conf is the default one.

Section "InputClass"
        Identifier "touchpad catchall"
        Driver  "synaptics"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option  "HorizScrollDelta"      "0"