Problems with Suse 11 updater and YasT

I upgraded from SuSE 10.3 to SuSE 11 on June 21 using the DVD download iso. The new operating system installed as an upgrade with no installation problems and is running. Some software systems such as VNC and the nvidia drivers need to be adjusted. The software updater replies “Refresh fails”. I have no updates. When I try to initiate software management with YaST I receive the error report

“Download (curl) error for ‘’:
Error code:
Error message: This doesn’t seem like a nice ftp-server response”

I had no problems with these services with 10.3. I can find no report of similar difficulties with an on line search. What is to be done to get things working?

3 possibilites:
1: 11.0’s yast use a different compression method, so it’s possible that the update had problem with it.
2: the server was just offline
3: the server’s adress is unexact.

  • clivesteventon,

I generally found HTTP more reliable and less picky about server configurations when being used for the repositories. Can you try HTTP instead of FTP?


Had the same problem, more or less. (maybe less, but might be the same issue)

Every time I tried to update it would time out.
Eventually went to and found out that the problem was that I was unable to connect to the mirror.

I found another mirror at added that and now it’s updating just fine.

Thanks for the three tips. I have been using Linux for many years but only as an xwindows client for matlab. Just started to investigate as replacement for my home desktop. Suse 10.3 worked well for me and I decided to upgrade to Suse 11. This has been a source of new problems as the upgrade destroyed some of the features I had set up in 10.3 In hindsight I would have stayed with 10.3 for another year or so until 11 was smoothed out. I have investigated Yast more completely and found a long list of repositories - nearly all http referrals. There was only one ftp - the failing one which referred to repo /etc/zypp/repos.d/20080621-163636.repo. There were just a few lines in that so I have no idea to what it referred - nothing apparently useful. I removed the ftp reference to that file from the list of repositories and all the other repositories are now updating properly and the software management package loads properly. I do not know if anything has been lost but obviously most of the repositories are now being managed and maintained:):). Thanks for the suggestions. I expect to be back for further help!