Problems with surfstick

I gut a surf stick from 1&1. I don’t know the true manufacturer. I insterted it into one usb slot of my Medion laptop. The stick was recognized automatically and I saw its entry in the network notifier of the KDE panel. But it was marked unconnected. I chose “Manage Connections”, where I was able to add a new connection under the “Mobile Broadband” tab. I tried a bit but never found out the correct settings to get the connection work. The whole time I found ttyUSB0-4 in the /dev directory.

I thought, ok reboot helps sometimes. But after that the stick was never recognized again and there were no more USB entries in /dev. Although KInfocenter shows “USB Modem” for EHCI Host controller.

I tried the same thing on my desktop PC. It happened exactly the same. The stick is no longer recognized.

I’m stuck. What can I do now?

EDIT:

the command usb-devicec gives me the following section containing informations about the stick:

T: Bus=01 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#= 8 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=1c9e ProdID=9605 Rev=00.00
S: Manufacturer=USB Modem
S: Product=USB Modem
S: SerialNumber=1234567890ABCDEF
C: #Ifs= 5 Cfg#= 1 Atr=e0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

[HR][/HR]

I tried the same thing on my desktop PC. It happened exactly the same. The stick is no longer recognized.

I’m stuck. What can I do now?

Plug it in and observe the output from the following

dmesg|tail
lsusb

If you have the ‘usbutils’ package installed, you can run the more useful command

usb-devices

which will show if a driver is associated with the hardware.

BTW, sometimes mobile broadband devices need to be initially configured in a Windows environment, although I haven’t personally experienced this requirement.

Sorry, I didn’t see your edit

T: Bus=01 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#= 8 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=1c9e ProdID=9605 Rev=00.00
S: Manufacturer=USB Modem
S: Product=USB Modem
S: SerialNumber=1234567890ABCDEF
C: #Ifs= 5 Cfg#= 1 Atr=e0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

That implies the device is in storage device mode. The chipset details are relevant here: Vendor=1c9e ProdID=9605. It may be that you need to research how to activate the modem device first. The usb-modeswitch utility is often used to automatically handle the switching of these types of hardware, so you may need to check further along those lines.

This may be relevant to you

https://bbs.archlinux.org/viewtopic.php?id=145608

Good luck.

The guy from archlinux describes a different problem. Although his stick is shown as storage device, just as mine. But he tries to set Vendor and Product to the values that I already have. Obviously this leads his stick to be recognized as usb-modem mobile broadband connection. But that’s not the case with my stick. It is shown as storage device.
Furthermore I don’t understand what MessageContent number to chose and what it’s meant for.

lsusb:

Bus 001 Device 010: ID 1c9e:9605 OMEGA TECHNOLOGY
Bus 001 Device 002: ID 0ace:1215 ZyDAS ZD1211B 802.11g
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

dmesg:

3544.341081] usb 1-2: new high-speed USB device number 9 using ehci-pci
3544.457721] usb 1-2: New USB device found, idVendor=1c9e, idProduct=f000
3544.457731] usb 1-2: New USB device strings: Mfr=3, Product=2, SerialNumber=4
3544.457739] usb 1-2: Product: USB Modem
3544.457746] usb 1-2: Manufacturer: USB Modem
3544.457753] usb 1-2: SerialNumber: 1234567890ABCDEF
3544.460179] usb-storage 1-2:1.0: USB Mass Storage device detected
3544.460611] scsi9 : usb-storage 1-2:1.0
3547.530506] usb 1-2: USB disconnect, device number 9
3547.841082] usb 1-2: new high-speed USB device number 10 using ehci-pci
3547.961727] usb 1-2: New USB device found, idVendor=1c9e, idProduct=9605
3547.961737] usb 1-2: New USB device strings: Mfr=3, Product=2, SerialNumber=4
3547.961746] usb 1-2: Product: USB Modem
3547.961753] usb 1-2: Manufacturer: USB Modem
3547.961759] usb 1-2: SerialNumber: 1234567890ABCDEF
3548.675776] usb-storage 1-2:1.4: USB Mass Storage device detected
3548.676034] scsi10 : usb-storage 1-2:1.4
3549.680615] scsi 10:0:0:0: Direct-Access USBModem Disk 2.31 PQ: 0 ANSI: 2
3549.681624] sd 10:0:0:0: Attached scsi generic sg2 type 0
3549.686224] sd 10:0:0:0: [sdb] Attached SCSI removable disk
4147.321576] SFW2-INext-DROP-DEFLT IN=enp0s18 OUT= MAC= SRC=fe80:0000:0000:0000:0240:d0ff:feb7:f29a DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44

[HR][/HR]

This helped: http://askubuntu.com/questions/141452/micromax-3g-mobile-internet-modem-not-being-detected

Now I have back the Mobile Broadband entry in the network section of the panel. But I’m still unable to connect. Going to try a bit further and report about my progress later.

It doesn’t work. Maybe I will go into detail tomorrow after sleep.

For the meantime: Does anybody know a surfstick that definitely works with Suse 13.1?

I’ve had success with various Huawei devices, but it does depend on the chipset involved.

Here’s another how-to describing the required usb_modeswitch config file

http://importgeek.wordpress.com/2012/10/04/how-to-connect-micromax-3g-mobile-internet-modem-in-ubuntu-12-04/

The config files are located in the /usr/share/usb_modeswitch/ directory, so you could add it there if required.

As for connecting, the parameters may depend on the service provider involved. Googling may help with that.

Please Jaizkibel, can yoou use CODE tags around your posted compter texts and not QUOTE tags? It is the # button in the tool bar of the post editor.

I will, hcvv. Thank you.

So, today I discovered that the connection gets further when I locate myself with the laptop in front of the house. It’s a bit of a rural area here, where UMTS is not so well accessable behind walls of stone.

  1. I’m outside. I insert the stick.
  2. modprobe usbserial vendor=0x1c9e product=0x9605
  3. usb_modeswitch -c /etc/usb_modeswitch.d/1c9e:9605

i get:

Looking for target devices ...
   found matching product ID
   adding device
 Found devices in target mode or class (1)
Looking for default devices ...
   found matching product ID
   adding device
 Found device in default mode, class or configuration (1)
Accessing device 008 on bus 001 ...
Getting the current device configuration ...
 OK, got current device configuration (1)
Using interface number 0
Error: can't use storage command in MessageContent with interface 0;
       interface class is 255, should be 8. Aborting.

nonetheless the Network Broadband appears in the panel.

  1. trying to start connection

  2. during that process /var/log/messages report: http://paste.opensuse.org/77921546

The connection terminates 20 secs after CHAP authentication succeeds.

Is this still an issue of wrong login data? I found the settings on the 1und1 site. It states that no user and pw are needed.

Or still too bad UMTS connection in my village? At least it gets that far. I tried multiple times. It always ends that way.

No, the credentials are likely to be correct or else the CHAP authentication would not succeed…


2014-07-08T13:04:04.947803+02:00 linux-z7bd pppd[2333]: Connect: ppp0 <--> /dev/ttyUSB3
2014-07-08T13:04:04.973545+02:00 linux-z7bd pppd[2333]: CHAP authentication succeeded
2014-07-08T13:04:04.978840+02:00 linux-z7bd pppd[2333]: CHAP authentication succeeded
2014-07-08T13:04:25.307054+02:00 linux-z7bd pppd[2333]: Terminating on signal 15
2014-07-08T13:04:25.310037+02:00 linux-z7bd ModemManager[545]: <info>  Modem
/org/freedesktop/ModemManager1/Modem/3: state changed (connected -> disconnecting)
2014-07-08T13:04:25.318784+02:00 linux-z7bd pppd[2333]: Connection terminated.

Or still too bad UMTS connection in my village? At least it gets that far. I tried multiple times. It always ends that way.

It may be the case that the signal level is insufficient. For marginal areas, a 3G router with external antenna may perform better. If practical, try testing nearer the cell tower, or wherever the signal is known to be stronger. Using a mobile phone can be helpful to determining the signal strength at a given location.

Yeah. I’m in the nearby town right now and the stick works :slight_smile:

Thank you for your assistance.

Glad to have been of help. :slight_smile: