Problems with Samba

I am having problems with porting windows forms apps (C#) to Linux using Mono. The related webpage is as follows:
Guide: P…s Applications - Mono

According to this webpage, I should have installed Mono 1.2.4 on openSUSE 10.2 VMWare image but this package is not available anymore so I had to install openSUSE 11.2 VMWare image which includes Mono 2.6.4.

I successfully installed it as mentioned on the related guide. The other steps are as follows:

  1. Right click the desktop, choose Create Directory, name the directory NClass.
    I did this without any problem.

  2. Click the “Computer” menu in the bottom left, choose Control Center.
    I did this without any problem.

  3. Choose “YaST” at the bottom, the password is “mono”.
    I did this without any problem.

  4. Choose “Network Services”, then “Samba Server”.
    After choosing “Network Services”, there is no “Samba Server” available in the list.

Then I went to software > software manager >network groups, I could see Samba and samba-client among the list of installed packages. So, this means that samba is already installed on the system.
Why can not I see it by opening “Network Services”???

I am very new to Linux and my information is very primitive. I tried to read one of your answers on the web exactly in relation to this problem and tried to follow the steps but I could not succeed.

I also ran this command (rpm -qa | grep samba) as you suggested and the results are as follows:


By the way, I am using GNOME. After the above step you suggest to install the apps yast2-samba-server and yast2-samba-client. I went to Yast and then software manger and I got this error:

There was an error in the repository initialization.
‘openSUSE_11.2_Updates’: Index of /update/11.2
[openSUSE_11.2_Updates|] Repository is not cached

Also by using software repositories, ADD > specify URL > putting the related URL for samba, again I got errors.
I have been struggling with these issues since one week ago and actually I lost a full week without any outcome. I would be very grateful if you do me a favor and give me some help.

Thank you very much in advance

Best regards,

No matter how you are trying to run Samba, there are a few things that must happen. Services need to be started, which may be your problem. Ports need to be opened in the firewall, configuration data files need to be created or edited, and certain program files in addition to Samba needs to be loaded, no matter if a real or virtual session. I suggest you read through a Samba tutorial I have written to see if any of the issues I mention above might be your problem.

Samba SMB file sharing in openSUSE 11.2 - openSUSE Forums

Thank You,