Problems with Samba only on OpenSuSE

Do a text only installation and you will have a very stable “computer room” system (what MS oriented people will call a “server”). You can of course add X and a simple desktop (or even Gnome or KDE) if you prefer that for your management tasks. That will not influence the “server” capability in a negative way by any means.

And do not go for hearsay, search for the facts. Ask those that say it, why they say so. Maybe we then can either admit that they have a point or argue against them. But we can not say anything usefull on “hearsay”. Just as on your rhetorical question earlier.

What does

systemctl status smb.service


What might be an issue, is that the networking starts too late, and the samba processes don’t detect the network. I had an issue with NFS not starting when using systemd, setting the network device to start “At boot” instead of “At cable connection” got it working. Now the network is there when NFS starts. Could this be something similar?

my installation is only text based. I didn’t feel it necessary to have a GUI as most of the time I’m accessing it through the ssh & terminal on my mac.
So I have installed only the minimal server (text based) & the file server package with samba and ntfs-3g
That is about it.

I guess I’m just hung up on how excited I am about openSUSE 12.3. The RC is gorgeous and well polished. I think it’s the best distro (and release candidate) I’ve ever tried and I wanted it to be perfect. But alas, It’s only a RC. Sigh I’ll admit fault there. I guess I’ll just install 12.2 XFCE and work with that. It’s just hard to wait another 4 weeks for the final release of 12.3.

I feel that OpenSUSE is a more polished distro. I know that Debian has the largest following and that Ubuntu gives sense that its easier to use, but from the looks, OpenSUSE is a free distro that looks like something u pay for. As a linux desktop, I’d take nothing else.
Sure apt-get is easier, but I can’t think of a distro without Yast.
Now for a server situation, I too cannot think of anything easier to setup that OpenSUSE. In truth, being a linux newbie, I tried to setup the file server using Debian and even though it is said to be the best distro for a server, I found it harder. Editing text files and stuff makes it hard. Yast is so much more easier.

The problem is that in general opinion, OpenSUSE doesn’t get the best rep for being stable. I’d have to say that with my problems with it, I’m on the fence.

I think you are going off topic here. This is in a forum about technical problems/questions. When you want to discuss the pros and cons of different distributions, please do so in the Soapbox section.

And when you do not even bother to answer e.g. Knurpht’s technical question, applicable to your problem, he (and others) will soon lose all interest ion helping you.

Yast > Network Services> Samba Server> Start Up. I always set mine to ‘At Boot’. This is because I’ve set the server box without a keyboard and monitor attached. For administration, I have the ssh enabled during the installation. After the installation is complete and working, I reboot the system and remove the monitor and keyboard.

As for the server not being able to be seen by the other computers, I think I have narrowed the problem down to my DHCP & router.
I used to have a static IP set on the server & that made it easy so that no matter how many times the thing rebooted the IP address stayed the same. I kept it outside the DHCP pool. While the clients got addresses & above, the server was getting an address that was It worked, but wasn’t able to connect to the internet for updates; even though the Gateway & DNS was correct. So I switched it back to DHCP and had the router reserve an address for the server to make sure it stayed the same on every reboot.
I think my router was acting up on the reservation. The funny thing was that even though I couldn’t see or browse the server on Win7 client, my mac was able to connect to it via ssh.
Now ofcourse, it just started working after a reboot; didn’t change a setting.

You are kidding?
Where is the output of the statement Knurpht asked for?

Sorry… I forgot that…

smb.service - LSB: Samba SMB/CIFS file and print server      Loaded: loaded (/etc/init.d/smb)
      Active: active (running) since Mon, 11 Feb 2013 16:04:10 +0400; 1 day and 1h ago
     Process: 6243 ExecReload=/etc/init.d/smb reload (code=exited, status=0/SUCCESS)
     Process: 3045 ExecStart=/etc/init.d/smb start (code=exited, status=0/SUCCESS)
      CGroup: name=systemd:/system/smb.service
          ├ 3067 /usr/sbin/smbd -D -s /etc/samba/smb.conf
          ├ 3085 /usr/sbin/smbd -D -s /etc/samba/smb.conf
          ├ 3844 /usr/sbin/smbd -D -s /etc/samba/smb.conf
          └ 5757 /usr/sbin/smbd -D -s /etc/samba/smb.conf

Feb 12 17:25:38 DATAHUB smbd[3067]: [2013/02/12 17:25:38.000903,  0] printi...k)
Feb 12 17:25:38 DATAHUB smbd[3067]: failed to retrieve printer list: NT_STA...UL
Feb 12 17:38:38 DATAHUB smbd[6383]: [2013/02/12 17:38:38.766464,  0] printi...t)
Feb 12 17:38:38 DATAHUB smbd[6383]: Unable to connect to CUPS server localh...ed
Feb 12 17:38:38 DATAHUB smbd[3067]: [2013/02/12 17:38:38.769342,  0] printi...k)
Feb 12 17:38:38 DATAHUB smbd[3067]: failed to retrieve printer list: NT_STA...UL
Feb 12 17:51:39 DATAHUB smbd[6405]: [2013/02/12 17:51:39.547800,  0] printi...t)
Feb 12 17:51:39 DATAHUB smbd[6405]: Unable to connect to CUPS server localh...ed
Feb 12 17:51:39 DATAHUB smbd[3067]: [2013/02/12 17:51:39.550899,  0] printi...k)
Feb 12 17:51:39 DATAHUB smbd[3067]: failed to retrieve printer list: NT_STA...UL

Its working now… So I don’t know if you can manage to get what you need from it.