problems with samba and smb4k in openSUSE 12.3 64 bit

The problems are:

1 - if I enable network manager I can browse the internet but can not access the network neighborhood machines because the smb and nmb are not running, this only happen whe using network manager, if I use ifup there is not problem

2 - if I try to mount a samba share via smb4k (when using ifup because samba + network manager is not working) it always promt for the root password, I have tried this Smb4K / Discussion / General Discussion:Root’s password required every (u-) mount it worked with 12.2 64 bit but not with 12.3 64 bit

this are very important issues to me because this are functions for my daily use at work

thanks

Everything you need to do is included in the following bash script:

S.A.C.T. - Samba Automated Configuration Tool - Version 1.02 - Blogs - openSUSE Forums

This works fine with Network Manager and no need to use Smb4K. If you really want Samba to work, please follow my advice, download version 1.02 and use the sact bash script and read through the entire blog report.

Thank You,

I have tried the tool, but the problem still persist, I can start the services with the SACT tool but if I restart the pc the problem is there again, having to restart the services with every reboot is not an option, please note that this is only when network manager is in use, the problematic service is nmb, if I use the tool to check the services status right after a reboot, smb is running but nmb is not, I even used the option 9 of the SACT tool but nothing, I need networkmanager to set up wireless networks.

no need to use Smb4K

Using the smb4k tool is the easiest way to let the users to mount there samba shares, that is way I use it, a coupe of clicks and the shares are mounted and ready to use, but I am having the root password problem

this is the output of option of the SACT tool

nmb.service - LSB: Samba NetBIOS naming service over IP
Loaded: loaded (/etc/init.d/nmb)
Active: inactive (dead) since Thu, 2013-03-14 23:49:21 CST; 2min 55s ago
Process: 564 ExecStop=/etc/init.d/nmb stop (code=exited, status=0/SUCCESS)
Process: 498 ExecStart=/etc/init.d/nmb start (code=exited, status=0/SUCCESS)
CGroup: name=systemd:/system/nmb.service

smb.service - LSB: Samba SMB/CIFS file and print server
Loaded: loaded (/etc/init.d/smb)
Active: active (running) since Thu, 2013-03-14 23:49:22 CST; 2min 54s ago
Process: 552 ExecStart=/etc/init.d/smb start (code=exited, status=0/SUCCESS)
CGroup: name=systemd:/system/smb.service
├ 611 /usr/sbin/smbd -D -s /etc/samba/smb.conf
└ 659 /usr/sbin/smbd -D -s /etc/samba/smb.conf

Press Any Key to Continue …

Please post the contents of your /etc/samba/smb.conf file placed between code # tags using the advanced forum message editor. Please do the same for the smb & nmb service status when it does not work and again if it ever works. Using the SMB desktop (smb://workgroup/) icon, can you see any other computers on your network, this requires only smb to be working.

Thank You,

On 3/14/2013 5:46 PM, Easgs wrote:
>
> The problems are:
>
> 1 - if I enable network manager I can browse the internet but can not
> access the network neighborhood machines because the smb and nmb are not
> running, this only happen whe using network manager, if I use ifup there
> is not problem
>
> 2 - if I try to mount a samba share via smb4k (when using ifup because
> samba + network manager is not working) it always promt for the root
> password, I have tried this ‘Smb4K / Discussion / General
> Discussion:Root’s password required every (u-) mount’
> (http://sourceforge.net/p/smb4k/discussion/general/thread/ddd509ca/) it
> worked with 12.2 64 bit but not with 12.3 64 bit
>
> this are very important issues to me because this are functions for my
> daily use at work
>
> thanks
>
>
Easgs;

Let me say at the outset that I do not regularly use NetworkManager. As everything works with ifup, it sounds to me
that when your system starts, NetwortManager has not yet brought up the network interface. Thus smb and nmb die. Have
you set your connection to be a “system connection”? I’ve been led to believe that, if your connection is not set as a
system connection, NM does not bring up the interface until someone logs in. this is too late for nmb and smb. I’m
sure if this is wrong it will be corrected. See:

http://doc.opensuse.org/documentation/html/openSUSE/opensuse-reference/cha.nm.html

As for smb4k, you can browse samba shares from a browser without smb4k and/or you can use mount.cifs. For help with a
cifs mount, see: http://www.swerdna.net.au/susesambacifs.html


P.V.
“We’re all in this together, I’m pulling for you” Red Green

if your connection is not set as a
system connection, NM does not bring up the interface until someone logs in. this is too late for nmb and smb. I’m
sure if this is wrong it will be corrected.

I unchecked the system connection option and it is working now, but I still have the problem with smb4k, I use smb4k because you can create bookmarks to the shares, and you can mount them only when you need them, and the bookmarks are user customizables, I want the user to be able to mount users without the need of the root password, or browsing the network neighbourhood, it was working with versio 12.2 64 bit, I can use the mount command and even have this [SOLVED] advanced shell script for mount and unmount samba share / Networking, Server, and Protection / Arch Linux Forums script but you need to use the command line and need the root password, which is not user friendly, I don’t want to have to edit the fstab file for every mobile share, I want the users to be able to mount the shares via bookmarks in the smb4k tray icon without root password, as a said before it was working in 12.2 via Smb4K / Discussion / General Discussion:Root’s password required every (u-) mount but it is not working anymore.

I think the SACT tool is excelent and I would be good if it is included in the installation media in future openSUSE releases.

On 3/15/2013 11:46 AM, Easgs wrote:
>
<snip>
>
> I unchecked the -system connection- option and it is working now, but I
> still have the problem with smb4k, I use smb4k because you can create
> bookmarks to the shares, and you can mount them only when you need them,
> and the bookmarks are user customizables, I want the user to be able to
> mount users without the need of the root password, or browsing the
> network neighbourhood, it was working with versio 12.2 64 bit, I can use
> the mount command and even have this
<snip>
>
Easgs;

Have you looked at /etc/sudoers and man sudoers? You should be able to give the users the ability to run smb4k without
knowing root’s password.


P.V.
“We’re all in this together, I’m pulling for you” Red Green

First, thanks for the very kind words on SACT. I accept and request any comments and suggestion be placed into my blog for S.A.C.T. here.

May I say that my way of dealing with on demand “mounts”, is not really a mount at all, but a link to a share, controlled by another user. For instance, to use a share on the PC called linuxuser from the user james, I can create a link that just says: smb://linuxuser/james, but the same thing works for a common share, not controlled by a user and set to not be browsable and instead of a username, its a share name like: smb://linuxuser/Windows and in kde, a link can be made on the desktop of in the menu system. For the desktop, you can create a text file saved at $HOME/Desktop/LinuxUser that says:

[Desktop Entry]
Icon=network-workgroup
Type=Link
URL$e]=smb://linuxuser/james
X-SuSE-translate=true

Now as always, if something does not work in openSUSE 12.3, a bug report should be made about the problem here: Bugzilla Main Page

Thank You,

This one did the trick, this is the final text file

 [Desktop Entry]
Icon=network-workgroup
Type=Link
URL$e]=smb://eduardo@linux-aw8a/Documentos/
X-SuSE-translate=true

just one question, what is the difference between using this file and using this command

mount -t cifs -o username=name, password=somepass //linux-aw8a/Documentos /home/user/somepoint

technical speaking

thank

The first is an on demand mount. I prefer using this method as the mount is temporary. There is a system speed loss for any network mount you make permanent and it can slow any network process. How much? If you have a fast and trouble free network, it may not be by much, but in every case, using an on demand mount will keep your system faster until you need the mount. Close the file manager and the temporary mount is gone, but you can bring it up anytime you want.

Thank You,

Check this out, hope it helps:

Using Smb4K on openSUSE 12.3 without password prompt

/Gunnar

Tested and working great

I added the lines

de.berlios.smb4k.mounthelper.mount auth_admin:auth_admin:yes
de.berlios.smb4k.mounthelper.unmount auth_admin:auth_admin:yes

to the file /etc/polkit-default-privs.local

and installed the privileges to the system with the command

/sbin/set_polkit_default_privs

and now it doesn’t ask for root password in opensuse 12.3 64 bit, thanks a lot for the link

Glad it worked and thanks for the note about set_polkit_default_privs. I forgot to mention that and have now updated the article.