Problems with Printer Brother MFC-7320 on openSUSE Tumblweed x64

Hi beautiful community,

I’ve recently introduced to a friend of mine this powerful distro with all the advantages that have. He’s at the beginning of a good learning curve and the future looks promising. Recently, and remotely, we can’t figure out how to solve a peculiar issue in configuring the printer via Yast Control Center. It is a Brother model MFC 7320, via USB. He installed those proprietary drivers - Downloads | MFC-7320 | Others | Brother - (LPR, CUPS for the print and the scanner driver)

Initially, the printer is available under Hardware > Printer: but the printing test won’t even start. The scanner, figured as “brother3” is available but won’t cooperate either. I didn’t felt to mess up with the additional options in order to don’t create, eventually, even more mess :slight_smile:

The PC is a Lenovo Z50-70, 16Gb of RAM, CPU Intel i74110U with Mesa Intel HD Graphics 4400.
Desktop KDE 5.27.8
Frameworks 5.110.0
Version qt 5.15.10
Kernel 6.5.4-1 default
Session X11

Hope to be helpful with the info provided, cheers. :green_heart:

They don’t mention it on the Brother website, but two additional libraries are needed for the printer to work properly.
sudo zypper in glibc-32bit libusb-0_1-4-32bit


Thanks a lot mate, the printer is working now, the scanner is still in trouble.

For that show us what is reported by

scanimage -L

If nothing is detected, check if the local machine’s firewall is active with

systemctl status firewalld

It can be stopped temporarily with

sudo systemctl stop firewalld

Then run the scanimage command again and report back.

1 Like

Hi Deano,

After the first scanimage -L we reported this:

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
localhost:/home/raffaele #

Then, after systemctl status firewalld

localhost:/home/raffaele # systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; preset: disabled)
Active: active (running) since Mon 2023-10-02 19:13:07 CEST; 2h 57min ago
Docs: man:firewalld(1)
Main PID: 1065 (firewalld)
Tasks: 2 (limit: 4915)
CPU: 704ms
CGroup: /system.slice/firewalld.service
└─1065 /usr/bin/python3 /usr/sbin/firewalld --nofork --nopid

Oct 02 19:13:03 localhost systemd[1]: Starting firewalld - dynamic firewall daemon…
Oct 02 19:13:07 localhost systemd[1]: Started firewalld - dynamic firewall daemon.

We also tried to stop the firewall with the suggested command, run scanimage -L again but we got the same message above.

I forgot this is a USB connected device and not on the local network. It should have been detected. Check that “brother3” is present in dll.conf…

grep "br" /etc/sane.d/dll.conf
1 Like

If that checks out, it may be that you need to add a suitable udev rule to match with the scanner device eg /etc/udev/rules.d/40-brother.rules

# Brother
ATTR{idVendor}=="04f9", MODE="0664", GROUP="lp", ENV{libsane_matched}="yes"

After adding the rule, it will take effect the next time the scanner is plugged in. Check that the scanner is then found with scanimage (or your favourite scanning application).


Hi, it reports back:

localhost:/home/raffaele # grep “br” /etc/sane.d/dll.conf
localhost:/home/raffaele #

Did I have to go in Dolphin manager (super user mode) and manually insert the rule in etc/udev/rules.d/40-brother.rules ?

The brscan3 package installation should have added the requisite entry in dll.conf. You can try adding it manually I guess.

The udev rule can be created with your favourite editor with root privileges.

1 Like

we can’t save the dll.conf even under admin privileges (dolphin) we tried to reinstall the .rpm scan (2 and 3) packages and the scanner list only shows brother2 but the document scan app doesn’t load any scanner.

The brscan3 package (as per your opening post link) is the correct one. Use a terminal editor (eg nano) like this

sudo nano /etc/sane.d/dll.conf

Navigate to the end and add ‘brother3’, then exit with CTRL-X (it will ask if you want to save at that time).


I can confirm this solution from my Brother MFC-7360N:

(editing /etc/udev/rules.d/55-libsane.rules and installing glibc-32bit)